Opened 15 years ago

Closed 12 years ago

#213 closed defect (worksforme)

Encoding from multiple input image files: Collects just around 1700 out of 17000 *.jpg

Reported by: Raphael.Becker@… Owned by: alex@…
Priority: normal Component: core
Version: 1.0pre5 Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

I have: directory with about 17,000 jpg-files, 640x480 (snapshots from a still
camera).
I want: a 10 fps mpeg4 Video from is.
See also: http://www.mplayerhq.hu/DOCS/HTML/en/menc-feat-enc-images.html

Commandline: mencoder -v mf://*.jpg -mf w=640:h=480:fps=10:type=jpg -o
../mshvolcanocam_2.avi -ovc lavc -lavcopts vcodec=mpeg4

It works fine for the first ca 1700 frames (jpg). After that, the AVI gets
finished and closed. Everything works fine. AVI is not corrupt, no error
messages. Just missing thousands of frames.

I guess it it about "too many arguments" by expanding "mf://*.jpg", something
similar to the following by an internal system-call:
$ ls frames/*.jpg
bash: /bin/ls: Argument list too long
$ find frames/ -name "*.jpg" | wc -l

19692

I've recorded a transcript of mencoder, you may download it from my website:
http://rabe.uugrn.org/temp/mplayer/mencoder.out

Again: no visible errors, just missing frames 1743 to end.

Workaround: no idea.

Thank you for reading this report.
Raphael Becker

PS: Sorry, I'm not sure about which component of mplayer is involved or
affected, so I've chosen "core". Please drop me a note and/or forward this
report to the particular recipient.

Change History (4)

comment:1 Changed 15 years ago by Raphael.Becker@…

Well, mplayer works pretty fine here, no crashes. Anyway, you might be
interested in some system details as described in "Appendix B. How to report
bugs". Here we go:

# uname -a
FreeBSD daemon.local.net 5.3-STABLE FreeBSD 5.3-STABLE #3: Sun Jan 16 23:37:17
CET 2005 root@…:/usr/obj/usr/src/sys/DAEMON i386

(5-STABLE sources and ports of 2005-01-16, everything updated)

# ls -l /lib/libc*
-r--r--r-- 1 root wheel 883640 Jan 17 01:20 /lib/libc.so.5

# gcc -v
Using built-in specs.
Configured with: FreeBSD/i386 system compiler
Thread model: posix
gcc version 3.4.2 [FreeBSD] 20040728

# ld -v
GNU ld version 2.15 [FreeBSD] 2004-05-23

# as --version
GNU assembler 2.15 [FreeBSD] 2004-05-23
Copyright 2002 Free Software Foundation, Inc.
This program is free software; you may redistribute it under the terms of
the GNU General Public License. This program has absolutely no warranty.
This assembler was configured for a target of `i386-obrien-freebsd'.

# pkg_info | grep xorg
xorg-6.8.1 X.Org distribution metaport

CPU-Info from dmesg:
CPU: Intel(R) Pentium(R) 4 CPU 2.40GHz (2405.46-MHz 686-class CPU)

Origin = "GenuineIntel?" Id = 0xf27 Stepping = 7


Features=0xbfebfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH,DTS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE>
real memory = 1073676288 (1023 MB)
avail memory = 1036918784 (988 MB)
ACPI APIC Table: <AMIINT INTEL845>
ioapic0 <Version 2.0> irqs 0-23 on motherboard

comment:2 Changed 13 years ago by reimar

Old bug, but: some JPEG files can not be decoded with ffmjpeg decoder, -vc ijpg
is supposed to help in some cases. No other ideas though.

comment:3 Changed 12 years ago by compn

workaround might be mf://@filelist.txt
where filelist.txt is one image filename per line ...

comment:4 Changed 12 years ago by Raphael.Becker@…

  • Resolution set to worksforme
  • Status changed from new to closed

Seems to work with a newer Version.

$ find frames/2007/04/ | wc -l

8391

OPTS="-mf w=640:h=480:fps=10:type=jpg -ovc lavc -lavcopts vcodec=mjpeg:mbd=1:vbitrate=180 -oac copy"

YYYY=2007
MPEG_DIR="mpeg/${YYYY}/"
mkdir -p ${MPEG_DIR}
for MM in 01 02 03 04; do

mencoder "mf://frames/${YYYY}/${MM}/${YYYY}${MM}*.jpg" ${OPTS} -o ${MPEG_DIR}/${YYYY}-${MM}.mpeg

done

Bug may be closed, works for me now.

Note: See TracTickets for help on using tickets.