Opened 6 years ago

Closed 6 years ago

#2131 closed defect (invalid)

Mplayer hangs trying to play short ogg file (in terminal)

Reported by: sergey@… Owned by: reimar
Priority: normal Component: ao
Version: unspecified Severity: major
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

I tried to run mplayer in terminal on .ogg file:

# mplayer /usr/share/sounds/gnome/default/alerts/drip.ogg

and got this:

# ----------------------------------------------------

MPlayer2 UNKNOWN (C) 2000-2012 MPlayer Team
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing /usr/share/sounds/gnome/default/alerts/drip.ogg.
Detected file format: Ogg (libavformat)
[lavf] stream 0: audio (vorbis), -aid 0
Load subtitles in /usr/share/sounds/gnome/default/alerts/
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 44100 Hz, 2 ch, s16le, 192.0 kbit/13.61% (ratio: 24000->176400)
Selected audio codec: [ffvorbis] afm: ffmpeg (FFmpeg Vorbis)
==========================================================================
AO: [pulse] 44100Hz 2ch s16le (2 bytes per sample)
Video: no video
Starting playback...
A: 0.0 (00.0) of 0.1 (00.1) ??,?%

# -----------------------------------------------------

MPlayer just hanged while trying to play this .ogg.
But when I feed it with relatively long song it plays it, it's ok.

Other players (not in terminal) can play this file.

Linux 3.5.0-25-generic #39-Ubuntu SMP Mon Feb 25 18:26:58 UTC 2013 x86_64 GNU/Linux

Attachments (1)

drip.ogg (8.3 KB) - added by sergey@… 6 years ago.
Ubuntu system sound - drip.ogg

Download all attachments as: .zip

Change History (2)

Changed 6 years ago by sergey@…

Ubuntu system sound - drip.ogg

comment:1 Changed 6 years ago by reimar

  • Resolution set to invalid
  • Status changed from new to closed

MPlayer2 is a fork of MPlayer, we have nothing to do with it.
I tried it locally with MPlayer and it did not hang, though it did not output any sound either with -ao pulse, -ao alsa worked better - which might hint at that this might be an issue with PulseAudio?.
But either way, if you want us to look into it please try with MPlayer, not MPlayer2.

Note: See TracTickets for help on using tickets.