Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#2133 closed defect (fixed)

WNYU stream squeeks with mplayer, ok with iTunes

Reported by: nixon8890@… Owned by: reimar
Priority: normal Component: ad
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

URL = http://cinema.acs.its.nyu.edu:8000/wnyu128.mp3

Tried "mplayer" from the command line, which was compiled with mac ports. It does play the stream, however encounters the squeaks during these periods of log output:

mp3float @ 0x10b7cd520]big_values too big
[mp3float @ 0x10b7cd520]Error while decoding MPEG audio frame.
A: 35.9 (35.8) of -0.0 (unknown) 0.2% 14%
[mp3float @ 0x10b7cd520]overread, skip -6 enddists: -2 -2
[mp3float @ 0x10b7cd520]overread, skip -4 enddists: -1 -1
A: 38.9 (38.9) of -0.0 (unknown) 0.2% 14%
[mp3float @ 0x10b7cd520]overread, skip -5 enddists: -1 -1
A: 42.0 (42.0) of -0.0 (unknown) 0.2% 15%
[mp3float @ 0x10b7cd520]overread, skip -5 enddists: -2 -2
A: 43.5 (43.5) of -0.0 (unknown) 0.2% 14%
[mp3float @ 0x10b7cd520]big_values too big
[mp3float @ 0x10b7cd520]Error while decoding MPEG audio frame.
A: 43.6 (43.5) of -0.0 (unknown) 0.2% 14%
[mp3float @ 0x10b7cd520]overread, skip -4 enddists: -3 -3
[mp3float @ 0x10b7cd520]overread, skip -5 enddists: -3 -3
A: 46.6 (46.6) of -0.0 (unknown) 0.2% 14%
[mp3float @ 0x10b7cd520]overread, skip -5 enddists: -3 -3
A: 46.6 (46.6) of -0.0 (unknown) 0.2% 14%
[mp3float @ 0x10b7cd520]overread, skip -7 enddists: -4 -4
A: 48.2 (48.1) of -0.0 (unknown) 0.2% 14%
[mp3float @ 0x10b7cd520]overread, skip -5 enddists: -1 -1
[mp3float @ 0x10b7cd520]overread, skip -6 enddists: -2 -2
A: 49.7 (49.6) of -0.0 (unknown) 0.2% 15%

Each squeak appears to instantaneously match up with the "skip" and "enddists" debug output lines. Perhaps a codec issue in mplayer because iTunes handles the same stream network location perfectly.

[np@:bin] ./mplayer --version
Unknown option on the command line: --version
Error parsing option on the command line: --version
MPlayer UNKNOWN-4.2.1 (C) 2000-2012 MPlayer Team
198 audio & 412 video codecs

Change History (3)

comment:1 Changed 6 years ago by reimar

  • Resolution set to fixed
  • Status changed from new to closed

This server is completely broken.
When (like MPlayer) you send a HTTP-request with Icy-MetaInt? you get a response that contains a MP3 header in the HTTP header!! I'm fairly certain that non-ASCII isn't allowed in there.
If you send a header without Icy-MetaInt? (by replacing http:// by noicyx://) the server does not answer at all (at least not with the specific header fields MPlayer uses).
I added a workaround in r35987, but this server is really, really broken.

comment:2 Changed 6 years ago by reimar

They seem to be running QTSS 6.1.0.
As far as I can tell 6.1.1 was released in 2003.
This means this is 10 year old software, directly exposed to the internet, if you know these people you should very much ask them if they know what they are doing and if they really want to take that kind of risk, having a server that obviously hasn't had security updates in ages directly accessible from the whole world.

comment:3 Changed 6 years ago by nixon8890@…

Sent note to Net Audio contact for WNYU. Thanks for adding a workaround.

Note: See TracTickets for help on using tickets.