Opened 7 years ago

Closed 7 years ago

#2135 closed defect (fixed)

crash on change of aspect (mpeg-ts)

Reported by: tegularius@… Owned by: reimar
Priority: normal Component: vd
Version: HEAD Severity: normal
Keywords: Cc: tegularius@…
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

When I am watching dvb-t (mpeg-ts), mplayer crashes when the programme changes the aspect-ratio in the stream. This worked for some time, maybe since about 2-3 months ago, at least until December 2012. I am sorry for this rough estimate.

I am using HEAD with latest pull for ffmpeg.

I have attached a backtrace and commandline output for one file shows the behaviour.

I used the mpeg-file from a bugreport of mplayer2 which had a similar problem but seems to be hardly related to that bug:
http://devel.mplayer2.org/attachment/ticket/157/cr.mpg

Attachments (2)

mplayer_bugreport (6.6 KB) - added by tegularius@… 7 years ago.
backtrace
cr.mpg (367.0 KB) - added by reimar 7 years ago.
Testcase file

Download all attachments as: .zip

Change History (5)

Changed 7 years ago by tegularius@…

backtrace

comment:1 Changed 7 years ago by tegularius@…

  • Cc tegularius@… added

Changed 7 years ago by reimar

Testcase file

comment:2 Changed 7 years ago by reimar

This looks like an FFmpeg bug, it calls the draw_slice function with an invalid frame.

comment:3 Changed 7 years ago by reimar

  • Resolution set to fixed
  • Status changed from new to closed

I am not 100% sure what the exact chain of events was that caused this issue, but it seems to be fixed in SVN r36169.

Note: See TracTickets for help on using tickets.