Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#2141 closed defect (fixed)

Cannot test OS support for SSE, disabling to be safe

Reported by: nucleo@… Owned by: reimar
Priority: normal Component: core
Version: unspecified Severity: normal
Keywords: Cc: belegdol+mplayer@…
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

There is error message "Cannot test OS support for SSE, disabling to be safe. when starting mplayer and mencoder in Fedora 19.

Version: mplayer-1.1-7.20130416svn.fc19.i686

MPlayer SVN-r36171-4.8.0 (C) 2000-2013 MPlayer Team

cpuinfo flags:

fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc arch_perfmon pebs bts aperfmperf pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm lahf_lm dtherm tpr_shadow

Attachments (1)

mplayer.patch (1.5 KB) - added by nucleo@… 6 years ago.
final patch

Download all attachments as: .zip

Change History (7)

comment:1 Changed 6 years ago by belegdol+mplayer@…

  • Cc belegdol+mplayer@… added

comment:2 Changed 6 years ago by reimar

The compiler used doesn't seem to define the stuff we expect it to.
Can you try with SVN r36299 and see if that fixes it?

comment:3 Changed 6 years ago by nucleo@…

After applying patch r36299 build failed:

cpudetect.c: In function 'check_os_katmai_support':
cpudetect.c:186:31: error: 'sigill_handler_sse' undeclared (first use in this function)

signal( SIGILL, (void (*)(int))sigill_handler_sse );


cpudetect.c:186:31: note: each undeclared identifier is reported only once for each function it appears in
make: * [cpudetect.o] Error 1

comment:4 Changed 6 years ago by nucleo@…

compiler version:
gcc version 4.8.0 20130526 (Red Hat 4.8.0-8) (GCC)

comment:5 Changed 6 years ago by reimar

  • Resolution set to fixed
  • Status changed from new to closed

Well, on the positive side that means I correctly identified the cause.
r36300 should hopefully work for real.

Changed 6 years ago by nucleo@…

final patch

comment:6 Changed 6 years ago by nucleo@…

Thanks, last commit fixes build and CPU detection.

MPlayer SVN-r36171-4.8.0 (C) 2000-2013 MPlayer Team
CPU vendor name: GenuineIntel? max cpuid level: 10
CPU: Intel(R) Core(TM)2 CPU 6300 @ 1.86GHz (Family: 6, Model: 15, Stepping: 6)
extended cpuid-level: 8
extended cache-info: 134242368
Detected cache-line size is 64 bytes
Testing OS support for SSE... yes.
Tests of OS support for SSE passed.
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNowExt: 0 SSE: 1 SSE2: 1 SSE3: 1 SSSE3: 1 SSE4: 0 SSE4.2: 0 AVX: 0
Compiled with runtime CPU detection.

Note: See TracTickets for help on using tickets.