Opened 4 years ago

Closed 4 years ago

#2148 closed defect (worksforme)

mplayer crashes when exiting fullscreen

Reported by: andysem@… Owned by: reimar
Priority: normal Component: vo
Version: unspecified Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: no Analyzed by developer: no

Description (last modified by reimar)

I'm using mplayer with smplayer frontend on Kubuntu (KDE 4.10.5). I sometimes observe mplayer crashes when exiting fullscreen mode. I.e. I can start video playback, enter fullscreen mode, then exit it or simply close mplayer and then mplayer crashes. This only happens when I set to suspend compositing in fullscreen windows in KDE system settings. It doesn't happen when compositing is always enabled.

I'm using MPlayer svn r34540 (Ubuntu), built with gcc-4.7 from Kubuntu 13.04, but I also had this problem with previous releases of Kubuntu and openSUSE and older mplayer versions. In fact, I've always had this problem and I can't remember any particular version not affected by this. I'm using proprietary Nvidia drivers (currently 319.32, the problem also showed with other versions), mplayer is setup to use VDPAU for decoding acceleration. I have two displays attached, which are configured in TwinView? mode.

Change History (3)

comment:1 Changed 4 years ago by reimar

I think our chances of reproducing and fixing this are bad, so you really should try getting either a gdb backtrace or a valgrind log from a debug build.
valgrind might be easier, since gdb in such cases usually ends with a non-removable, fullscreen MPlayer window, which makes things challenging...
I have two guesses:

  • VDPAU has issues with switching to composited
  • That switch probably involves re-initializing the VDPAU state, and that code is not well tested and might cause issues.

comment:2 Changed 4 years ago by andysem@…

I'll try what I can, but it may take time.

comment:3 Changed 4 years ago by reimar

  • Analyzed by developer unset
  • Description modified (diff)
  • Reproduced by developer unset
  • Resolution set to worksforme
  • Status changed from new to closed

I am using KDE myself (though the latest version) and I cannot reproduce the issue with VDPAU using the OpenSource? AMD VDPAU implementation.
I did not see any obvious issue with the code either.
So I am closing it until someone can provide additional information, since I do not see what more we could do for the moment.

Note: See TracTickets for help on using tickets.