Opened 5 years ago

Closed 4 years ago

#2206 closed defect (fixed)

Mplayer from today's SVN cannot play an x265 encoded file

Reported by: birdie Owned by:
Priority: highest Component: core
Version: HEAD Severity: blocker
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: yes Analyzed by developer: no

Description

MPlayer SVN-r37278-4.7.4 (C) 2000-2014 MPlayer Team
210 audio & 441 video codecs

ffplay 2.3 and 2.4 play it just fine.

Attachments (1)

out.mkv (963.7 KB) - added by birdie 5 years ago.

Download all attachments as: .zip

Change History (7)

Changed 5 years ago by birdie

comment:1 Changed 5 years ago by beastd

  • Resolution set to fixed
  • Status changed from new to closed

Fixed by Reimar in SVN r37297

comment:2 Changed 5 years ago by beastd

  • Reproduced by developer set

comment:3 follow-up: Changed 5 years ago by birdie

  • Resolution fixed deleted
  • Status changed from closed to reopened

This bug is not really fixed (-vo gl):

Starting playback...
Unexpected decoder output format Planar 422P
Unexpected decoder output format Planar 422P
Unexpected decoder output format Planar 422P
Unexpected decoder output format Planar 422P
Unexpected decoder output format Planar 422P
Unexpected decoder output format Planar 422P
Unexpected decoder output format Planar 422P
Unexpected decoder output format Planar 422P
Unexpected decoder output format Planar 422P
Unexpected decoder output format Planar 422P
Unexpected decoder output format Planar 422P

Mplayer is from today's SVN (ffmpeg is from GIT head of course).

Version 0, edited 5 years ago by birdie (next)

comment:4 in reply to: ↑ 3 Changed 4 years ago by beastd

Hmm. Works for me after r37297 .

Replying to birdie:

This bug is not really fixed (-vo gl and -vo xv):

Starting playback...
Unexpected decoder output format Planar 422P
Unexpected decoder output format Planar 422P
Unexpected decoder output format Planar 422P
Unexpected decoder output format Planar 422P
Unexpected decoder output format Planar 422P
Unexpected decoder output format Planar 422P
Unexpected decoder output format Planar 422P
Unexpected decoder output format Planar 422P
Unexpected decoder output format Planar 422P
Unexpected decoder output format Planar 422P
Unexpected decoder output format Planar 422P

Mplayer is from today's SVN (ffmpeg is from GIT head of course).

Exhibits the behavior you quote above if I revert r37297 .

comment:5 Changed 4 years ago by reimar

Works for me, too.
Could you re-test?
And also make sure you have no old codecs.conf lying around somewhere!

comment:6 Changed 4 years ago by birdie

  • Resolution set to fixed
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.