Opened 5 years ago

Closed 5 years ago

#2210 closed defect (invalid)

film does not play with signal 11 saying "This shouldn't happen".

Reported by: gorn Owned by: beastd
Priority: normal Component: demuxer
Version: unspecified Severity: blocker
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: no Analyzed by developer: no

Description

Summary of the bug: film does not play with signal 11 saying "This shouldn't happen". It used to work with previous versions of mplayer.

How to reproduce:

$ mplayer -v Star\ Trek\ TNG\ -\ 1x26\ -\ The\ Neutral\ Zone.avi 
Reading config file /etc/mplayer/mplayer.conf
: No such file or directory
get_path('') -> '/home/gorn/.mplayer/'
get_path('config') -> '/home/gorn/.mplayer/config'
Reading config file /home/gorn/.mplayer/config
MPlayer2 2.0-728-g2c378c7-4+b1 (C) 2000-2012 MPlayer Team
CPU vendor name: AuthenticAMD  max cpuid level: 13
CPU: AMD FX(tm)-6300 Six-Core Processor              (Family: 21, Model: 2, Stepping: 0)
extended cpuid-level: 30
extended cache-info: 134250816
Detected cache-line size is 64 bytes
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNowExt: 0 SSE: 1 SSE2: 1 SSSE3: 1
Compiled with runtime CPU detection.
Compiled against libavutil version 54.3.0
Compiled against libavcodec version 56.1.0
Compiled against libavformat version 56.1.0
Compiled against libswscale version 3.0.0
get_path('codecs.conf') -> '/home/gorn/.mplayer/codecs.conf'
No optional codecs config file: /home/gorn/.mplayer/codecs.conf
No optional codecs config file: /etc/mplayer/codecs.conf
163 audio & 363 video codecs
Using built-in default codecs.conf.
Configuration: --prefix=/usr --confdir=/etc/mplayer --enable-translation --enable-debug=3 --extra-ldflags=-Wl,--as-needed --enable-runtime-cpudetection
CommandLine: '-v' 'Star Trek TNG - 1x26 - The Neutral Zone.avi'
get_path('fonts') -> '/home/gorn/.mplayer/fonts'
Using MMX (with tiny bit MMX2) Optimized OnScreenDisplay
get_path('fonts') -> '/home/gorn/.mplayer/fonts'
[ass] Raster: FreeType 2.5.2
[ass] Shaper: FriBidi 0.19.6 (SIMPLE) HarfBuzz-ng 0.9.35 (COMPLEX)
[ass] Initialized
get_path('fonts') -> '/home/gorn/.mplayer/fonts'
get_path('subfont.ttf') -> '/home/gorn/.mplayer/subfont.ttf'
[ass] Updating font cache
Using nanosleep() timing
get_path('input.conf') -> '/home/gorn/.mplayer/input.conf'
Cannot open file '/home/gorn/.mplayer/input.conf': No such file or directory
Failed to open /home/gorn/.mplayer/input.conf.
Can't open input config file /home/gorn/.mplayer/input.conf.
Cannot open file '/etc/mplayer/input.conf': No such file or directory
Failed to open /etc/mplayer/input.conf.
Can't open input config file /etc/mplayer/input.conf.
Falling back on default (hardcoded) input config
Setting up LIRC support...
Failed to open LIRC support. You will not be able to use your remote control.
get_path('Star Trek TNG - 1x26 - The Neutral Zone.avi.conf') -> '/home/gorn/.mplayer/Star Trek TNG - 1x26 - The Neutral Zone.avi.conf'

Playing Star Trek TNG - 1x26 - The Neutral Zone.avi.
get_path('sub/') -> '/home/gorn/.mplayer/sub/'
[file] File size is 175134720 bytes
STREAM: [file] Star Trek TNG - 1x26 - The Neutral Zone.avi
STREAM: Description: File
STREAM: Author: Albeu
STREAM: Comment: based on the code from ??? (probably Arpi)
LAVF_check: no clue about this gibberish!
Checking for YUV4MPEG2
ASF_check: not ASF guid!
Checking for REAL
Checking for SMJPEG
Searching demuxer type for filename Star Trek TNG - 1x26 - The Neutral Zone.avi ext: .avi
Trying demuxer 3 based on filename extension
Checking for Nullsoft Streaming Video
Checking for MOV
Checking for VIVO
header block 1 size: 0
Checking for PVA
Checking for MPEG-TS...
THIS DOESN'T LOOK LIKE AN MPEG-TS FILE!
TRIED UP TO POSITION 0, FOUND 0, packet_size= 0, SEEMS A TS? 0
Checking for LMLM4 Stream Format
Invalid packet in LMLM4 stream: ch=0 size=4294967288
LMLM4 Stream Format not found
MPEG Stream reached EOF
ds_fill_buffer: EOF reached (stream: video)  
MPEG packet stats: p100: 0  p101: 0 p1B6: 0 p12x: 0 sli: 0 a: 0 b: 0 c: 0 idr: 0 sps: 0 pps: 0 PES: 0  MP3: 0, synced: 0
Not MPEG System Stream format... (maybe Transport Stream?)
MPEG Stream reached EOF
ds_fill_buffer: EOF reached (stream: video)  
MPEG packet stats: p100: 0  p101: 0 p1B6: 0 p12x: 0 sli: 0 a: 0 b: 0 c: 0 idr: 0 sps: 0 pps: 0 PES: 0  MP3: 0, synced: 3
Not MPEG System Stream format... (maybe Transport Stream?)
==> Found video stream: 0
ds_fill_buffer: EOF reached (stream: video)  


MPlayer interrupted by signal 11 in module: demux_open
- MPlayer crashed by bad usage of CPU/FPU/RAM.
  Recompile MPlayer with --enable-debug and make a 'gdb' backtrace and
  disassembly. Details in DOCS/HTML/en/bugreports_what.html#bugreports_crash.
- MPlayer crashed. This shouldn't happen.
  It can be a bug in the MPlayer code _or_ in your drivers _or_ in your
  gcc version. If you think it's MPlayer's fault, please read
  DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and
  won't help unless you provide this information when reporting a possible bug.

Change History (3)

comment:2 in reply to: ↑ description Changed 5 years ago by beastd

Hi!

Replying to gorn:

Summary of the bug: film does not play with signal 11 saying "This shouldn't happen". It used to work with previous versions of mplayer.

How to reproduce:

$ mplayer -v Star\ Trek\ TNG\ -\ 1x26\ -\ The\ Neutral\ Zone.avi 
Reading config file /etc/mplayer/mplayer.conf
: No such file or directory
get_path('') -> '/home/gorn/.mplayer/'
get_path('config') -> '/home/gorn/.mplayer/config'
Reading config file /home/gorn/.mplayer/config
MPlayer2 2.0-728-g2c378c7-4+b1 (C) 2000-2012 MPlayer Team

Unfortunately you are not using MPlayer. This is a fork called MPlayer2. It is not the next version of MPlayer what so ever, it just has a confusing name. The last MPlayer release is version 1.1.1 and we recommend to use current SVN trunk version. (We should make a new release soon.)

I was curious to find out why that file does not play and from what I found I can tell you that file contains nothing but lots of zero bits. So not sure what happened but it is no surprise it does not show any reasonable content.

If you can confirm that the file on your end contains only zeros too, I would like to close this bug report with resolution invalid.

That specific MPlayer2 version looks like you use Debian. Debian deleted MPlayer package from testing and unstable. They transitioned it to MPlayer2 and that means, you probably originally installed MPlayer and lately it was replaced by MPlayer2 when you upgraded your packages.

We plan to bring MPlayer back into Debian. I personally did some work on it, but didn't have much time to wrap it up lately. If we manage to get MPlayer back into Debian you will read it in the news on our home page.

For now I would recommend you to build MPlayer yourself. You can use it without installing it into the system. Simplified how-to:

  1. Install some build dependencies with apt-get build-dep mplayer2
  2. Download current MPlayer sources https://mplayerhq.hu/design7/dload.html#source
  3. cd /to/mplayer/source/dir ; ./configure && make
  4. Use the mplayer executable that should now be available in that source directory

If that does not work, you could try to get help on our user mailing:
https://lists.mplayerhq.hu/mailman/listinfo/mplayer-users
(Please do not ask in this bug report, that kind of support does not belong here.)

[...]

LAVF_check: no clue about this gibberish!
Checking for YUV4MPEG2
ASF_check: not ASF guid!
Checking for REAL
Checking for SMJPEG
Searching demuxer type for filename Star Trek TNG - 1x26 - The Neutral Zone.avi ext: .avi
Trying demuxer 3 based on filename extension
Checking for Nullsoft Streaming Video
Checking for MOV
Checking for VIVO
header block 1 size: 0
Checking for PVA
Checking for MPEG-TS...
THIS DOESN'T LOOK LIKE AN MPEG-TS FILE!
TRIED UP TO POSITION 0, FOUND 0, packet_size= 0, SEEMS A TS? 0
Checking for LMLM4 Stream Format
Invalid packet in LMLM4 stream: ch=0 size=4294967288
LMLM4 Stream Format not found
MPEG Stream reached EOF
ds_fill_buffer: EOF reached (stream: video)  
MPEG packet stats: p100: 0  p101: 0 p1B6: 0 p12x: 0 sli: 0 a: 0 b: 0 c: 0 idr: 0 sps: 0 pps: 0 PES: 0  MP3: 0, synced: 0
Not MPEG System Stream format... (maybe Transport Stream?)
MPEG Stream reached EOF
ds_fill_buffer: EOF reached (stream: video)  
MPEG packet stats: p100: 0  p101: 0 p1B6: 0 p12x: 0 sli: 0 a: 0 b: 0 c: 0 idr: 0 sps: 0 pps: 0 PES: 0  MP3: 0, synced: 3

Those messages indicate MPlayer2 is trying hard to find out what kind of media file this is...
(MPlayer output looks very similar.)
[...]

MPlayer interrupted by signal 11 in module: demux_open
- MPlayer crashed by bad usage of CPU/FPU/RAM.
  Recompile MPlayer with --enable-debug and make a 'gdb' backtrace and
  disassembly. Details in DOCS/HTML/en/bugreports_what.html#bugreports_crash.
- MPlayer crashed. This shouldn't happen.
  It can be a bug in the MPlayer code _or_ in your drivers _or_ in your
  gcc version. If you think it's MPlayer's fault, please read
  DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and
  won't help unless you provide this information when reporting a possible bug.

That crash should not happen. And indeed it does not happen with current MPlayer SVN version here.

Sorry for this really long answer, but there seem to be many confusions and I hope I cleared some up.

comment:3 Changed 5 years ago by beastd

  • Resolution set to invalid
  • Status changed from new to closed

If I missed anything, feel free to re-open this bug.

Thank you for taking the time to report the crash.

Note: See TracTickets for help on using tickets.