Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#222 closed enhancement (invalid)

Having -ac hwac3 + hwdts is not easy and obvious to use

Reported by: david@… Owned by: diego@…
Priority: if idle Component: DOCS
Version: HEAD Severity: minor
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

While those two codecs may make sense for users with hardware then can only
decode one of both, many people like me will probably have a decoder which takes
both. It used to be that hwac3 did accept dts as well which was easier to use
with DVD.
So I'd suggest to add something like -ac passthrough which takes AC3 + DTS [+
whatever future format that's supported in passthrough by new decoders].

Change History (19)

comment:1 Changed 14 years ago by reimar

  • Resolution set to invalid
  • Status changed from new to closed

add ac=hwac3,hwdts, to your config and you don't have to think about it a bit
anymore.
-ac hwac3,hwdts is not much more to write than -ac passthrough.

comment:2 Changed 14 years ago by reimar

Hmm... should have been WONTFIX, not invalid. Anyway, my solution may need a bit
more knowledge about MPlayer usage but I really think it is simple enough.
Although it should be little work to add a codecs.conf entry that does what you
want.

comment:3 Changed 14 years ago by david@…

Related to another problem I had with codecs.conf, I was just told to completely
remove it and don't use it unless I really know what I'm doing. Well, I know
what I'd be doing but I don't want to be that deeply involved just to use such
basic functionality easily.
You're asking for knowledge about MPlayer that's obvious to you, easy to
understand for me (as a programmer myself) but most likely NOT easy to
understand for the average user of MPlayer.

comment:4 Changed 14 years ago by reimar

Don't quite understand what you mean... The point is that the codecs.conf in etc
or home is a leftover from old versions and should be removed (maybe a big
warning about that should be somewhere, but it needs somebody to implement it -
just waiting until all long-time MPlayer users removed it is easier ;-) ). That
file is mostly still supported to make it easy for people (esp. developers) to
try new formats (what is about what I meant with "if you know what you're doing")

comment:5 Changed 14 years ago by david@…

Well, I didn't understand your message until I had written my reply halfways and
forgot to complete rephrase it. ;-)
In short - I don't think that -ac hwac3,hwdts is really good either. -ac does
force MPlayer to use a specific codec so I wouldn't have expected to be able to
specify two. Now that I know it, it's clear to me that -ac does simply exchange
the default list to probe with the given one, but that's not something I'd have
expected.

comment:6 Changed 14 years ago by david@…

BTW I just tried out what happens with ac=hwac3,hwdts in the config file. It
works for AC3, for others it tries hwdts and then fails completely. Definitely
not what I want.

comment:7 Changed 14 years ago by reimar

-ac hwac3,hwdts was my idea of a replacement of -ac passthrough, the variant you
should put in the config is
ac=hwac2,hwdts,
with the comma at the end that will make it try other decoders next.

comment:8 Changed 14 years ago by david@…

Now that's a nice feature, exactly what I need. If it's already documented -
sorry for the inconvenience but you may consider to make the documentation for
it more prominent. If it's not documented - please add an easy to find
documentation for it.

comment:9 Changed 14 years ago by david@…

I forgot to be nitpicky all the time...

Opening audio decoder: [hwac3] AC3/DTS pass-through SP/DIF


comment:10 Changed 14 years ago by reimar

  • Component changed from ao to DOCS
  • Resolution invalid deleted
  • Status changed from closed to reopened

comment:11 Changed 14 years ago by reimar

  • Owner changed from alex@… to diego@…
  • Status changed from reopened to new

Diego: Could you have a look at that if you have some spare time ;-)

comment:12 Changed 14 years ago by diego@…

  • Status changed from new to assigned

(In reply to comment #9)

I forgot to be nitpicky all the time...

Opening audio decoder: [hwac3] AC3/DTS pass-through SP/DIF

That message comes from ad_hwac3.c which indeed decodes both AC3 and DTS.
What's your point?

(In reply to comment #10)

Diego: Could you have a look at that if you have some spare time ;-)

Dunno what you want me to do..

If you look at the man page and the descriptions of -ac and -vc I hope the
trailing "," is clear already. Suggestions welcome.

comment:13 Changed 14 years ago by david@…

Very simple - -ac hwac3 does not support DTS. You need to specify -ac hwdts for
that. Using -ac hwac3 you're told that it will support DTS as well though.

comment:14 Changed 14 years ago by diego@…

  • Resolution set to invalid
  • Status changed from assigned to closed

(In reply to comment #12)

Very simple - -ac hwac3 does not support DTS. You need to specify -ac hwdts for
that. Using -ac hwac3 you're told that it will support DTS as well though.

I repeat, that message comes from the file ad_hwac3.c that implements BOTH the
hardware AC3 and DTS decoder. I'm resolving this as INVALID, I see nothing we
could fix.

comment:15 Changed 14 years ago by david@…

It's completely irrelevant what the FILE can do. When called with -ac hwac3 it
can only pass AC3 and when called through -ac hwdts it can only pass DTS. Still
the message says it can do both when called with -ac hwac3 which is misleading.
According to this message, -ac hwac3 should also pass DTS (which was the old
behaviour and probably the reason behind this message).

comment:16 Changed 14 years ago by diego@…

(In reply to comment #14)

It's completely irrelevant what the FILE can do. When called with -ac hwac3 it
can only pass AC3 and when called through -ac hwdts it can only pass DTS.

You're misinterpreting the message. It's not supposed to tell you what the -ac
option you specified can do, but what the driver is capable of. That driver is
for both AC3 and DTS.

comment:17 Changed 14 years ago by david@…

It would probably not hurt if not for the fact that the behaviour changed
somewhat recently. Now we've got the situation that hwac3 doesn't work for DTS
anymore and the message you get from using hwac3 seems to indicate that it
should still work.

comment:18 Changed 14 years ago by diego@…

There is no easy way to mend this even if you were to consider it a problem. I
doubt anybody will spend energy on this. Feel free to come up with a patch.

comment:19 Changed 14 years ago by reimar

(In reply to comment #11)

(In reply to comment #10)

Diego: Could you have a look at that if you have some spare time ;-)

Dunno what you want me to do..

If you look at the man page and the descriptions of -ac and -vc I hope the
trailing "," is clear already. Suggestions welcome.

Wasn't sure about that... Also if you have/want to create some common samples
thing... Or maybe put it (ac=hwac3,hwdts,) commented-out in the sample config
file? Something like that...

Note: See TracTickets for help on using tickets.