Opened 15 years ago

Closed 14 years ago

Last modified 14 years ago

#224 closed defect (fixed)

X11 error: BadAccess (attempt to access private resource denied) using xv/x11/gl/gl2

Reported by: nuitari@… Owned by: alex@…
Priority: important Component: vo
Version: HEAD Severity: critical
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Since 1.0pre6, I am getting a
X11 error: BadAccess? (attempt to access private resource denied)
on playback and mplayer receives a SIGABRT signal and crashes. The only outputs
that I could test to work are caca, sdl,aa and vesa.

The xv, x11, gl and gl2 all crashes with the same error.

I have a Nvidia Geforce 4 Ti 4400.
I have tried with mplayer CVS, (MPlayer dev-CVS-050131-19:22-3.4.3) and the
problem is still present.

I am using xorg 6.8.1.902, aka 6.8.2 RC 2 and it has happenned with at least 1
previous version of xorg.

The window manager is KDE 3.3.1, however the problem still happen on a X11
without a window manager.

gandalf nuitari # gcc --version
gcc (GCC) 3.4.3 20041125 (Gentoo Linux 3.4.3-r1, ssp-3.4.3-0, pie-8.7.7)
Copyright (C) 2004 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

gandalf nuitari # uname -a
Linux gandalf 2.6.10-gentoo-r6 #1 Tue Jan 25 01:43:09 NZDT 2005 i686 Unknown CPU
Type AuthenticAMD GNU/Linux

The CPU is an Athlon XP.

This bug happen even if I compile mplayer with --disable-shm and
--disable-fastmemcpy

Here is a paste of what happens and the gdb backtrace.

X11 error: BadAccess? (attempt to access private resource denied)

Program received signal SIGABRT, Aborted.
[Switching to Thread 16384 (LWP 30838)]
0xb72faf71 in kill () from /lib/libc.so.6
(gdb) bt
#0 0xb72faf71 in kill () from /lib/libc.so.6
#1 0xb7bab270 in pthread_kill () from /lib/libpthread.so.0
#2 0xb7bab5fb in raise () from /lib/libpthread.so.0
#3 0xb72fabe6 in raise () from /lib/libc.so.6
#4 0xb72fc1ba in abort () from /lib/libc.so.6
#5 0x080c4dc5 in x11_errorhandler (display=0x0, event=0xbfffd560) at
x11_common.c:207
#6 0xb76fbe63 in _XError () from /usr/lib/libX11.so.6

The problem does not happen with mplayer 1.0_pre5

I also have a compilation log and an strace of both MPlayer 1.0_pre5 and 1.0_pre6

Change History (4)

comment:1 Changed 15 years ago by reimar

Please provide a complete mplayer -v log

comment:2 Changed 15 years ago by nuitari@…

Please note that the problem is also independant of the codec. I have tried a
variety of files and all exhibit the same behaviour.

nuitari@gandalf ~/movies/to_watch/bougon $ mplayer -v qcs-les\ bougon\ 01.mpg
Using GNU internationalization
Original domain: messages
Original dirname: /usr/share/locale
Current domain: mplayer
Current dirname: /usr/share/locale

MPlayer dev-CVS-050131-19:22-3.4.3 (C) 2000-2005 MPlayer Team
CPU: Advanced Micro Devices Athlon MP/XP Thoroughbred (Family: 6, Stepping: 1)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx SSE

CommandLine?: '-v' 'qcs-les bougon 01.mpg'
init_freetype
get_path('font/font.desc') -> '/home/nuitari/.mplayer/font/font.desc'
Font /home/nuitari/.mplayer/font/font.desc loaded successfully! (206 chars)
Using MMX (with tiny bit MMX2) Optimized OnScreenDisplay?
Using Linux hardware RTC timing (1024Hz).
get_path('input.conf') -> '/home/nuitari/.mplayer/input.conf'
Can't open input config file /home/nuitari/.mplayer/input.conf: No such file or
directory
Can't open input config file /usr/etc/mplayer/input.conf: No such file or directory
Falling back on default (hardcoded) input config
get_path('qcs-les bougon 01.mpg.conf') -> '/home/nuitari/.mplayer/qcs-les bougon
01.mpg.conf'
Playing qcs-les bougon 01.mpg.
[file] File size is 235047068 bytes
STREAM: [file] qcs-les bougon 01.mpg
STREAM: Description: File
STREAM: Author: Albeu
STREAM: Comment: based on the code from ??? (probably Arpi)
Checking for YUV4MPEG2
ASF_check: not ASF guid!
Checking for Nullsoft Streaming Video
Checking for NuppelVideo?
Checking for REAL
Checking for SMJPEG
Searching demuxer type for filename qcs-les bougon 01.mpg ext: .mpg
Checking for MOV
Checking for VIVO
header block 1 size: 0
Checking for PVA
Checking for MPEG-TS...
TRIED UP TO POSITION 67812, FOUND 47, packet_size= 0, SEEMS A TS? 0
Checking for LMLM4 Stream Format
Invalid packet in LMLM4 stream: ch=0 size=553648376
LMLM4 Stream Format not found
system stream synced at 0xB (0)!
==> Found video stream: 0
==> Found audio stream: 0
MPEG Stream reached EOF
ds_fill_buffer: EOF reached (stream: video)
MPEG-PS file format detected.
Searching for sequence header... OK!
VIDEO: MPEG1 352x240 (aspect 12) 29.970 fps 1150.0 kbps (143.8 kbyte/s)
[V] filefmt:2 fourcc:0x10000001 size:352x240 fps:29.97 ftime:=0.0334
get_path('sub/') -> '/home/nuitari/.mplayer/sub/'
get_path('default.sub') -> '/home/nuitari/.mplayer/default.sub'
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
dec_audio: Allocating 4608 + 65536 = 70144 bytes for output buffer.
mp3lib: made decode tables with MMX optimization
mp3lib: using 3DNow!Ex optimized decore!
MP3lib: init layer2&3 finished, tables done
MPEG 1.0, Layer II, 44100 Hz 224 kbit Stereo, BPF: 731
Channels: 2, copyright: No, original: No, CRC: No, emphasis: 0
AUDIO: 44100 Hz, 2 ch, 16 bit (0x9), ratio: 28000->176400 (224.0 kbit)
Selected audio codec: [mp3] afm:mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
X11 opening display: :0.0
vo: X11 color mask: FFFFFF (R:FF0000 G:FF00 B:FF)
vo: X11 running at 1152x864 with depth 24 and 32 bpp (":0.0" => local display)
[x11] Detected wm supports NetWM.
[x11] Detected wm supports FULLSCREEN state.
[x11] Detected wm supports ABOVE state.
[x11] Detected wm supports BELOW state.
[x11] Detected wm supports STAYS_ON_TOP state.
[x11] Current fstype setting honours FULLSCREEN STAYS_ON_TOP ABOVE BELOW X atoms
==========================================================================
Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough
VDec: vo config request - 352 x 240 (preferred csp: Mpeg PES)
Trying filter chain: vo
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
SwScale? params: -1 x -1 (-1=no scaling)
Trying filter chain: scale vo
The selected video_out device is incompatible with this codec.
VDecoder init failed :(
Opening video decoder: [libmpeg2] MPEG 1/2 Video decoder libmpeg2-v0.4.0b
Selected video codec: [mpeg12] vfm:libmpeg2 (MPEG 1 or 2 (libmpeg2))
==========================================================================
Checking audio filter chain for 44100Hz/2ch/16bit -> 44100Hz/2ch/16bit...
[libaf] Adding filter dummy
[dummy] Was reinitialized, rate=44100Hz, nch = 2, format = 0x00000009 and bps = 2
AF_pre: af format: 2 bps, 2 ch, 44100 hz, little-endian 16-bit signed int
AF_pre: 44100Hz 2ch little-endian 16-bit signed int
ao2: 44100 Hz 2 chans s16le
audio_setup: using '/dev/sound/dsp' dsp device
audio_setup: using '/dev/sound/mixer' mixer device
audio_setup: using 'pcm' mixer device
audio_setup: sample format: s16le (requested: s16le)
audio_setup: using 2 channels (requested: 2)
audio_setup: using 44100 Hz samplerate (requested: 44100)
audio_setup: frags: 8/8 (8192 bytes/frag) free: 65536
AO: [oss] 44100Hz 2ch little-endian 16-bit signed int (2 bps)
AO: Description: OSS/ioctl audio output
AO: Author: A'rpi
Building audio filter chain for 44100Hz/2ch/16bit -> 44100Hz/2ch/16bit...
[dummy] Was reinitialized, rate=44100Hz, nch = 2, format = 0x00000009 and bps = 2
[dummy] Was reinitialized, rate=44100Hz, nch = 2, format = 0x00000009 and bps = 2
Starting playback...
VDec: vo config request - 352 x 240 (preferred csp: Planar YV12)
Trying filter chain: vo
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO Config (352x240->352x264,flags=0,'MPlayer',0x32315659)
VO: [xv] 352x240 => 352x264 Planar YV12
VO: Description: X11/Xv
VO: Author: Gerd Knorr <kraxel@…> and others
Xvideo image format: 0x32595559 (YUY2) packed
Xvideo image format: 0x32315659 (YV12) planar
Xvideo image format: 0x59565955 (UYVY) packed
Xvideo image format: 0x30323449 (I420) planar
X11 error: BadAccess? (attempt to access private resource denied)
Type: 0, display: 86b8c28, resourceid: 0, serial: 38
Error code: a, request code: 58, minor code: 0

MPlayer interrupted by signal 6 in module: decode_video

  • MPlayer crashed. This shouldn't happen. It can be a bug in the MPlayer code _or_ in your drivers _or_ in your gcc version. If you think it's MPlayer's fault, please read DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and won't help unless you provide this information when reporting a possible bug.

Uninit audio filters...
[libaf] Removing filter dummy
uninit audio: mp3lib
uninit video: libmpeg2
vo: uninit ...

comment:3 Changed 15 years ago by nuitari@…

I have downloaded and installed mplayer CVS 050328 and xv works again! It still
fails with pre6.

comment:4 Changed 14 years ago by dominik@…

  • Resolution set to fixed
  • Status changed from new to closed

I understand this has long been fixed.

Note: See TracTickets for help on using tickets.