Opened 4 years ago

Closed 3 years ago

#2241 closed defect (fixed)

pa_stream_write() failed: Invalid argument with >=media-sound/pulseaudio-6.0

Reported by: pacho Owned by: beastd
Priority: normal Component: ao
Version: HEAD Severity: blocker
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: no Analyzed by developer: no

Description

As reported downstream at:
https://bugs.gentoo.org/show_bug.cgi?id=549680

Since pulseaudio commit: https://github.com/pulseaudio/pulseaudio/commit/150ace90f3808bbb7240e18a11140d66a7bda146 (stream: Fail on client submitting non-frame-aligned memblocks) (applied to Pulseaudio release: 6.0), mplayer sometimes gets pa_stream_write() failed: Invalid argument when sending audio to pulseaudio. When playing with 6 channels, I always get the error. This is because mplayer doesn't align the audio output to the current frame size when sending audio to pulseaudio. There is also a bug report here: https://bugs.archlinux.org/task/44937 .

The patch from:
https://bugs.gentoo.org/attachment.cgi?id=403444

looks to fix the problem, could it be upstreamed then?

Thanks a lot

Change History (3)

comment:1 Changed 3 years ago by quequotion

Please incorporate this patch!

comment:2 Changed 3 years ago by dominik@…

I reproduced this with MPlayer 1.2 and pulseaudio 7.1 on Fedora 23. Patch not tested yet.

comment:3 Changed 3 years ago by rxt

  • Component changed from undetermined to ao
  • Resolution set to fixed
  • Status changed from new to closed
  • Version changed from unspecified to HEAD

Patch applied, thanks.

Fixed in r37600 for trunk, and r37601 for 1.2 branch (will be in the 1.2.1 release).

Note: See TracTickets for help on using tickets.