Opened 4 years ago

Closed 4 years ago

#2258 closed defect (worksforme)

'-sub <file>' not working when mkv has an embedded subtitle

Reported by: xvan Owned by: beastd
Priority: low Component: undetermined
Version: unspecified Severity: blocker
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: no Analyzed by developer: no

Description

Summary of the bug:
'-sub <file>' not working when mkv has a subtitle track

Tested in mplayer 2:1.1+dfsg1-0ubuntu3

How to reproduce:
video.mkv has an embedded subtitle. ie:english
somefile.srt is another subtitle ie:spanish

% mplayer video.mkv -sub somefile.srt

What do I expect:
somefile.srt should be added to the subtitles tracks and selected by default.

What happens:
somefile.srt is not loaded
somefile.srt is not shown in the subtitles tracks ("j" keypress)
Only the embedded subtitle can be chosen.

Workaround:
Rename somefile.srt to videoname.srt and place it in the same folder as videoname.mkv.
Mplayer will show the subtitles if sub auto load is enabled.

Change History (1)

comment:1 Changed 4 years ago by reimar

  • Resolution set to worksforme
  • Status changed from new to closed

I cannot reproduce this issue.
Note that mplayer2 is a separate project from MPlayer.
Please try with the 1.2 or 1.3 release, if it still happens reopen.

Note: See TracTickets for help on using tickets.