Opened 3 years ago

Closed 3 years ago

#2265 closed defect (fixed)

--extra-cflags is not passed to codec-cfg

Reported by: curaga Owned by: beastd
Priority: normal Component: build system
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: no Analyzed by developer: no

Description

Summary of the bug: If some of your includes are in other dirs, you'd pass --extra-cflags=-I/some/path/include to configure. In today's SVN, the build is broken, because the flags do not reach codec-cfg.

% make
gcc -D_POSIX_C_SOURCE=200112 -D_XOPEN_SOURCE=600 -D_ISOC99_SOURCE -I. -Iffmpeg -O3 -DCODECS2HTML -o codec-cfg codec-cfg.c
In file included from codec-cfg.c:59:0:
libmpcodecs/img_format.h:24:25: fatal error: vdpau/vdpau.h: No such file or directory
compilation terminated.
make: *** [codec-cfg] Error 1

Change History (6)

comment:1 Changed 3 years ago by beastd

  • Status changed from new to open

Hi,

thanks for reporting this problem.

Flags passed via --extra-cflags are not meant to be passed to the host compiler because of cross-compiling.

If I am not mistaken this build failure was already discussed on the mailing lists:

https://lists.mplayerhq.hu/pipermail/mplayer-users/2015-December/088206.html

IIUC rxt wanted to fix it by re-arranging the code so codec-cfg.c won't depend on vdpau like it was before. I would also prefer that solution.

comment:2 Changed 3 years ago by beastd

I have sent a patch to the MPlayer development ml:

http://lists.mplayerhq.hu/pipermail/mplayer-dev-eng/attachments/20160129/6533a40a/attachment.patch

Can you confirm it fixes this issue?

comment:3 Changed 3 years ago by curaga

It'll be a bit before I can test it. Perhaps next weekend.

comment:4 Changed 3 years ago by beastd

In response to the comments received I have sent a new patch:

http://lists.mplayerhq.hu/pipermail/mplayer-dev-eng/attachments/20160207/508a6bf2/attachment.patch

Would be better if you could test that one instead of the first patch.

Thank you.

comment:5 follow-up: Changed 3 years ago by curaga

Yes, your new patch fixes this. I encountered an unrelated build failure in today's svn, a missing stdint.h include, I'll send a patch for that.

comment:6 in reply to: ↑ 5 Changed 3 years ago by beastd

  • Resolution set to fixed
  • Status changed from open to closed

Replying to curaga:

Yes, your new patch fixes this. I encountered an unrelated build failure in today's svn, a missing stdint.h include, I'll send a patch for that.

Ok, thanks for both testing and submitting the patch.

I committed my second patch now. So this should be fixed with r37734 .

Note: See TracTickets for help on using tickets.