Opened 14 years ago

Closed 13 years ago

Last modified 13 years ago

#228 closed defect (fixed)

ffmp3 use the wrong bitrate

Reported by: castet.matthieu@… Owned by: r_togni@…
Priority: normal Component: ad
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Hi

I upload files at ftp://ftp.mplayerhq.hu/MPlayer/incoming/ffmp3.

ffmp3_bad_rate_detection.avi : bug in ad_ffmpeg.c (mplayer) : it detect [1] the
wrong bitrate if using -vc ffmp3. Play fine with ffplay.

Matthieu

[1]
mplayer -v /mnt/hd3/adrien/Boogiepop\ Phantom/*02* -ac ffmp3
MPlayer dev-CVS-050130-12:59-3.3.5 (C) 2000-2005 MPlayer Team
CPU: Advanced Micro Devices Athlon 4 /Athlon MP/XP Palomino (Family: 6, Stepping: 2)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx SSE

[...]
======= WAVE Format =======
Format Tag: 85 (0x55)
Channels: 2
Samplerate: 48000
avg byte/sec: 16000
Block align: 1
bits/sample: 0
cbSize: 12
mp3.wID=1
mp3.fdwFlags=0x2
mp3.nBlockSize=384
mp3.nFramesPerBlock=1
mp3.nCodecDelay=1393
===========================
[...]
==========================================================================
Forced audio codec: ffmp3
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
dec_audio: Allocating 131072 + 65536 = 196608 bytes for output buffer.
FFmpeg's libavcodec audio codec
INFO: libavcodec init OK!
AUDIO: 11025 Hz, 2 ch, 16 bit (0x9), ratio: 32000->44100 (256.0 kbit)
Selected audio codec: [ffmp3] afm:ffmpeg (FFmpeg MPEG layer-3 audio decoder)
==========================================================================

Change History (3)

comment:1 Changed 14 years ago by reimar

(In reply to comment #0)

I upload files at ftp://ftp.mplayerhq.hu/MPlayer/incoming/ffmp3.

Can't find anything...

ffmp3_bad_rate_detection.avi : bug in ad_ffmpeg.c (mplayer) : it detect [1] the
wrong bitrate if using -vc ffmp3. Play fine with ffplay.

Known, though it is caused by a broken file. Changing the "#if 1" in
libmpcodecs/ad_ffmpeg.c, line 113 to #if 0 it will work in this case but might
break other things.

comment:2 Changed 13 years ago by diego@…

  • Owner changed from alex@… to r_togni@…

comment:3 Changed 13 years ago by diego@…

  • Resolution set to fixed
  • Status changed from new to closed

A fix for this was recently committed to CVS.

Note: See TracTickets for help on using tickets.