Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#2280 closed enhancement (invalid)

Significant mplayer size increase

Reported by: curaga Owned by: beastd
Priority: normal Component: undetermined
Version: unspecified Severity: minor
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: no Analyzed by developer: no

Description

The mplayer binary from 2013 was 13mb. The one from recent SVN is 18mb. This is a rather huge increase over just three years, with exact same configure args. Even a hundred new codecs in C shouldn't cause that much size.

I wonder if maybe ffmpeg builds in assembly for other platforms too by accident? Or perhaps the encoding functions are included in mplayer, when they should only be in mencoder.

Change History (3)

comment:1 in reply to: ↑ description Changed 3 years ago by cehoyos

  • Resolution set to invalid
  • Status changed from new to closed

Replying to curaga:

The mplayer binary from 2013 was 13mb. The one from recent SVN is 18mb. This is a rather huge increase over just three years, with exact same configure args. Even a hundred new codecs in C shouldn't cause that much size.

Shouldn't?

libavcodec size alone increased by more than five MB.

comment:2 follow-up: Changed 3 years ago by curaga

Why is it invalid? Do you think 18mb is an acceptable size for a player (it's not, it takes several seconds to start with cold caches)? Or do you mean the problem is in ffmpeg?

comment:3 in reply to: ↑ 2 Changed 3 years ago by beastd

Replying to curaga:

Why is it invalid? Do you think 18mb is an acceptable size for a player (it's not, it takes several seconds to start with cold caches)? Or do you mean the problem is in ffmpeg?

IIUC because of efforts from curaga and from reimar, size already decreased for current builds of MPlayer SVN.

Not sure if we should track those efforts in here or not. But it might be nice for documentation.

Note: See TracTickets for help on using tickets.