Opened 2 years ago

Closed 2 years ago

#2293 closed defect (fixed)

Mencoder return value on exit causes problem

Reported by: 4Selur@… Owned by: beastd
Priority: normal Component: undetermined
Version: HEAD Severity: critical
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: no Analyzed by developer: no

Description

Something changed in the last month that causes Qt's QProcess to assume mencoder exited with a crash.
testing with the builds from https://sourceforge.net/projects/mplayerwin/files/MPlayer-MEncoder/

r37831 works fine
r37817 reports a crash
-> something changed between these releases that causes all my Qt based programs to report mencoder as crashing

Don't know a way to reproduce this inside a console/terminal, but I can write some C++ Qt Code to test this if that would help.

Change History (15)

comment:1 follow-up: Changed 2 years ago by 4Selur@…

Sorry, correction:

r37817 works fine
r37831 reports a crash
the older one works :)

comment:2 in reply to: ↑ 1 Changed 2 years ago by beastd

Replying to 4Selur@…:

Sorry, correction:

r37817 works fine
r37831 reports a crash
the older one works :)

IIUC you can easily reproduce the issue. Could you bisect to find out the exact commit that breaks your use case?

comment:3 Changed 2 years ago by beastd

  • Summary changed from Mencoder return value on exit causes problem - r37831 works - r37817 fails to Mencoder return value on exit causes problem

comment:4 Changed 2 years ago by 4Selur@…

Problem is that I have no facility to build the versions myself.
So if you can provide me with 32bit binaries for each of the revisions I can check them and report back.
(Is there a way to browse the svn repository online?)

comment:5 follow-up: Changed 2 years ago by 4Selur@…

Friend of mine tested for me:
r37825 works
r37826+ is broken,
-> seems like something changed with r37826

comment:6 follow-up: Changed 2 years ago by redxii

r37826 was probably the fix for #2190.

Last edited 2 years ago by redxii (previous) (diff)

comment:7 in reply to: ↑ 5 Changed 2 years ago by beastd

Replying to 4Selur@…:

Friend of mine tested for me:
r37825 works
r37826+ is broken,
-> seems like something changed with r37826

Thanks.

Unfortunately I could not reproduce the problem here :(

Could you also post the used command line and the console output.

comment:8 in reply to: ↑ 6 Changed 2 years ago by beastd

Replying to redxii:

r37826 was probably the fix for #2190.

Are you able reproduce the described mencoder problem?

comment:9 Changed 2 years ago by redxii

I don't know about when using it with Qt but from the command-line I am only seeing exit code 0 when mencoder finishes encoding (or something like 'mencoder -oac help'), and I get 1 if I do something like input a wrong parameter or execute mencoder without any parameters.

comment:10 Changed 2 years ago by 4Selur@…

When calling:

mencoder -lavdopts threads=8 -really-quiet -of rawvideo -o - -ovc raw -noskip -field-dominance -1 -vf scale,format=i420,yadif=0,scale,format=i420 -forcedsubsonly -nosub -nosound -mc 0 "H:\1x05.mkv" | x264 --crf 18.00 --profile high --level 4.1 --direct auto --qcomp 0.5 --no-mbtree --partitions i4x4,p8x8,b8x8 --no-fast-pskip --subme 5 --trellis 0 --weightp 1 --aq-mode 0 --vbv-maxrate 62500 --vbv-bufsize 78125 --sar 16:15 --non-deterministic --range tv --colormatrix bt709 --input-csp i420  --fps 25 --input-res 720x576 --output "H:\Temp\18_57_20_0610_01.264" -

inside a command line everything is fine, but when I call it with Qt it stops near the end since I get a exitCode: -1073740940 and exitStatus: 1 from the QProcess I use, since this only started with the version above and works fine with all the versions before it looks to me like something in mplayer changed,...

comment:11 Changed 2 years ago by 4Selur@…

removing
+if(mux_v) free(mux_v->buffer);
+if(mux_a) free(mux_a->buffer);
seems to fix it,..

comment:12 Changed 2 years ago by reimar

I fixed one issue (related to the mux_v->buffer free) in r37853.
It doesn't really match 100% with your symptoms though, so it would be good to hear if it fixes it or issues remain...

comment:13 Changed 2 years ago by 4Selur@…

Will check and report back after work

comment:14 Changed 2 years ago by 4Selur@…

Did a bunch of encodes and r37853 seems to have finished the issue for me.
Thanks for fixing it. :)

comment:15 Changed 2 years ago by beastd

  • Resolution set to fixed
  • Status changed from new to closed

Hopefully fully fixed by Reimar in SVN r37853

Note: See TracTickets for help on using tickets.