Opened 14 years ago

Closed 13 years ago

Last modified 13 years ago

#230 closed defect (worksforme)

RealAudio problem

Reported by: gkulcsar@… Owned by: r_togni@…
Priority: normal Component: ad
Version: 1.0pre6 Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

I've downloaded a file from www.radio.hu.
It is in RealAudio? format, with the extension .rm.
When I try to open it with mplayer (no options), it crashes the ac3 (!) decoder.
When I remove the ac3 decoder (-ac -ac3), it says:

REAL file format detected.
======= WAVE Format =======
Format Tag: 28260 (0x6E64)
Channels: 2
Samplerate: 11025
avg byte/sec: 32000
Block align: 556
bits/sample: 16
cbSize: 0
===========================
==========================================================================
Cannot find codec for audio format 0x74656E64.
Read DOCS/HTML/en/codecs.html!
==========================================================================

I checked this magic number, and it identifies ac3 files (that's why mplayer
tried to open it with its ac3 decoder...).

The file plays without problems with the original RealPlayer?.
What's wrong?

Change History (12)

comment:1 Changed 14 years ago by gkulcsar@…

OK, here is the normal output, without any options:
==========================================================================
Opening audio decoder: [liba52] AC3 decoding with liba52
AC3: 2.0 (stereo) 11025 Hz 32.0 kbit/s
AUDIO: 11025 Hz, 2 ch, 16 bit (0x10), ratio: 4000->44100 (32.0 kbit)
Selected audio codec: [a52] afm:liba52 (AC3-liba52)
==========================================================================
Checking audio filter chain for 11025Hz/2ch/16bit -> 11025Hz/2ch/16bit...
AF_pre: af format: 2 bps, 2 ch, 11025 hz, little endian signed int
AF_pre: 11025Hz 2ch Signed 16-bit (Little-Endian)
AO: [dsound] 11025Hz 2ch Signed 16-bit (Little-Endian) (2 bps)
Building audio filter chain for 11025Hz/2ch/16bit -> 11025Hz/2ch/16bit...
Video: no video
Starting playback...

MPlayer interrupted by signal 11 in module: decode_audio

  • MPlayer crashed by bad usage of CPU/FPU/RAM. Recompile MPlayer with --enable-debug and make a 'gdb' backtrace and disassembly. Details in DOCS/HTML/en/bugreports_what.html#bugreports_crash.
  • MPlayer crashed. This shouldn't happen. It can be a bug in the MPlayer code _or_ in your drivers _or_ in your gcc version. If you think it's MPlayer's fault, please read DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and won't help unless you provide this information when reporting a possible bug.

comment:2 Changed 14 years ago by r_togni@…

Can you give the exact url for that file (or upload it on mphq)?
The use of ac3 could be right, real dnet is byte-swapped ac3.

comment:4 Changed 14 years ago by reimar

(In reply to comment #3)

Here is an example:
http://people.inf.elte.hu/medve/2004-11-12-k00_bojar.rm

Works fine for me with latest CVS under linux. What version are you using (where
did you get it from)? Does it work with -ao win32?

comment:5 Changed 14 years ago by gkulcsar@…

-ao win32 makes no difference.
The file I downloaded is called MPlayer-mingw32-1.0pre6.zip (downloaded from
mplayerhq.hu).
Here is the first few lines of the player output:

MPlayer 1.0pre6-3.2.3 (C) 2000-2004 MPlayer Team
CPU: Intel Pentium M Banias (Family: 6, Stepping: 5)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 0 SSE2: 0
Compiled with runtime CPU detection - WARNING - this is not optimal!
To get best performance, recompile MPlayer with --disable-runtime-cpudetection.

comment:6 Changed 14 years ago by reimar

Please test if it works with
http://www.mplayerhq.hu/MPlayer/releases/win32-beta/MPlayer-mingw32-dev-CVS-050227.zip
If it still doesn't work you should give the full output when using mplayer with -v

comment:7 Changed 14 years ago by gkulcsar@…

(In reply to comment #6)
OK, here is the full output.

MPlayer dev-CVS-050227-17:21 (C) 2000-2005 MPlayer Team
CPU: Intel Pentium M Banias (Family: 6, Stepping: 5)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 0 SSE2: 0
Compiled with runtime CPU detection - WARNING - this is not optimal!
To get best performance, recompile MPlayer with --disable-runtime-cpudetection.

CommandLine?: '-v' '2004-11-12-k00_bojar.rm'
init_freetype
get_path('font/font.desc') -> 'H:\/mplayer/font/font.desc'
font: can't open file: H:\/mplayer/font/font.desc
font: can't open file: /usr/local/share/mplayer/font/font.desc
Using MMX (with tiny bit MMX2) Optimized OnScreenDisplay?
Using Windows native timing
get_path('input.conf') -> 'H:\/mplayer/input.conf'
Can't open input config file H:\/mplayer/input.conf: No such file or directory
Can't open input config file /usr/local/etc/mplayer/input.conf: No such file or
directory
Falling back on default (hardcoded) input config
get_path('2004-11-12-k00_bojar.rm.conf') -> 'H:\/mplayer/2004-11-12-
k00_bojar.rm.conf'
Playing 2004-11-12-k00_bojar.rm.
WINSOCK2 init: 0
[file] File size is 14817613 bytes
STREAM: [file] 2004-11-12-k00_bojar.rm
STREAM: Description: File
STREAM: Author: Albeu
STREAM: Comment: based on the code from ??? (probably Arpi)
Checking for YUV4MPEG2
ASF_check: not ASF guid!
Checking for Nullsoft Streaming Video
Checking for NuppelVideo?
Checking for REAL
REAL file format detected.
real: Header size: 18
real: Header object version: 0
real: File version: 0
Chunk: PROP (504f5250) (size: 0x32, offset: 0x12)
First index chunk offset: 0xdfe821
First data chunk offset: 0xe9
Chunk: MDPR (5250444d) (size: 0x9b, offset: 0x44)
Found new stream (id: 0)
Stream description: The Audio Stream
Stream mimetype: audio/x-pn-realaudio
==> Found audio stream: 0
Found audio stream!
version: 4
header size: 57
frame_size: 556
sub_packet_size: 0
samplerate: 11025, channels: 2
skip_str: 4 bytes skipped
read_str: 4 bytes read
Audio: DNET -> AC3
======= WAVE Format =======
Format Tag: 28260 (0x6E64)
Channels: 2
Samplerate: 11025
avg byte/sec: 32000
Block align: 556
bits/sample: 16
cbSize: 0
===========================
### skipping 7 bytes of codec info
Chunk: DATA (41544144) (size: 0xdfe742, offset: 0xdf)
Packets in file: 25834
Reading index table from index chunk (14673953)
size: 20 bytes
entries: 10260
stream_id: 0
next_header_pos: 0
Auto-selected RM audio ID = 0
==========================================================================
Opening audio decoder: [liba52] AC3 decoding with liba52
dec_audio: Allocating 3840 bytes for input buffer.
dec_audio: Allocating 6144 + 65536 = 71680 bytes for output buffer.
AC3: 2.0 (stereo) 11025 Hz 32.0 kbit/s
A52 flags before a52_frame: 0x2A
A52 flags after a52_frame: 0x2
AUDIO: 11025 Hz, 2 ch, s16le, 32.0 kbit/9.07% (ratio: 4000->44100)
Selected audio codec: [a52] afm:liba52 (AC3-liba52)
==========================================================================
Checking audio filter chain for 11025Hz/2ch/s16le -> 11025Hz/2ch/s16le...
[libaf] Adding filter dummy
[dummy] Was reinitialized: 11025Hz/2ch/s16le
AF_pre: 11025Hz/2ch/s16le
ao_dsound: Output Devices:
0 Primary Sound Driver <--
1 SoundMAX Digital Audio
ao_dsound: DirectSound? initialized
ao_dsound: Samplerate:11025Hz Channels:2 Format:s16le
ao_dsound: Buffersize:44100 bytes (1000 msec)
ao_dsound: primary buffer created
ao_dsound: secondary (stream)buffer created
AO: [dsound] 11025Hz 2ch s16le (2 bps)
AO: Description: Windows DirectSound? audio output
AO: Author: Gabor Szecsi <deje@…>
Building audio filter chain for 11025Hz/2ch/s16le -> 11025Hz/2ch/s16le...
[dummy] Was reinitialized: 11025Hz/2ch/s16le
[dummy] Was reinitialized: 11025Hz/2ch/s16le
Video: no video
Freeing 0 unused video chunks.
Starting playback...

MPlayer interrupted by signal 11 in module: decode_audio

  • MPlayer crashed by bad usage of CPU/FPU/RAM. Recompile MPlayer with --enable-debug and make a 'gdb' backtrace and disassembly. Details in DOCS/HTML/en/bugreports_what.html#bugreports_crash.
  • MPlayer crashed. This shouldn't happen. It can be a bug in the MPlayer code _or_ in your drivers _or_ in your gcc version. If you think it's MPlayer's fault, please read DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and won't help unless you provide this information when reporting a possible bug.

Uninit audio filters...
[libaf] Removing filter dummy
uninit audio: liba52
WINSOCK2 uninit
ao_dsound: DirectSound? uninitialized

comment:8 Changed 14 years ago by gkulcsar@…

I've also tried it again with -ao win32, but got the same result.

comment:9 Changed 14 years ago by gamester17@…

Adding search keywords (for people searching for RealMedia? bugs/issues): Real,
RealNetworks? RealPlayer?, RealVideo?, RealAudio?, RM, RAM, RA, RV, RMVB, live,
live.com

comment:10 Changed 14 years ago by diego@…

  • Owner changed from alex@… to r_togni@…

comment:11 Changed 14 years ago by gkulcsar@…

Checked again.
Now (as of 14-12-2005) it works with the latest CVS snapshot build for Windows!

comment:12 Changed 13 years ago by diego@…

  • Resolution set to worksforme
  • Status changed from new to closed

Resolving as WORKSFORME, the reporter says the problem is gone.

Note: See TracTickets for help on using tickets.