Opened 10 months ago

Closed 4 weeks ago

#2312 closed defect (wontfix)

build fails on debian oldstable and stable

Reported by: shurreg Owned by: beastd
Priority: normal Component: build system
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: yes Analyzed by developer: yes

Description

Summary of the bug: build process fails on Debian Wheezy and Jessie because the distros have GCC 4.7 and 4.8 respectively, and those versions don't have stdatomic.h bundled. Standalone FFmpeg builds prefectly because its configure script adds path to stdatomic.h bundled in ffmpeg/compat/atomics/gcc, while mplayer's one doesn't.

Quick manual fix was an addition of "CPPFLAGS += -Icompat/atomics/gcc" into ffmpeg/common.mak

It seems CentOSes are affected, too: https://codingweb.io/centos-7-stdatomic-h-no-file-directory/

How to reproduce:

% ./configure --disable-runtime-cpudetection
...
% make
CC      libavutil/cpu.o
libavutil/cpu.c:20:23: fatal error: stdatomic.h: No such file or directory
%

Change History (4)

comment:1 Changed 9 months ago by beastd

  • Reproduced by developer set
  • Status changed from new to open

Could reproduce on Ubuntu with gcc-4.7

comment:2 follow-up: Changed 6 weeks ago by yotam

The quick manual fix to CPPFLAGS - in my case -
was applied to ffmpeg/ffbuild/common.mak

comment:3 in reply to: ↑ 2 Changed 4 weeks ago by beastd

Replying to yotam:

The quick manual fix to CPPFLAGS - in my case -
was applied to ffmpeg/ffbuild/common.mak

Yes, the file moved inside of ffmpeg into the mentioned directory.

NOTE:

BTW if the build isn't working for you today, that is because lot's of stuff that was deprecated for quite some time got disabled in FFmpeg. I am working on it right now and I already have MPlayer compiling again, but it will probably take some time to get it right.

comment:4 Changed 4 weeks ago by beastd

  • Analyzed by developer set
  • Resolution set to wontfix
  • Status changed from open to closed

I will close this ticket because

  • it's only relevant for old compilers
  • a trivial workaround is described in this ticket
  • it is non-trivial to fix properly
Note: See TracTickets for help on using tickets.