Opened 7 months ago

Closed 3 weeks ago

Last modified 3 weeks ago

#2324 closed defect (invalid)

MPlayer crashes when playing playlists with ffmpeg-3.3

Reported by: orbea Owned by: beastd
Priority: normal Component: undetermined
Version: 1.3 Severity: blocker
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: no Analyzed by developer: no

Description

OS: Slackware64-current
MPlayer-1.3.0-x86_64-1
ffmpeg-3.3-x86_64-1

Summary of the bug: When playing files through a playlist MPlayer will sometimes crash after a video ends and when trying to start the next one in the playlist. This only started after compiling MPlayer with ffempg-3.3, it did not occur with ffmpeg 3.2.

How to reproduce:
Start a mplayer playlist, wait a little bit for it to play and then skip to the next video. Repeat up to a few times if it doesn't occur the first time.

Full log + backtrace.
https://pastebin.com/bFYN0DPn

Change History (4)

comment:1 Changed 7 months ago by orbea

I have discovered some more details.

This will only occur with hwdec, as I am a nouveau user this requires the firmware extracted from the nvidia blob and I configured mplayer following the nouveau documentation:

vo=vdpau
[vo.vdpau]
vc=ffmpeg12vdpau,ffwmv3vdpau,ffvc1vdpau,ffh264vdpau,ffodivxvdpau,

https://nouveau.freedesktop.org/wiki/VideoAcceleration/

If I comment the 'vc' line it no longer occurs. However the whole reason I use MPlayer is the hwdec support.

Additionally it doesn't seem to crash every time and I have tried running it in valgrind where it does not crash.

MPlayer Memory map - https://pastebin.com/QSTGYUPy
gdb log 1 - https://pastebin.com/Kb75BJJ7
gdb log 2 - https://pastebin.com/VyYN5JPrin
valgrind - https://pastebin.com/ExYmAEgK

Last edited 7 months ago by orbea (previous) (diff)

comment:2 Changed 3 weeks ago by beastd

Can you confirm the crash happens only without FFmpeg commit 3a6ded7cfc ?

The mentioned commit fixed a vdpau crash bug that I could trigger with some files, especially when pressing enter early after starting up mplayer.

comment:3 Changed 3 weeks ago by orbea

  • Resolution set to fixed
  • Status changed from new to closed

Yes. It seems that FFmpeg commit 3a6ded7cfc solved this. With FFmpeg-3.4 where this is applied the crashes stopped. I also tried reverting that change with an internal version of FFmpeg-3.4 and the crashes quickly resumed. I would consider this fixed until someone can reproduce it again. Thanks again for the help in irc!

comment:4 Changed 3 weeks ago by beastd

  • Resolution changed from fixed to invalid

Thank you for reporting this issue and actively helping to resolve it even after the problems didn't occur anymore with your mplayer installation.

I just switched resolution to invalid as the problem was fixed outside of MPlayer in FFmpeg commit 3a6ded7cfc .

Note: See TracTickets for help on using tickets.