Opened 4 months ago

Closed 3 months ago

Last modified 2 months ago

#2329 closed defect (fixed)

ac3 decoding issue breaks divx video

Reported by: octoploid Owned by: beastd
Priority: normal Component: undetermined
Version: unspecified Severity: blocker
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: no Analyzed by developer: no

Description

Summary of the bug:

Current mplayer trunk doesn't play divx videos correctly.

markus@x4 films % mplayer The\ Shanghai\ Gesture\ \(1941\)\ Josef\ von\ Sternberg-4658019.avi
MPlayer SVN-r37940-7.1.1 (C) 2000-2017 MPlayer Team                   
                                                                       
Playing The Shanghai Gesture (1941) Josef von Sternberg-4658019.avi.  
libavformat version 57.72.101 (internal)                               
AVI file format detected.                                              
[aviheader] Video stream found, -vid 0                                 
[aviheader] Audio stream found, -aid 1                                 
VIDEO:  [XVID]  656x500  12bpp  25.000 fps  840.2 kbps (102.6 kbyte/s) 
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family       
libavcodec version 57.96.101 (internal)                                
Selected video codec: [ffodivx] vfm: ffmpeg (FFmpeg MPEG-4)            
==========================================================================
Clip info:                                                             
 Software: VirtualDubMod 1.5.10.1 (build 2366/release)              
Load subtitles in ./                                                   
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders       
AUDIO: 48000 Hz, 2 ch, floatle, 192.0 kbit/6.25% (ratio: 24000->384000)
Selected audio codec: [ffac3] afm: ffmpeg (FFmpeg AC-3)                
==========================================================================
AO: [oss] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...                  
Movie-Aspect is undefined - no prescaling applied.
VO: [vdpau] 656x500 => 656x500 Planar YV12
[mpeg4 @ 0x560ad68f5220]Video uses a non-standard and wasteful way to store B-frames ('packed B-frames'). Consider using the mpeg4_unpack_bframes bitstream filter without encoding
 but stream copy to fix it.
Movie-Aspect is 1.31:1 - prescaling to correct movie aspect.
VO: [vdpau] 656x500 => 656x500 Planar YV12
A:   0.2 V:   0.2 A-V: -0.029 ct: -0.013   6/  6 ??% ??% ??,?% 0 0
[ac3 @ 0x560ad68f5220]Got unexpected packet size after a partial decode
A:   0.2 V:   0.2 A-V: -0.006 ct: -0.014   7/  7 ??% ??% ??,?% 0 0
[ac3 @ 0x560ad68f5220]Got unexpected packet size after a partial decode
A:   0.3 V:   0.3 A-V:  0.034 ct: -0.011   8/  8 ??% ??% ??,?% 0 0
[ac3 @ 0x560ad68f5220]Got unexpected packet size after a partial decode
A:   0.4 V:   0.3 A-V:  0.071 ct: -0.007   9/  9 ??% ??% ??,?% 0 0
[ac3 @ 0x560ad68f5220]Got unexpected packet size after a partial decode
A:   0.5 V:   0.4 A-V:  0.107 ct: -0.003  10/ 10 ??% ??% ??,?% 0 0
[ac3 @ 0x560ad68f5220]Got unexpected packet size after a partial decode
A:   0.5 V:   0.4 A-V:  0.143 ct:  0.001  11/ 11 ??% ??% ??,?% 0 0
[ac3 @ 0x560ad68f5220]Got unexpected packet size after a partial decode
A:   0.6 V:   0.4 A-V:  0.179 ct:  0.005  12/ 12 ??% ??% ??,?% 0 0
[ac3 @ 0x560ad68f5220]Got unexpected packet size after a partial decode
A:   0.7 V:   0.5 A-V:  0.215 ct:  0.009  13/ 13 ??% ??% ??,?% 0 0
[ac3 @ 0x560ad68f5220]Got unexpected packet size after a partial decode
A:   0.8 V:   0.5 A-V:  0.249 ct:  0.013  14/ 14 13%  4%  0.4% 0 0
[ac3 @ 0x560ad68f5220]Got unexpected packet size after a partial decode
A:   0.8 V:   0.6 A-V:  0.249 ct:  0.017  15/ 15 13%  4%  0.3% 0 0
[ac3 @ 0x560ad68f5220]Got unexpected packet size after a partial decode
A:   0.8 V:   0.6 A-V:  0.249 ct:  0.017  16/ 16 12%  4%  0.3% 0 0
[ac3 @ 0x560ad68f5220]Got unexpected packet size after a partial decode
A:   0.9 V:   0.6 A-V:  0.289 ct:  0.017  16/ 16 12%  4%  0.3% 0 0
[ac3 @ 0x560ad68f5220]Got unexpected packet size after a partial decode
A:   0.9 V:   0.6 A-V:  0.329 ct:  0.017  16/ 16 12%  4%  0.3% 0 0
[ac3 @ 0x560ad68f5220]Got unexpected packet size after a partial decode
A:   1.0 V:   0.6 A-V:  0.369 ct:  0.017  16/ 16 12%  4%  0.4% 0 0
[ac3 @ 0x560ad68f5220]Got unexpected packet size after a partial decode
A:   1.0 V:   0.6 A-V:  0.409 ct:  0.017  16/ 16 12%  4%  0.4% 0 0
[ac3 @ 0x560ad68f5220]Got unexpected packet size after a partial decode
A:   1.0 V:   0.6 A-V:  0.449 ct:  0.017  16/ 16 12%  4%  0.4% 0 0
[ac3 @ 0x560ad68f5220]Got unexpected packet size after a partial decode
A:   1.1 V:   0.6 A-V:  0.489 ct:  0.017  16/ 16 12%  4%  0.4% 0 0
[ac3 @ 0x560ad68f5220]Got unexpected packet size after a partial decode
A:   1.1 V:   0.6 A-V:  0.529 ct:  0.017  16/ 16 12%  4%  0.4% 0 0
[ac3 @ 0x560ad68f5220]Got unexpected packet size after a partial decode
A:   1.2 V:   0.6 A-V:  0.569 ct:  0.017  16/ 16 12%  4%  0.4% 0 0
[ac3 @ 0x560ad68f5220]Got unexpected packet size after a partial decode
A:   1.2 V:   0.6 A-V:  0.609 ct:  0.017  16/ 16 12%  4%  0.4% 0 0
[ac3 @ 0x560ad68f5220]Got unexpected packet size after a partial decode
A:   1.2 V:   0.6 A-V:  0.649 ct:  0.017  16/ 16 12%  4%  0.4% 0 0
[ac3 @ 0x560ad68f5220]Got unexpected packet size after a partial decode
A:   1.3 V:   0.6 A-V:  0.689 ct:  0.017  16/ 16 12%  4%  0.4% 0 0
[ac3 @ 0x560ad68f5220]Got unexpected packet size after a partial decode
A:   1.3 V:   0.6 A-V:  0.729 ct:  0.017  16/ 16 12%  4%  0.5% 0 0
[ac3 @ 0x560ad68f5220]Got unexpected packet size after a partial decode
A:   1.4 V:   0.6 A-V:  0.769 ct:  0.017  16/ 16 12%  4%  0.5% 0 0
[ac3 @ 0x560ad68f5220]Got unexpected packet size after a partial decode
A:   1.4 V:   0.6 A-V:  0.809 ct:  0.017  16/ 16 12%  4%  0.5% 0 0
[ac3 @ 0x560ad68f5220]Got unexpected packet size after a partial decode
A:   1.4 V:   0.6 A-V:  0.849 ct:  0.017  16/ 16 12%  4%  0.5% 0 0
[ac3 @ 0x560ad68f5220]Got unexpected packet size after a partial decode
A:   1.5 V:   0.6 A-V:  0.889 ct:  0.017  16/ 16 12%  4%  0.5% 0 0
[ac3 @ 0x560ad68f5220]Got unexpected packet size after a partial decode
A:   1.5 V:   0.6 A-V:  0.929 ct:  0.017  16/ 16 12%  4%  0.5% 0 0
[ac3 @ 0x560ad68f5220]Got unexpected packet size after a partial decode
A:   1.6 V:   0.6 A-V:  0.969 ct:  0.017  16/ 16 12%  4%  0.5% 0 0
[ac3 @ 0x560ad68f5220]Got unexpected packet size after a partial decode
A:   1.6 V:   0.6 A-V:  1.009 ct:  0.017  16/ 16 12%  4%  0.5% 0 0
[ac3 @ 0x560ad68f5220]Got unexpected packet size after a partial decode
A:   1.6 V:   0.6 A-V:  1.049 ct:  0.017  16/ 16 12%  4%  0.5% 0 0
[ac3 @ 0x560ad68f5220]Got unexpected packet size after a partial decode
A:   1.7 V:   0.6 A-V:  1.089 ct:  0.017  16/ 16 12%  4%  0.6% 0 0
[ac3 @ 0x560ad68f5220]Got unexpected packet size after a partial decode
A:   1.7 V:   0.6 A-V:  1.129 ct:  0.017  16/ 16 12%  4%  0.6% 0 0
[ac3 @ 0x560ad68f5220]Got unexpected packet size after a partial decode
A:   1.8 V:   0.6 A-V:  1.169 ct:  0.017  16/ 16 12%  4%  0.6% 0 0
[ac3 @ 0x560ad68f5220]Got unexpected packet size after a partial decode
A:   1.8 V:   0.6 A-V:  1.209 ct:  0.017  16/ 16 12%  4%  0.6% 0 0
[ac3 @ 0x560ad68f5220]Got unexpected packet size after a partial decode
A:   1.8 V:   0.6 A-V:  1.249 ct:  0.017  16/ 16 12%  4%  0.6% 0 0
[ac3 @ 0x560ad68f5220]Got unexpected packet size after a partial decode
A:   1.9 V:   0.6 A-V:  1.289 ct:  0.017  16/ 16 12%  4%  0.6% 0 0
[ac3 @ 0x560ad68f5220]Got unexpected packet size after a partial decode
A:   1.9 V:   0.6 A-V:  1.329 ct:  0.017  16/ 16 12%  4%  0.6% 0 0
[ac3 @ 0x560ad68f5220]Got unexpected packet size after a partial decode
A:   2.0 V:   0.6 A-V:  1.369 ct:  0.017  16/ 16 12%  4%  0.6% 0 0
OSS: Reset failed
[ac3 @ 0x560ad68f5220]frame sync error

The video stops at the first frame and displays it forever.
Fast forward skips to another frame that is also displayed forever.

Attachments (2)

test.avi (2.0 MB) - added by octoploid 4 months ago.
testcase
Intro.avi (2.2 MB) - added by topolinik 3 months ago.

Change History (8)

Changed 4 months ago by octoploid

testcase

comment:1 Changed 4 months ago by octoploid

  • Summary changed from divx videos broken to ac3 decoding issue lead to breaks divx video

-nosound "fixes" the issue

comment:2 Changed 4 months ago by octoploid

  • Summary changed from ac3 decoding issue lead to breaks divx video to ac3 decoding issue breaks divx video

comment:3 Changed 3 months ago by topolinik

I'm currently facing the same behavior with SVN-37940.
The audio codec is not relevant, as this issue appears with mpeg layer3 also. Sample clip attached.
Further, I see mplayer does NOT stay stuck forever, it tries to play audio at first (and video freezes) and fails, then at the end of the audio track, it starts decoding video. This is what happens with this short clip.

Changed 3 months ago by topolinik

comment:4 Changed 3 months ago by redxii

DVDs are affected by this as well.

comment:5 Changed 3 months ago by beastd

  • Resolution set to fixed
  • Status changed from new to closed

Works for me again after SVN r37946 by Reimar.

The first sample has some lip sync issues, that are not related to the reported problem AFAICT.

Thank you all for reporting and providing samples.

comment:6 Changed 2 months ago by topolinik

For me, the only trick to make this warning disappear was fixing the video.
Since it only happened with mpeg4-asp files, I used avidemux with them, unpacking the "packed bitstream" (current mplayer doesn't warn about it as it used to do) and then saving the new video.
This makes mplayer happy again.

Note: See TracTickets for help on using tickets.