Opened 3 weeks ago

Last modified 13 hours ago

#2345 reopened defect

gmplayer won't accept m3u playlist from interface only from CLI

Reported by: BrianA_MN Owned by: ib
Priority: normal Component: GUI
Version: unspecified Severity: minor
Keywords: gmplayer playlist Cc: ib@…
Blocked By: Blocking:
Reproduced by developer: no Analyzed by developer: yes

Description

Summary of the bug: If you hand create a playlist.m3u of a radio stream using either the EXTM3U/EXTINT headers or not using them, and pass that playlist to mplayer or gmplayer with the -playlist option from the command line it will play the playlist. If you open mplayer, using gui gmplayer, and then load that same radio station stream via the playlist button, nothing will play. SMPlayer and Xine do play the radio stream from the example playlist when using their playlist selection buttons.

Example playlist file:
bash-4.3$ cat Music/test.m3u8
#EXTM3U8
#EXTINF:0,BossBoss Radio - 0
http://streaming.live365.com/b26873_128mp3

System is Slackware 64 14.2, Kernel is 4.4.118

Attachments (4)

1a.png (33.2 KB) - added by ib 2 days ago.
Open File Selector
1b.png (9.2 KB) - added by ib 2 days ago.
Open File Selector
2.png (18.2 KB) - added by ib 2 days ago.
Playlist Selection
3.png (11.3 KB) - added by ib 2 days ago.
Open URL

Download all attachments as: .zip

Change History (16)

comment:1 Changed 3 weeks ago by ib

  • Analyzed by developer set
  • Cc ib@… added
  • Component changed from undetermined to GUI
  • Owner changed from beastd to ib
  • Status changed from new to open

Since mplayer doesn't allow to directly play playlists for security reasons, you have to use gmplayer's load button or open file from its menu and filter playlists.

In your case (a simple URL) you can also use open url from the menu.

comment:2 Changed 5 days ago by ib

  • Resolution set to invalid
  • Status changed from open to closed

comment:3 Changed 5 days ago by BrianA_MN

  • Resolution invalid deleted
  • Status changed from closed to reopened

This is not an invalid defect. Mplayer does allow a playlist to be passed in the commandline with the following command #mplayer -playlist test.m3u8. The gmplayer, the gui interface, will NOT accept the same playlist with the load and open file buttons on the gmplayer interface. Please re-examine this defect. If you use the command line and pass # gmplayer -playlist test.m3u8 it will also start playing correctly. ONLY when attempting to load from the gmplayer buttons does this fail. So you solution is what is failing!

comment:4 Changed 5 days ago by ib

  • Resolution set to invalid
  • Status changed from reopened to closed

Please carefully read my comment where I explained the filter to be used with the load and open file buttons! (Change from Popular audio and video files to Playlists.)

comment:5 Changed 5 days ago by BrianA_MN

  • Resolution invalid deleted
  • Status changed from closed to reopened

Please provide a step by step, like I have done to explain your "filter"?

I have started #gmplayer in an KDE xsession. After the interface opens, click the three dots buttons (located in the upper left quadrant between the "S" and "PL" buttons) to load a file, switch the filtered mode to "All Files". Select the test.m3u8 file from the ~/Music directory. Then click the "PL" button and make sure the test.m3u8 file is "Add" to the "Select" list, click OK. Now on the gmplayer gui press the ">
" button. Nothing will play.

If this is the wrong procedure, I'm open to correction of the proper procedure. If this is a valid procedure then there is something wrong with the gmplayer interface.

Again from the command line interface (CLI) passing "mplayer -playlist ~/Music/test.m3u8" will play the test file. OR doing the same with gmplayer will play the list, but I can not get it to play from the gmplayer gui interface.

comment:6 Changed 5 days ago by ib

  • Resolution set to invalid
  • Status changed from reopened to closed

You really should carefully read what I wrote.

After the interface opens, click the three dots buttons (located in the upper left quadrant between the "S" and "PL" buttons) to load a file, switch the filtered mode to "All Files".

You must switch the filtered mode to "Playlists"!

comment:7 Changed 4 days ago by BrianA_MN

  • Resolution invalid deleted
  • Status changed from closed to reopened

The only time the "Playlist" filter appears is if I start Mplayer, and then right click on the mplayer screen and ignore the minicontrols (which I call gmplayer). However even with a right click (ignoring the minicontrols) on the big MPLAYER screen, then switching to playlist and selecting the test.m3u8 file there is still nothing which will play. Infact mplayer locks up.

In the gmplayer minicontrol panel there is no "Playlist" filter. If I select "All Subtitles" then the playlist files appear and can be loaded. The file title appears in the minicontrol window. But pressing the play button in the minicontrol panel results in nothing.

Have you attempted to use the steps that I've provided? If you do, what is your result?

Last edited 4 days ago by BrianA_MN (previous) (diff)

comment:8 Changed 4 days ago by ib

So what version of gmplayer are you using?

comment:9 Changed 3 days ago by BrianA_MN

When I open gmplayer and click on the minicontrol panel "MPLAYER" logo the following pops up:

MPlayer 1.2.1-5.3.0 (C) 2000-2016 MPlayer Team

GUI development has been sponsored by UHU-Linux:

http://www.uhulinux.hu/

Changed 2 days ago by ib

Open File Selector

Changed 2 days ago by ib

Open File Selector

Changed 2 days ago by ib

Playlist Selection

Changed 2 days ago by ib

Open URL

comment:10 Changed 2 days ago by ib

  • Resolution set to invalid
  • Status changed from reopened to closed

First of all, your version is approx. 2 1/2 years old and lacks approx. 500 changes/fixes since.

Secondly, the right place to ask about usage is the mailing list.

Open the file selector:

Open File Selector

or using the default menu (right mouse button click):

Open File Selector

and filter playlists:

Playlist Selection

In your case, the easiest way is to directly open the URL:

Open URL

comment:11 Changed 18 hours ago by BrianA_MN

  • Resolution invalid deleted
  • Status changed from closed to reopened

This bug report is that a standard playlist can not be read and played by gmplayer, not how the minicontrol functions. Please try to make the playlist that I've posted earlier and try opening it with the minicontroller or mplayer. If it plays for you then great, then I have a local problem. If it doesn't play, then please realize this is a bug with mplayer not supporting playlist standards. Or at least acknowledge that mplayer doens't support standard playlists.

I use Slackware 14.2 whose current distribution is MPlayer 1.2.1, which was released in January 2016, 1.3.0 was released one month later and no newer release has been made since. This is not a user instruction issue, this is a bug in mplayer reading and using standard playlists. If a playlist bug was addressed in 1.3.0 then please show me the release note showing it was addressed.

I"ve tried to use the eject button to pull up. load and then play. That results in mplayer lockup and nothing played. Also using the eject button on the minicontrols to pull-up playlists doesn't follow expected results, because every "physical" audio or cd player eject button simply causes the player to stop playing and eject the current CD/DVD.

Please leave this bug request open until it is properly resolved. If this bug is a duplicate then please refer to that bug so I can correct my standard playlist to conform to what mplayer expects.

Thank you.


Last edited 18 hours ago by BrianA_MN (previous) (diff)

comment:12 Changed 13 hours ago by reimar

I am not sure selecting "playlists" in the open menu helps?
I still get "Playlist parsing disabled for security reasons. Ignoring file."
However it's still in the playlist, and explicitly pressing play results in trying to play it as a media file - which of course fails. In such an old version, it might well have resulted in a hang on top of it, that at least is not the case in current versions.
gmplayer -playlist test.m3u8
does work however, so this seems more of an issue with the file open dialog and playlist management...

Note: See TracTickets for help on using tickets.