Opened 5 months ago

Closed 5 months ago

Last modified 5 months ago

#2347 closed defect (invalid)

Problem with loading subtitles

Reported by: bozydarek Owned by: beastd
Priority: normal Component: undetermined
Version: 1.3 Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: no Analyzed by developer: no

Description

Summary of the bug:

Quite funny bug. Folder structure:

Movie/
├── Movie.mp4
├── Movie.srt
└── Movie.txt

File Movie.srt contains subtitles (in English).
File Movie.txt contains subtitles (in my native language).

If I try to start mplayer it stuck on loading subtitles (and use 100% of one CPU core). If I remove or rename Movie.txt it works normally and if I add flags -noautosub -sub Movie.srt it's works too.

How to reproduce:

% mplayer Movie.mp4 
MPlayer 1.3.0 (Debian), built with gcc-7 (C) 2000-2016 MPlayer Team
do_connect: could not connect to socket
connect: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing Movie.mp4.
libavformat version 57.71.100 (external)
libavformat file format detected.
[mov,mp4,m4a,3gp,3g2,mj2 @ 0x7fb7819725e0]Protocol name not provided, cannot determine if input is local or a network protocol, buffers and access patterns cannot be configured optimally without knowing the protocol
[lavf] stream 0: video (h264), -vid 0
[lavf] stream 1: audio (aac), -aid 0, -alang und
VIDEO:  [H264]  1920x800  24bpp  23.976 fps  1999.9 kbps (244.1 kbyte/s)
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
libavcodec version 57.89.100 (external)
Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
==========================================================================
Clip info:
 major_brand: isom
 minor_version: 512
 compatible_brands: isomiso2avc1mp41
 encoder: Lavf58.2.103
Load subtitles in ./
SUB: Added subtitle file (1): ./Movie.srt


MPlayer interrupted by signal 2 in module: read_subtitles_file

Of course I stop it using SIGINT. After couple of minutes.

Attachments (1)

Movie.txt (313 bytes) - added by bozydarek 5 months ago.
trimed to first 10 lines

Download all attachments as: .zip

Change History (4)

comment:1 Changed 5 months ago by beastd

Hi! Thank you for reporting the issue.

Unfortunately I am not able to reproduce the problem.

Could you try to find out if the issue is related to the contents of Movie.txt?

E.g. try to play the file with only the Movie.txt file in the same folder.

comment:2 Changed 5 months ago by bozydarek

  • Resolution set to invalid
  • Status changed from new to closed

Apparently it was my fault. On the end of subtitle file (Movie.txt) there was bunch of Chinese characters (I don't know why, and I don't check it earlier). Sorry for that.


Edit: There is some problem with this file encoding. Actually I can access it without any problems only with console programs like vim.

Last edited 5 months ago by bozydarek (previous) (diff)

comment:3 Changed 5 months ago by beastd

Could you provide the subtitle file that caused the problem for you?

Or maybe a trimmed version that still triggers the issue.

Changed 5 months ago by bozydarek

trimed to first 10 lines

Note: See TracTickets for help on using tickets.