Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#24 closed defect (invalid)

compile error in libavcodec/ffv1.c line 465 on Suse 9.0

Reported by: mplayer@… Owned by: alex@…
Priority: normal Component: core
Version: 1.0pre5 Severity: normal
Keywords: VERIFIED Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

sample[p][i]=sample_buffer[p][(h+i-y)%ring_size]+3;

does not compile

sample[p][i]=sample_buffer[p][(h+i-y)%ring_size];

sample[p][i]=sample[p][i]+3;


does.
Duh. I don't know what I am doing. Suse 9.0, professional, no further info
provided. I just hope someone can make sense of it.
Oh it reported 'internal compiler error'.
-Ace

Change History (2)

comment:1 Changed 15 years ago by r_togni@…

  • Resolution set to invalid
  • Status changed from new to closed

Not an Mplayer bug.
Report to Suse compliler packager.

comment:2 Changed 15 years ago by diego@…

  • Keywords VERIFIED added

I have no idea why it is so hard to guess that "internal compiler error" is a
problem that is internal to the COMPILER. Nevertheless it happens again and
again. VERIFIED.

Ace, no harm intended, but please try to provide more information next time and
first determine where the problem lies before reporting a bug where it does not
belong.

Note: See TracTickets for help on using tickets.