Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#247 closed defect (fixed)

minor bug in mplayer with m4a-type file

Reported by: avl@… Owned by: alex@…
Priority: normal Component: ad
Version: HEAD Severity: minor
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

The Problem:

When I skip forward or backward in a .m4a file, the "audio position
in seconds" in the status line is always reset to zero. (the skipping
operation itself goes ok, it's really only the counter that's reset)

For Diagnosis:
When I play such a ".m4a" file, my version of mplayer writes:
" MPlayer dev-CVS-050228-14:37-3.3.5 (C) 2000-2005 MPlayer Team
and
" MOV: Found MPEG4 audio Elementary Stream Descriptor atom (51)!
" Fourcc: mp4a
and
" Opening audio decoder: [faad] AAC (MPEG2/4 Advanced Audio Coding)
" AUDIO: 44100 Hz, 2 ch, s16le, 128.0 kbit/9.07% (ratio: 16000->176400)
" Selected audio codec: [faad] afm:faad (FAAD AAC (MPEG2/MPEG4 Audio) decoder)

It happens with *all* of a couple of m4a-files that I tried.
These files were all audio-only.
It does not seem to happen with any other file-types I tried.
This makes me think it cannot be OS/platform/audio-system-specific.
Anyway, I'm using oss(not alsa) on Linux 2.6.5 (debian sarge)

If there exists a .m4a file (type mp4a) where this symptom is not
reproducable, I'll try to make a (legally) distributable version
of one of my .m4a's or have someone create one for me. (Something
I'd really prefer not to do, unless strictly necessary)

Change History (3)

comment:1 Changed 14 years ago by avl@…

Just in case, my description of the Problem is not clear, yet:

I play an .m4a-file, and let it play e.g. for a minute.

At that time, the status line shows something like:

A: 60.0 00:01:00.0 ...

Then I press Cursor-Up (to skip forward by one minute)
and the audiostream correctly skips one minute,
but the status-line says (immediately after skipping)
A: 0.0 00:00:00.0

Letting it play till end, the final status-line shows that
one minute less than the real playing time of that file.

The same, principially, happens with smaller skips and
with backskips.

comment:2 Changed 14 years ago by avl@…

damn again. in the end it shows two minutes less
than the total playing time (both the previously
played minute and the skipped minute are not counted)

comment:3 Changed 14 years ago by reimar

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in CVS.

Note: See TracTickets for help on using tickets.