Opened 14 years ago

Closed 13 years ago

Last modified 13 years ago

#248 closed defect (fixed)

can't play hirtv.asf from www.hirtv.hu

Reported by: balazs.konya@… Owned by: moritz@…
Priority: normal Component: demuxer
Version: 1.0pre6 Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

hi,

Mplayer fails to play the hirtv.asf from www.hirtv.hu.

I have the
MPlayer 1.0pre6-3.4.1 (C) 2000-2004 MPlayer Team
version installed and capable playing some other .asf formats,
for example

mplayer -playlist http://w3.cantos.com/04/ebrd-403-4m5xf/video/ebrd-h001-nb-v-1.asx

works just fine.

But mplayer fails against the hirtv site (see below).


mplayer -v -playlist http://www.hirtv.net/adas.asx
MPlayer 1.0pre6-3.4.1 (C) 2000-2004 MPlayer Team
CPU: Intel Celeron 2/Pentium III Coppermine,Geyserville (Family: 6, Stepping: 6)
Detected cache-line size is 32 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 SSE

Resolving www.hirtv.net for AF_INET6...
Couldn't resolve name for AF_INET6: www.hirtv.net
Resolving www.hirtv.net for AF_INET...
Connecting to server www.hirtv.net[195.70.35.150]:80 ...
Cache size set to 320 KBytes
Connected to server: www.hirtv.net
This codecs.conf is too old and incompatible with this MPlayer release! at line 6
CommandLine?: '-v' '-playlist' 'http://www.hirtv.net/adas.asx'
init_freetype
get_path('font/font.desc') -> '/home/balazs/.mplayer/font/font.desc'
Font /home/balazs/.mplayer/font/font.desc loaded successfully! (206 chars)
Using MMX (with tiny bit MMX2) Optimized OnScreenDisplay?
Failed to open /dev/rtc: No such file or directory (it should be readable by the
user.)
Using nanosleep() timing
get_path('input.conf') -> '/home/balazs/.mplayer/input.conf'
Can't open input config file /home/balazs/.mplayer/input.conf: No such file or
directory
Can't open input config file /usr/local/etc/mplayer/input.conf: No such file or
directory
Falling back on default (hardcoded) input config
get_path('hirtv.asf.conf') -> '/home/balazs/.mplayer/hirtv.asf.conf'
Playing http://media01.interware.hu/hirtv.asf.
Filename for url is now http://media01.interware.hu/hirtv.asf
Filename for url is now http://media01.interware.hu/hirtv.asf
Resolving media01.interware.hu for AF_INET6...
Couldn't resolve name for AF_INET6: media01.interware.hu
Resolving media01.interware.hu for AF_INET...
Connecting to server media01.interware.hu[195.70.32.162]:80 ...
--- HTTP DEBUG HEADER --- START ---
protocol: [HTTP/1.0]
http minor version: [0]
uri: [(null)]
method: [(null)]
status code: [200]
reason phrase: [OK]
body size: [0]
Fields:

0 - Content-type: application/octet-stream
1 - Server: Cougar 4.1.0.3921
2 - Pragma: no-cache
3 - Pragma: client-id=20813
4 - Pragma: features="broadcast"
5 - Cache-Control: no-cache

--- HTTP DEBUG HEADER --- END ---
Content-Type: [application/octet-stream]
Cache size set to 320 KBytes
Connected to server: media01.interware.hu
CACHE_PRE_INIT: 0 [0] 0 pre:0 eof:0
Cache fill: 0.26% (861 bytes) Checking for YUV4MPEG2
ASF_check: not ASF guid!
Checking for Nullsoft Streaming Video
Checking for NuppelVideo?
Checking for REAL
Checking for SMJPEG
Searching demuxer type for filename http://media01.interware.hu/hirtv.asf ext: .asf
Trying demuxer 6 based on filename extension
ASF_check: not ASF guid!
demuxer: continue fuzzy content-based format guessing...
Checking for MOV
Checking for VIVO
header block 1 size: 72
Checking for PVA
Checking for MPEG-TS...
COULDN'T READ ENOUGH DATA, EXITING TS_CHECK
Checking for LMLM4 Stream Format
Invalid packet in LMLM4 stream: ch=9288 size=-8
LMLM4 Stream Format not found
MPEG Stream reached EOF
ds_fill_buffer: EOF reached (stream: video)
MPEG packet stats: p100: 6 p101: 1 p1B6: 0 p12x: 0 sli: 1 a: 1 b: 0 c: 0 idr: 0
sps: 0 pps: 0 PES: 2 MP3: 0
Not MPEG System Stream format... (maybe Transport Stream?)
ds_fill_buffer: EOF reached (stream: video)
LAVF_check: no clue about this gibberish!

vo: x11 uninit called but X11 not inited..

Exiting... (End of file)

Change History (8)

comment:1 Changed 14 years ago by reimar

The problem is that the asf stream header (denoted by the {0x91, 0x07, 0xdc, 0xb7,

0xb7, 0xa9, 0xcf, 0x11, 0x8e, 0xe6, 0x00, 0xc0, 0x0c, 0x20, 0x53, 0x65} guid)

is not at the start of the file... No fix for that yet though.

comment:2 Changed 14 years ago by balazs.konya@…

ok, just made a quick try with the MPlayer 1.0pre7-3.3.2 release:

---
mplayer -playlist http://www.hirtv.net/adas.asx
MPlayer 1.0pre7-3.3.2 (C) 2000-2005 MPlayer Team
CPU: Intel Pentium 4/Xeon/Celeron Northwood (Family: 8, Stepping: 3)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2

Resolving www.hirtv.net for AF_INET6...
Couldn't resolve name for AF_INET6: www.hirtv.net
Resolving www.hirtv.net for AF_INET...
Connecting to server www.hirtv.net[195.70.35.150]:80 ...
Cache size set to 320 KBytes
Connected to server: www.hirtv.net
Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup
scripts.
Playing http://media01.interware.hu/hirtv.asf.
Resolving media01.interware.hu for AF_INET6...
Couldn't resolve name for AF_INET6: media01.interware.hu
Resolving media01.interware.hu for AF_INET...
Connecting to server media01.interware.hu[195.70.32.162]:80 ...
Cache size set to 320 KBytes
Connected to server: media01.interware.hu
Cache fill: 0.26% (861 bytes) Win32 LoadLibrary? failed to load:
avisynth.dll, /usr/local/codecs/avisynth.dll, /usr/lib/win32/avisynth.dll,
/usr/local/lib/win32/avisynth.dll
---

as far as I see the avisynth.dll is not distributed in any of the codecs.
I chcked both windows-all-20050412.zip and all-20050412.tar and windows-essential

comment:3 Changed 14 years ago by reimar

mmshttp://media01.interware.hu/hirtv.asf works btw.

comment:4 Changed 14 years ago by balazs.konya@…

Thanks!

indeed

mplayer mmshttp://media01.interware.hu/hirtv.asf

works while

mplayer http://media01.interware.hu/hirtv.asf

fails.

comment:5 Changed 14 years ago by zuxy.meng@…

Or try the following patch:

--- main/libmpdemux/network.c Tue Oct 18 17:14:56 2005
+++ main.new/libmpdemux/network.c Wed Nov 2 14:07:36 2005
@@ -72,6 +72,9 @@

{ "video/x-ms-wvx", DEMUXER_TYPE_ASF },
{ "video/x-ms-wmv", DEMUXER_TYPE_ASF },
{ "video/x-ms-wma", DEMUXER_TYPE_ASF },

+ { "application/x-mms-framed", DEMUXER_TYPE_ASF },
+ { "application/vnd.ms.wms-hdr.asfv1", DEMUXER_TYPE_ASF },
+ { "application/octet-stream", DEMUXER_TYPE_ASF },

Playlists
{ "video/x-ms-wmx", DEMUXER_TYPE_PLAYLIST },
{ "audio/x-scpls", DEMUXER_TYPE_PLAYLIST },

comment:6 Changed 14 years ago by balazs.konya@…

hi

Tried the patch, it solves the problem, both

./mplayer http://media01.interware.hu/hirtv.asf

./mplayer mmshttp://media01.interware.hu/hirtv.asf

url gets played with mplayer (though the quality is rather poor)

I also tested the
./mplayer -v -playlist http://www.hirtv.net/adas.asx

which is OK too.

I assume someone can close this bug.

comment:7 Changed 13 years ago by balazs.konya@…

Anyone is taking care of this bug?

The patch proposed by Zuxy Meng should be added to the CVS, then the bug can be
closed.

Regards,
Balazs

comment:8 Changed 13 years ago by diego@…

  • Resolution set to fixed
  • Status changed from new to closed

The patch from Zuxy Meng was just committed to CVS.

Note: See TracTickets for help on using tickets.