Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#258 closed defect (fixed)

Mplayer binary is marked PT_GNU_STACK RWE

Reported by: ivg2@… Owned by: alex@…
Priority: normal Component: core
Version: 1.0pre6 Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

The mplayer binary is marked PT_GNU_STACK RWE when compiled with binary codecs
support. This results in problems when running mplayer in an environment which
places restrictions against executable stack. One such environment is the
SElinux strict policy, part of Fedora Core.

It was concluded on mplayer-list that executable stack should not be required,
for binary codecs which are maintained (since they wouldn't work with
an enhanced version of windows with non-exec stack). The attached patch was
proposed to fix the problem, and has yet to be integrated, I believe.
A complaint was raised that a configure check is needed to verify
whether this flag is supported.

Also consider ld on Linux:

-z KEYWORD Ignored for Solaris compatibility

Attachments (1)

noexecstack.diff (1.5 KB) - added by ivg2@… 14 years ago.
The proposed patch

Download all attachments as: .zip

Change History (6)

Changed 14 years ago by ivg2@…

The proposed patch

comment:1 Changed 14 years ago by ivg2@…

comment:2 Changed 14 years ago by poirierg@…

I tested this patch on a i386 NX-bit enabled AMD-64, and there are just no
problem with it.

comment:3 Changed 14 years ago by reimar

  • Resolution set to fixed
  • Status changed from new to closed

Applied to get it some testing.

comment:4 Changed 14 years ago by reimar

  • Resolution fixed deleted
  • Status changed from closed to reopened

Reversed due to portability problems with at least MacOSX and Solaris 9

comment:5 Changed 14 years ago by reimar

  • Resolution set to fixed
  • Status changed from reopened to closed

Implemented via a more portable configure check, hope it will stay in this time *g*

Note: See TracTickets for help on using tickets.