Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#263 closed defect (worksforme)

"mplayer http://www.spiegel.de/video/0,4916,7867,00.htm" crashes

Reported by: toralf.foerster@… Owned by: moritz@…
Priority: normal Component: demuxer
Version: 1.0pre5 Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Here is the output:
tfoerste@nhh221 /usr/share/doc/mplayer-1.0_pre5-r5 $ mplayer
http://www.spiegel.de/video/0,4916,7867,00.html
MPlayer 1.0pre5try2-3.3.5 (C) 2000-2004 MPlayer Team

CPU: Intel 999.6 MHz (Family: 6, Stepping: 6)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Kompiliert für x86 CPU mit folgenden Erweiterungen: MMX MMX2 SSE SSE2

Reading config file /usr/share/mplayer/mplayer.conf
Reading config file /home/tfoerste/.mplayer/config
Reading /home/tfoerste/.mplayer/codecs.conf: Can't open
'/home/tfoerste/.mplayer/codecs.conf': No such file or directory
Reading /usr/share/mplayer/codecs.conf: 73 audio & 180 video codecs
font: can't open file: /home/tfoerste/.mplayer/font/font.desc
Font /usr/share/mplayer/font/font.desc loaded successfully! (206 chars)
Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup
scripts.
Using usleep() timing
Can't open input config file /home/tfoerste/.mplayer/input.conf: No such file or
directory
Input config file /usr/share/mplayer/input.conf parsed: 53 binds
Opening joystick device /dev/input/js0
Can't open joystick device /dev/input/js0 : No such file or directory
Can't init input joystick

Spiele http://www.spiegel.de/video/0,4916,7867,00.html
Resolving www.spiegel.de for AF_INET...
Connecting to server www.spiegel.de[195.71.11.67]:80 ...
Cache size set to 8192 KBytes
Verbunden mit Server: www.spiegel.de
Cache fill: 0.05% (4155 bytes) XMMS: found plugin: libmp4.so (MP4 &
MPEG2/4-AAC audio player - 1.2.x)
XMMS: found plugin: libxmms-flac.so (Reference FLAC Player v1.1.0)
XMMS: found plugin: libmikmod.so (MikMod? Player 1.2.10)
XMMS: found plugin: libvorbis.so (Ogg Vorbis Player 1.2.10)
XMMS: found plugin: libxmmsmad.so (MAD MPEG Decoder plugin 0.8)

MPlayer wurde durch Signal 11 im Modul demux_open unterbrochen

  • MPlayer stürzte wegen falscher Benutzung der CPU/FPU/des RAMs ab. Kompiliere MPlayer erneut mit --enable-debug und erstelle mit 'gdb' einen Backtrace und eine Disassemblierung. Details dazu findest du in DOCS/de/bugreports.html.
  • MPlayer ist abgestürzt. Das sollte nicht passieren. Es kann sich um einen Fehler im MPlayer-Code _oder_ in deinen Treibern _oder_ in deinem gcc handeln. Wenn du meinst, es sei MPlayers Fehler, dann lies DOCS/de/bugreports.html und folge den dortigen Anweisungen. Wir können und werden dir nicht helfen, wenn du nicht alle dort aufgeführten Informationen zur Verfügung stellst.

More informations:
tfoerste@nhh221 /usr/share/doc/mplayer-1.0_pre5-r5 $ uname -a
Linux nhh221 2.6.11-gentoo-r4 #1 Fri Mar 18 10:27:24 CET 2005 i686 Intel(R)
Pentium(R) M processor 1.70GHz GenuineIntel? GNU/Linux
tfoerste@nhh221 /usr/share/doc/mplayer-1.0_pre5-r5 $ qpkg -I -v -nc mplayer
net-www/mplayerplug-in-2.66
media-video/mplayer-1.0_pre5-r5
tfoerste@nhh221 /usr/share/doc/mplayer-1.0_pre5-r5 $ qpkg -I -v -nc mpeg
media-libs/smpeg-0.4.4-r4
media-libs/libmpeg3-1.5.2
media-video/ffmpeg-0.4.7
media-video/mpeg2vidcodec-12-r1

Change History (1)

comment:1 Changed 15 years ago by r_togni@…

  • Resolution set to worksforme
  • Status changed from new to closed

MPlayer is not a web browser. Open that page in a web browser with a media
player plugin.
Else get the direct link for the video (Video im externen Player öffnen) and use
mplayer -playlist put_video_link_here. Note that you have to use -playlist
explicitely for playlist files (like the .ram file on that site), because
mplayer can't autodetect them.
Tested with cvs, pre5 is obsolete.
BTW i get no crash if i try to play the html link.

Note: See TracTickets for help on using tickets.