Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#271 closed defect (fixed)

1.0pre6-3.3.4 MPlayer rtsp:// url crash

Reported by: jg@… Owned by: r_togni@…
Priority: important Component: demuxer
Version: 1.0pre6 Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Crash verified by two other people, one on win32 on #mplayer channel, rxt and Compn.

$ mplayer --verbose
rtsp://rm.bbc.net.uk:7070/news/media/video/40939000/rm/_40939079_oil22_palast17_vi.rm
MPlayer 1.0pre6-3.3.4 (C) 2000-2004 MPlayer Team
CPU: Advanced Micro Devices Athlon MP/XP/XP-M Barton (Family: 6, Stepping: 0)
Detected cache-line size is 64 bytes
MMX2 supported but disabled
3DNow supported but disabled
3DNowExt supported but disabled
CPUflags: MMX: 1 MMX2: 0 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 0
Compiled for x86 CPU with extensions: MMX SSE

Opening joystick device /dev/input/js0
Can't open joystick device /dev/input/js0 : No such file or directory
Can't init input joystick
Setting up LIRC support...
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support.
You will not be able to use your remote control.
Playing
rtsp://rm.bbc.net.uk:7070/news/media/video/40939000/rm/_40939079_oil22_palast17_vi.rm.
Resolving rm.bbc.net.uk for AF_INET6...
Couldn't resolve name for AF_INET6: rm.bbc.net.uk
Resolving rm.bbc.net.uk for AF_INET...
Connecting to server rm.bbc.net.uk[212.58.224.62]:7070 ...
librtsp: server responds: 'h$Ant: RealMedia? Player Version 6.0.9.1235
(linux-2.0-libc6-i386-gcc2.95)'

MPlayer interrupted by signal 11 in module: open_stream

  • MPlayer crashed by bad usage of CPU/FPU/RAM. Recompile MPlayer with --enable-debug and make a 'gdb' backtrace and disassembly. Details in DOCS/HTML/en/bugreports_what.html#bugreports_crash.
  • MPlayer crashed. This shouldn't happen. It can be a bug in the MPlayer code _or_ in your drivers _or_ in your gcc version. If you think it's MPlayer's fault, please read DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and won't help unless you provide this information when reporting a possible bug.

it also crashes on the url without hte port:

rtsp://rm.bbc.net.uk/news/media/video/40939000/rm/_40939079_oil22_palast17_vi.rm

It seems to be a crash because the file does not exist.
Cheers
JG

Change History (7)

comment:1 Changed 14 years ago by dominik@…

Fine. Now read
http://www.mplayerhq.hu/DOCS/HTML/en/bugreports_what.html#bugreports_crash and
come back with more detailed results, please.

comment:2 Changed 14 years ago by jg@…

Hi dominik@…,
Thank you for your comment.
I do not have source on this machine or the time to provide more detailed info
at present. Could you provide the details if you really need them? The case was
easily reproducable, a backtrace and debug log is not essential.

Regards

comment:3 Changed 14 years ago by r_togni@…

  • Status changed from new to assigned

I'm on it, i probably already got the reason of the sig11; the server is
answering nonsense and mplayer does not like it :)

comment:4 Changed 14 years ago by r_togni@…

  • Owner changed from moritz@… to r_togni@…
  • Status changed from assigned to new

comment:5 Changed 14 years ago by r_togni@…

  • Status changed from new to assigned

comment:6 Changed 14 years ago by jg@…

Hi Roberto, Execlent newss, thank you for working on this bug fix.
Kind regards
JG

comment:7 Changed 14 years ago by r_togni@…

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed in CVS.
Does not crash anymore, and the url is unplayable (even with realplayer).

Note: See TracTickets for help on using tickets.