Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#290 closed defect (invalid)

Quicktime file has no sound

Reported by: ismail@… Owned by: alex@…
Priority: normal Component: ad
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Download
http://images.apple.com/movies/us/apple/tiger_sitedemos/apple-tiger-safari_rss.mov and try to
play. Play it and notice that you hear no sound but no codec error either. Here is the execution :

opt/development/cvs/mplayer> mplayer -v ~/apple-tiger-safari_rss.mov
MPlayer dev-CVS-050428-19:34-3.4.4 (C) 2000-2005 MPlayer Team
CPU: Advanced Micro Devices (Family: 8, Stepping: 10)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx SSE SSE2


CommandLine?: '-v' '/home/cartman/apple-tiger-safari_rss.mov'
init_freetype
Using MMX (with tiny bit MMX2) Optimized OnScreenDisplay?
Using Linux hardware RTC timing (1024Hz).
get_path('input.conf') -> '/home/cartman/.mplayer/input.conf'
Parsing input config file /home/cartman/.mplayer/input.conf
Input config file /home/cartman/.mplayer/input.conf parsed: 1 binds
get_path('apple-tiger-safari_rss.mov.conf') ->
'/home/cartman/.mplayer/apple-tiger-safari_rss.mov.conf'
Playing /home/cartman/apple-tiger-safari_rss.mov.
[file] File size is 20907443 bytes
STREAM: [file] /home/cartman/apple-tiger-safari_rss.mov
STREAM: Description: File
STREAM: Author: Albeu
STREAM: Comment: based on the code from ??? (probably Arpi)
Checking for YUV4MPEG2
ASF_check: not ASF guid!
Checking for Nullsoft Streaming Video
Checking for NuppelVideo?
Checking for REAL
Checking for SMJPEG
Searching demuxer type for filename /home/cartman/apple-tiger-safari_rss.mov ext: .mov
Trying demuxer 7 based on filename extension
Checking for MOV
MOV: Movie header found!
MOV: 'WIDE' chunk found!
MOV: Movie DATA found!
QuickTime?/MOV file format detected.
MOV: Movie header (100 bytes): tscale=30 dur=2696


MOV: Track #0:
MOV: Track header!
tkhd len=84 ver=0 flags=0x0 id=1 dur=2696 lay=0 vol=0
MOV: Edit atom!
MOV: Edit list table (1 entries) (ver:0,flags:0)
MOV: entry#0: duration: 2696 start time: 0 speed: 1.0x
MOV: Media stream!
MOV: Media header!
MOV: Handler header: mhlr/vide (appl) Apple Video Media Handler
MOV: Media info!
MOV: Video header!
MOV: Handler header: dhlr/alis (appl) Apple Alias Data Handler
MOV: unknown chunk: dinf 28
MOV: Sample info!
MOV: Description list! (cnt:1)
MOV: desc #0: rle (70 bytes)
MOV: Sample duration table! (1 blocks)
MOV: Syncing samples (keyframes) table! (1 entries) (ver:0,flags:0)
MOV: Sample->Chunk mapping table! (251 blocks) (ver:0,flags:0)
MOV: Sample size table! (entries=2696 ss=0) (ver:0,flags:0)
MOV: Chunk offset table! (306 chunks)
MOV track #0: 306 chunks, 2696 samples
pts=2696 scale=30 time=89.867
EL#0: pts=0 1st_sample=0 frames=2696 (89.867s) pts_offs=0
==> Found video stream: 0
Image size: 640 x 360 (24 bpp)
Display size: 640 x 360
Fourcc: rle Codec: 'Animation'


MOV: Track #1:
MOV: Track header!
tkhd len=84 ver=0 flags=0x0 id=2 dur=2695 lay=0 vol=256
MOV: Edit atom!
MOV: Edit list table (1 entries) (ver:0,flags:140733193388032)
MOV: entry#0: duration: 2695 start time: 0 speed: 1.0x
MOV: Media stream!
MOV: Media header!
MOV: Handler header: mhlr/soun (appl) Apple Sound Media Handler
MOV: Media info!
MOV: Sound header!
MOV: Handler header: dhlr/alis (appl) Apple Alias Data Handler
MOV: unknown chunk: dinf 28
MOV: Sample info!
MOV: Description list! (cnt:1)
MOV: desc #0: mp4a (139 bytes)
MOV: Sample duration table! (1 blocks)
MOV: Sample->Chunk mapping table! (375 blocks) (ver:0,flags:0)
MOV: Sample size table! (entries=3869 ss=0) (ver:0,flags:0)
MOV: Chunk offset table! (376 chunks)
MOV track #1: 376 chunks, 3869 samples
pts=3961856 scale=44100 time=89.838
EL#0: pts=0 1st_sample=0 frames=3869 (89.833s) pts_offs=0
==> Found audio stream: 1
Audio bits: 16 chans: 2 rate: 44100
Audio header: samp/pack=1024 bytes/pack=1536 bytes/frame=2 bytes/samp=2
Audio extra header: len=103 fcc=0x77617665
MOV: Found MPEG4 audio Elementary Stream Descriptor atom (51)!
ESDS MPEG4 version: 0 flags: 0x000000
ESDS MPEG4 ES Descriptor (34Bytes):

-> ESId: 0
-> streamPriority: 0

ESDS MPEG4 Decoder Config Descriptor (20Bytes):

-> objectTypeId: 64
-> streamType: 0x15
-> bufferSizeDB: 0x001800
-> maxBitrate: 160.000kbit/s
-> avgBitrate: 160.000kbit/s

ESDS MPEG4 Decoder Specific Descriptor (2Bytes)
ESDS MPEG4 Sync Layer Config Descriptor (1Bytes)

-> predefined: 2

Fourcc: mp4a


Quicktime Clip Info:

Name: Apple 10.4 (Tiger) Feature Demo
Info: www.apple.com
Copyright: 2004 Apple Computer, Inc. All rights reserved

MOV: longest streams: A: #1 (3869 samples) V: #0 (2696 samples)
VIDEO: [rle ] 640x360 24bpp 30.000 fps 0.0 kbps ( 0.0 kbyte/s)
[V] filefmt:7 fourcc:0x20656C72 size:640x360 fps:30.00 ftime:=0.0333
Clip info:

name: Apple 10.4 (Tiger) Feature Demo
copyright: 2004 Apple Computer, Inc. All rights reserved

get_path('sub/') -> '/home/cartman/.mplayer/sub/'
get_path('default.sub') -> '/home/cartman/.mplayer/default.sub'
==========================================================================
Opening audio decoder: [faad] AAC (MPEG2/4 Advanced Audio Coding)
dec_audio: Allocating 4608 bytes for input buffer.
dec_audio: Allocating 49152 + 65536 = 114688 bytes for output buffer.
FAAD: Decoder init done (0Bytes)!
FAAD: Negotiated samplerate: 44100Hz channels: 2
FAAD: got 160kbit/s bitrate from MP4 header!
AUDIO: 44100 Hz, 2 ch, s16le, 160.0 kbit/11.34% (ratio: 20000->176400)
Selected audio codec: [faad] afm:faad (FAAD AAC (MPEG2/MPEG4 Audio) decoder)
==========================================================================
X11 opening display: :0.0
vo: X11 color mask: FFFFFF (R:FF0000 G:FF00 B:FF)
vo: X11 running at 1280x1024 with depth 24 and 32 bpp (":0.0" => local display)
[x11] Detected wm supports NetWM.
[x11] Detected wm supports FULLSCREEN state.
[x11] Detected wm supports ABOVE state.
[x11] Detected wm supports BELOW state.
[x11] Detected wm supports STAYS_ON_TOP state.
[x11] Current fstype setting honours FULLSCREEN STAYS_ON_TOP ABOVE BELOW X atoms
Disabling DPMS
DPMSDisable stat: 1
[xv common] Drawing no colorkey.
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
INFO: libavcodec init OK!
Selected video codec: [ffqtrle] vfm:ffmpeg (QuickTime? Animation (RLE))
==========================================================================
Checking audio filter chain for 44100Hz/2ch/s16le -> 44100Hz/2ch/s16le...
[libaf] Adding filter dummy
[dummy] Was reinitialized: 44100Hz/2ch/s16le
AF_pre: 44100Hz/2ch/s16le
alsa-init: requested format: 44100 Hz, 2 channels, 9
alsa-init: compiled for ALSA-1.0.8
alsa-init: setup for 1/2 channel(s)
alsa-init: 1 soundcard found, using: default
alsa-init: pcm opend in block-mode
alsa-init: chunksize set to 1024
alsa-init: fragcount=16
alsa-init: got buffersize=65536
alsa: 44100 Hz/2 channels/4 bpf/65536 bytes buffer/Signed 16 bit Little Endian
AO: [alsa] 44100Hz 2ch s16le (2 bps)
AO: Description: ALSA-0.9.x-1.x audio output
AO: Author: Alex Beregszaszi, Zsolt Barat <joy@…>
AO: Comment: under developement
Building audio filter chain for 44100Hz/2ch/s16le -> 44100Hz/2ch/s16le...
[dummy] Was reinitialized: 44100Hz/2ch/s16le
[dummy] Was reinitialized: 44100Hz/2ch/s16le
Starting playback...
alsa-space: free space = 65536, prepared --
[ffmpeg] aspect_ratio: 0.000000
VDec: vo config request - 640 x 360 (preferred csp: RGB 24-bit)
Trying filter chain: vo
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
SwScale? params: -1 x -1 (-1=no scaling)
Trying filter chain: scale vo
VDec: using RGB 24-bit as output csp (no 1)
Movie-Aspect is undefined - no prescaling applied.
VO Config (640x360->640x360,flags=0,'MPlayer',0x52474218)
SwScaler?: reducing / aligning filtersize 1 -> 4
SwScaler?: reducing / aligning filtersize 1 -> 4
SwScaler?: reducing / aligning filtersize 1 -> 1
SwScaler?: reducing / aligning filtersize 9 -> 8

SwScaler?: BICUBIC scaler, from RGB 24-bit to Planar YV12 using MMX2
SwScaler?: using 4-tap MMX scaler for horizontal luminance scaling
SwScaler?: using 4-tap MMX scaler for horizontal chrominance scaling
SwScaler?: using 1-tap MMX "scaler" for vertical scaling (YV12 like)
SwScaler?: 640x360 -> 640x360
REQ: flags=0x437 req=0x0
VO: [xv] 640x360 => 640x360 Planar YV12
VO: Description: X11/Xv
VO: Author: Gerd Knorr <kraxel@…> and others
Xvideo image format: 0x32595559 (YUY2) packed
Xvideo image format: 0x32315659 (YV12) planar
Xvideo image format: 0x59565955 (UYVY) packed
Xvideo image format: 0x30323449 (I420) planar
using Xvideo port 177 for hw scaling
[xv] dx: 0 dy: 0 dw: 640 dh: 384
[x11] NET style stay on top (layer 1). Using state _NET_WM_STATE_STAYS_ON_TOP.
* [scale] Allocating mp_image_t, 640x368x24bpp RGB packed, 706560 bytes
* [vo] Allocating mp_image_t, 640x360x12bpp YUV planar, 345600 bytes
Unicode font: 255 glyphs.
[xv] dx: 0 dy: 0 dw: 640 dh: 384
Uninit audio filters... 0.019 ct: 0.015 142/142 0% 15% 0.9% 0 0
[libaf] Removing filter dummy
uninit audio: faad
FAAD: Closing decoder!
uninit video: ffmpeg
Successfully enabled DPMS
alsa-uninit: pcm closed
vo: uninit ...

Exiting... (Quit)

Change History (2)

comment:1 Changed 14 years ago by ismail@…

  • Component changed from ad to demuxer

Changing product to demuxer because I can hear sound in mkv+aac+xvid sample

comment:2 Changed 14 years ago by diego@…

  • Component changed from demuxer to ad
  • Resolution set to invalid
  • Status changed from new to closed

Just tried the URL in QuickTime? 7 on Mac OS X, there is no sound...

Note: See TracTickets for help on using tickets.