Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#295 closed defect (worksforme)

Framedrop errors in H.264

Reported by: ariel_gonz@… Owned by: lorenm@…
Priority: normal Component: libavcodec
Version: unspecified Severity: minor
Keywords: FFmpeg Cc: diego@…
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Click the "Download 1080 Version (129Mb)" link to download the MOV. When playing
with mplayer 1.0pre7 and the essential-20050412.tar.bz2 plugins, the video is
shown but with heavy artifacting and frame dropping. Machine speed should not be
a problem as I am able to play other 1080p movies.

During playback, the following errors will be shown on the console:
[h264 @ 009E3CB8]concealing 4896 DC, 4896 AC, 4896 MV errors
[h264 @ 009E3CB8]illegal short term buffer state detected
The "concealing" error will appear quite often, while the "illegal" message will
be displayed less frequently. These lines were not saved piped to the file while
doing "mplayer > textfile" and I will append a bigger sample at the bottom. Here
are my system specs and verbose output log.

Windows 2000 SP4
ATI Radeon X800 XL, Catalyst 5.4
AMD Athlon64 3000+, 1GB RAM

MPlayer 1.0pre7-3.4.2 (C) 2000-2005 MPlayer Team
CPU: Advanced Micro Devices (Family: 8, Stepping: 0)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 0 SSE2: 0
Compiled with runtime CPU detection - WARNING - this is not optimal!
To get best performance, recompile MPlayer with --disable-runtime-cpudetection.

CommandLine?: '-v' 'F:\Movies\Trailers\Serenity (H.264, 1080p).mov'
init_freetype
Using MMX (with tiny bit MMX2) Optimized OnScreenDisplay?
Using Windows native timing
get_path('input.conf') -> 'C:/bin/mplayer/mplayer/input.conf'
Parsing input config file C:/bin/mplayer/mplayer/input.conf
Input config file C:/bin/mplayer/mplayer/input.conf parsed: 53 binds
get_path('F:\Movies\Trailers\Serenity (H.264, 1080p).mov.conf') ->
'C:/bin/mplayer/mplayer/F:\Movies\Trailers\Serenity (H.264, 1080p).mov.conf'
Playing F:\Movies\Trailers\Serenity (H.264, 1080p).mov.
WINSOCK2 init: 0
[file] File size is 145184114 bytes
STREAM: [file] F:\Movies\Trailers\Serenity (H.264, 1080p).mov
STREAM: Description: File
STREAM: Author: Albeu
STREAM: Comment: based on the code from ??? (probably Arpi)
Checking for YUV4MPEG2
ASF_check: not ASF guid!
Checking for Nullsoft Streaming Video
Checking for NuppelVideo?
Checking for REAL
Checking for SMJPEG
Searching demuxer type for filename F:\Movies\Trailers\Serenity (H.264,
1080p).mov ext: .mov
Trying demuxer 7 based on filename extension
Checking for MOV
ISO: File Type Major Brand: Original QuickTime?
ISO: File Type Minor Version: 537199360
ISO: File Type Compatible Brand #0: qt
ISO: File Type Compatible Brand #1:
ISO: File Type Compatible Brand #2:
ISO: File Type Compatible Brand #3:
MOV: Movie header found!
MOV: 'WIDE' chunk found!
MOV: Movie DATA found!
QuickTime?/MOV file format detected.
MOV: Movie header (100 bytes): tscale=600 dur=85032


MOV: Track #0:
MOV: Track header!
tkhd len=84 ver=0 flags=0x0 id=1 dur=85032 lay=0 vol=256
MOV: Edit atom!
MOV: Edit list table (1 entries) (ver:0,flags:0)
MOV: entry#0: duration: 85032 start time: 0 speed: 1.0x
MOV: Media stream!
MOV: Media header!
MOV: Handler header: mhlr/soun (appl) Apple Sound Media Handler
MOV: Media info!
MOV: Sound header!
MOV: Handler header: dhlr/alis (appl) Apple Alias Data Handler
MOV: unknown chunk: dinf 28
MOV: Sample info!
MOV: Description list! (cnt:1)
MOV: desc #0: mp4a (151 bytes)
MOV: Sample duration table! (1 blocks)
MOV: Sample->Chunk mapping table! (846 blocks) (ver:0,flags:0)
MOV: Sample size table! (entries=6644 ss=0) (ver:0,flags:0)
MOV: Chunk offset table! (846 chunks)
MOV track #0: 846 chunks, 6644 samples
pts=6803456 scale=48000 time=141.739
EL#0: pts=0 1st_sample=0 frames=6644 (141.720s) pts_offs=0
==> Found audio stream: 0
Audio bits: 16 chans: 2 rate: 48000
Audio header: samp/pack=1024 bytes/pack=1 bytes/frame=2 bytes/samp=2
Audio extra header: len=91 fcc=0x77617665
MOV: Found MPEG4 audio Elementary Stream Descriptor atom (51)!
ESDS MPEG4 version: 0 flags: 0x000000
ESDS MPEG4 ES Descriptor (34Bytes):

-> ESId: 0
-> streamPriority: 0

ESDS MPEG4 Decoder Config Descriptor (20Bytes):

-> objectTypeId: 64
-> streamType: 0x15
-> bufferSizeDB: 0x001800
-> maxBitrate: 192.000kbit/s
-> avgBitrate: 192.000kbit/s

ESDS MPEG4 Decoder Specific Descriptor (2Bytes)
ESDS MPEG4 Sync Layer Config Descriptor (1Bytes)

-> predefined: 2

Fourcc: mp4a


MOV: Track #1:
MOV: Track header!
tkhd len=84 ver=0 flags=0x0 id=2 dur=85032 lay=0 vol=0
MOV: Edit atom!
MOV: Edit list table (1 entries) (ver:0,flags:0)
MOV: entry#0: duration: 85032 start time: 0 speed: 1.0x
MOV: Media stream!
MOV: Media header!
MOV: Handler header: mhlr/vide (appl) Apple Video Media Handler
MOV: Media info!
MOV: Video header!
MOV: Handler header: dhlr/alis (appl) Apple Alias Data Handler
MOV: unknown chunk: dinf 28
MOV: Sample info!
MOV: Description list! (cnt:1)
MOV: desc #0: avc1 (117 bytes)
MOV: Sample duration table! (4 blocks)
MOV: unknown chunk: ctts 26400
MOV: unknown chunk: cslg 24
MOV: Syncing samples (keyframes) table! (131 entries) (ver:0,flags:0)
MOV: unknown chunk: stps 76
MOV: unknown chunk: sdtp 3403
MOV: Sample->Chunk mapping table! (564 blocks) (ver:0,flags:0)
MOV: Sample size table! (entries=3399 ss=0) (ver:0,flags:0)
MOV: Chunk offset table! (567 chunks)
MOV track #1: 567 chunks, 3399 samples
pts=424737 scale=2997 time=141.721
EL#0: pts=0 1st_sample=0 frames=3399 (141.720s) pts_offs=0
==> Found video stream: 1
MOV: AVC decoder configuration record atom (43)!
MOV: avcC version: 1
MOV: avcC profile: 77
MOV: avcC profile compatibility: 64
MOV: avcC level: 40
MOV: avcC nal length size: 4
MOV: avcC number of sequence param sets: 1
MOV: avcC sps 0 have length 20
MOV: avcC number of picture param sets: 1
MOV: avcC pps 0 have length 4
Image size: 1920 x 816 (24 bpp)
Display size: 1920 x 816
Fourcc: avc1 Codec: 'H.264'


Quicktime Clip Info:
MOV: longest streams: A: #0 (6644 samples) V: #1 (3399 samples)
VIDEO: [avc1] 1920x816 24bpp 23.976 fps 0.0 kbps ( 0.0 kbyte/s)
[V] filefmt:7 fourcc:0x31637661 size:1920x816 fps:23.98 ftime:=0.0417
get_path('sub/') -> 'C:/bin/mplayer/mplayer/sub/'
get_path('default.sub') -> 'C:/bin/mplayer/mplayer/default.sub'
==========================================================================
Opening audio decoder: [faad] AAC (MPEG2/4 Advanced Audio Coding)
dec_audio: Allocating 4608 bytes for input buffer.
dec_audio: Allocating 49152 + 65536 = 114688 bytes for output buffer.
FAAD: Decoder init done (0Bytes)!
FAAD: Negotiated samplerate: 48000Hz channels: 2
FAAD: got 192kbit/s bitrate from MP4 header!
AUDIO: 48000 Hz, 2 ch, s16le, 192.0 kbit/12.50% (ratio: 24000->192000)
Selected audio codec: [faad] afm:faad (FAAD AAC (MPEG2/MPEG4 Audio) decoder)
==========================================================================
<vo_directx><INFO>checking primary surface
<vo_directx><FORMAT PRIMARY>14 BGR32 supported
<vo_directx><INFO>testing supported overlay pixelformats
<vo_directx><FORMAT OVERLAY>0 YV12 supported
<vo_directx><FORMAT OVERLAY>1 I420 not supported
<vo_directx><FORMAT OVERLAY>2 IYUV not supported
<vo_directx><FORMAT OVERLAY>3 YVU9 supported
<vo_directx><FORMAT OVERLAY>4 YUY2 supported
<vo_directx><FORMAT OVERLAY>5 UYVY supported
<vo_directx><FORMAT OVERLAY>6 BGR8 not supported
<vo_directx><FORMAT OVERLAY>7 RGB15 supported
<vo_directx><FORMAT OVERLAY>8 BGR15 supported
<vo_directx><FORMAT OVERLAY>9 RGB16 supported
<vo_directx><FORMAT OVERLAY>10 BGR16 supported
<vo_directx><FORMAT OVERLAY>11 RGB24 not supported
<vo_directx><FORMAT OVERLAY>12 BGR24 not supported
<vo_directx><FORMAT OVERLAY>13 RGB32 supported
<vo_directx><FORMAT OVERLAY>14 BGR32 supported
<vo_directx><INFO>Your card supports 10 of 15 overlayformats
<vo_directx><INFO>hardware supports overlay
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
INFO: libavcodec init OK!
Selected video codec: [ffh264] vfm:ffmpeg (FFmpeg H.264)
==========================================================================
Checking audio filter chain for 48000Hz/2ch/s16le -> 48000Hz/2ch/s16le...
[libaf] Adding filter dummy
[dummy] Was reinitialized: 48000Hz/2ch/s16le
AF_pre: 48000Hz/2ch/s16le
ao_dsound: Output Devices:
0 Primary Sound Driver <--
1 Realtek AC97 Audio
ao_dsound: DirectSound? initialized
ao_dsound: Samplerate:48000Hz Channels:2 Format:s16le
ao_dsound: Buffersize:192000 bytes (1000 msec)
ao_dsound: primary buffer created
ao_dsound: secondary (stream)buffer created
AO: [dsound] 48000Hz 2ch s16le (2 bps)
AO: Description: Windows DirectSound? audio output
AO: Author: Gabor Szecsi <deje@…>
Building audio filter chain for 48000Hz/2ch/s16le -> 48000Hz/2ch/s16le...
[dummy] Was reinitialized: 48000Hz/2ch/s16le
[dummy] Was reinitialized: 48000Hz/2ch/s16le
Starting playback...
[ffmpeg] aspect_ratio: 0.000000
VDec: vo config request - 1920 x 816 (preferred csp: Planar YV12)
Trying filter chain: vo
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is undefined - no prescaling applied.
VO Config (1920x816->1920x816,flags=0,'MPlayer',0x32315659)
VO: [directx] 1920x816 => 1920x816 Planar YV12
VO: Description: Directx DDraw YUV/RGB/BGR renderer
VO: Author: Sascha Sommer <saschasommer@…>
<vo_directx><INFO>overlay with format YV12 created
* [vo] Exporting mp_image_t, 1920x816x12bpp YUV planar, 2350080 bytes
Unicode font: 1418 glyphs.
Uninit audio filters...
[libaf] Removing filter dummy
uninit audio: faad
FAAD: Closing decoder!
uninit video: ffmpeg
WINSOCK2 uninit
ao_dsound: DirectSound? uninitialized

Exiting... (Quit)

--- Errors Printed ---

[h264 @ 009E3CB8]concealing 4896 DC, 4896 AC, 4896 MV errors
[h264 @ 009E3CB8]concealing 4896 DC, 4896 AC, 4896 MV errors
[h264 @ 009E3CB8]concealing 4896 DC, 4896 AC, 4896 MV errors
[h264 @ 009E3CB8]concealing 4896 DC, 4896 AC, 4896 MV errors
[h264 @ 009E3CB8]concealing 4896 DC, 4896 AC, 4896 MV errors
[h264 @ 009E3CB8]concealing 4896 DC, 4896 AC, 4896 MV errors
[h264 @ 009E3CB8]concealing 4896 DC, 4896 AC, 4896 MV errors
[h264 @ 009E3CB8]concealing 4896 DC, 4896 AC, 4896 MV errors
[h264 @ 009E3CB8]illegal short term buffer state detected
[h264 @ 009E3CB8]concealing 4896 DC, 4896 AC, 4896 MV errors
[h264 @ 009E3CB8]concealing 4896 DC, 4896 AC, 4896 MV errors
[h264 @ 009E3CB8]concealing 4896 DC, 4896 AC, 4896 MV errors
[h264 @ 009E3CB8]illegal short term buffer state detected
[h264 @ 009E3CB8]concealing 4896 DC, 4896 AC, 4896 MV errors
[h264 @ 009E3CB8]concealing 4896 DC, 4896 AC, 4896 MV errors
[h264 @ 009E3CB8]illegal short term buffer state detected
[h264 @ 009E3CB8]illegal short term buffer state detected
[h264 @ 009E3CB8]concealing 4896 DC, 4896 AC, 4896 MV errors
[h264 @ 009E3CB8]concealing 4896 DC, 4896 AC, 4896 MV errors
[h264 @ 009E3CB8]illegal short term buffer state detected
[h264 @ 009E3CB8]illegal short term buffer state detected
[h264 @ 009E3CB8]concealing 4896 DC, 4896 AC, 4896 MV errors
[h264 @ 009E3CB8]concealing 4896 DC, 4896 AC, 4896 MV errors
[h264 @ 009E3CB8]illegal short term buffer state detected
[h264 @ 009E3CB8]illegal short term buffer state detected
[h264 @ 009E3CB8]concealing 4896 DC, 4896 AC, 4896 MV errors
[h264 @ 009E3CB8]concealing 4896 DC, 4896 AC, 4896 MV errors
[h264 @ 009E3CB8]illegal short term buffer state detected
[h264 @ 009E3CB8]illegal short term buffer state detected
[h264 @ 009E3CB8]concealing 4896 DC, 4896 AC, 4896 MV errors
[h264 @ 009E3CB8]concealing 4896 DC, 4896 AC, 4896 MV errors
[h264 @ 009E3CB8]illegal short term buffer state detected
[h264 @ 009E3CB8]concealing 4896 DC, 4896 AC, 4896 MV errors
[h264 @ 009E3CB8]concealing 4896 DC, 4896 AC, 4896 MV errors
[h264 @ 009E3CB8]concealing 4896 DC, 4896 AC, 4896 MV errors
[h264 @ 009E3CB8]concealing 4896 DC, 4896 AC, 4896 MV errors
[h264 @ 009E3CB8]illegal short term buffer state detected
[h264 @ 009E3CB8]concealing 4896 DC, 4896 AC, 4896 MV errors
[h264 @ 009E3CB8]concealing 4896 DC, 4896 AC, 4896 MV errors
[h264 @ 009E3CB8]concealing 4896 DC, 4896 AC, 4896 MV errors
[h264 @ 009E3CB8]concealing 4896 DC, 4896 AC, 4896 MV errors
[h264 @ 009E3CB8]concealing 4896 DC, 4896 AC, 4896 MV errors
[h264 @ 009E3CB8]concealing 4896 DC, 4896 AC, 4896 MV errors
[h264 @ 009E3CB8]concealing 4896 DC, 4896 AC, 4896 MV errors
...continues...

Well, there is my first bugreport for mplayer. I have some experience with
Mozilla's Bugzilla, but please forgive me if I missed some information. Thanks!

Change History (7)

comment:1 Changed 14 years ago by ariel_gonz@…

  • Component changed from vo to libavcodec
  • Keywords FFmpeg added; MPlayer removed
  • Owner changed from alex@… to diego@…
  • product changed from MPlayer to FFmpeg
  • Version changed from 1.0pre7 to unspecified

comment:2 Changed 14 years ago by diego@…

  • Status changed from new to assigned

Does this happen with latest CVS as well? There were some fixes since pre7.

comment:3 Changed 14 years ago by ariel_gonz@…

Apologies for not answering sooner...

Tested with the May 6, 2005 build from http://oss.netfarm.it/mplayer-win32.php
without any extra plugins. The visual artifacts are "different" but still there.
The error address (??) has changed in the error messages, but the content is the
same:

[h264 @ 008F9BC8]concealing 4896 DC, 4896 AC, 4896 MV errors
[h264 @ 008F9BC8]illegal short term buffer state detected

comment:4 Changed 14 years ago by diego@…

There have been fixes since May 6. Try out _latest_ CVS.

comment:5 Changed 14 years ago by diego@…

  • Cc diego@… added
  • Owner changed from diego@… to lorenm@…
  • Status changed from assigned to new

Loren, I'm assigning this to you as you are the local H.264 guru.

comment:6 Changed 14 years ago by lorenm@…

  • Resolution set to worksforme
  • Status changed from new to closed

Plays correctly with MPlayer dev-CVS-050512-09:00 on an Athlon-XP and an Opteron.
Also plays correctly with
http://oss.netfarm.it/mplayer/builds/mplayer-k7-cvs-20050506.zip under Wine.
The relevant fix was applied on May 3.

comment:7 Changed 14 years ago by ariel_gonz@…

  • Summary changed from [h264 @ 009E3CB8] Errors with QuickTime H.264 to Framedrop errors in H.264

Well, after playing around with the config file trying to figure out what could
be causing this, since its WFM for you guys, I discovered that the cause is that
I had framedropping active (framedrop=yes) in the config file.

Removing that line took care of the visual artifacts, as well as the error
messages. So this bug is WFM as well. I'm also changing the summary. Thanks!

Note: See TracTickets for help on using tickets.