Opened 14 years ago

Closed 12 years ago

#301 closed defect (duplicate)

id_length is always zero for realmedia videos containing multiple streams

Reported by: sannie@… Owned by: r_togni@…
Priority: normal Component: demuxer
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

When using -identify to display the length of a locally stored realmedia video
containing multiple streams id_length is always zero. The video itself plays fine.

(Multiple streaming within a video are defined as 'audiences' in the helix
producer. They are used to store multiple streams with different bitrates within
one .rm file.)

When adding the -vid 0 parameter to select a stream from the video file the
id_length value stays zero.

The last mplayer version I've tested this bug on dev-CVS-050518-19:45-3.3.6 .

I've uploaded an example video which can be downloaded from:
http://w00tah.dyndns.org/~kman/multiple_stream_test.rm. Please be aware that
this file is served on a plain and simple webserver so don't expect any fancy
streaming magic :)

Attachments (1)

dur_hack.diff (733 bytes) - added by reimar 14 years ago.
More a hack than a fix, but please try anyway

Download all attachments as: .zip

Change History (10)

comment:1 Changed 14 years ago by sannie@…

  • Component changed from demuxer to vo

It is also impossible to seek in the realmedia video with multiple streams,
while with the same movie with a single stream the seek function works.

Changed 14 years ago by reimar

More a hack than a fix, but please try anyway

comment:2 Changed 14 years ago by reimar

comment:3 Changed 14 years ago by gamester17@…

any updates on this one?

comment:4 Changed 14 years ago by gamester17@…

Adding search keywords (for people searching for RealMedia? bugs/issues): Real,
RealNetworks? RealPlayer?, RealVideo?, RealAudio?, RM, RAM, RA, RV, RMVB, live,
live.com

comment:5 Changed 14 years ago by gamester17@…

Does this "Real demuxer audio cleanup" patch help this issue?:
http://thread.gmane.org/gmane.comp.video.mplayer.devel/30307

comment:6 Changed 13 years ago by diego@…

  • Component changed from vo to demuxer
  • Owner changed from moritz@… to r_togni@…

comment:7 Changed 13 years ago by gamester17@…

Has this hack/fix (or other) been implemented in MPlayer's public CVS yet?

comment:8 Changed 13 years ago by r_togni@…

No idea, test it and report :)

comment:9 Changed 12 years ago by compn

  • Resolution set to duplicate
  • Status changed from new to closed

moving all id_length bugs to bug 30

* This bug has been marked as a duplicate of bug 30 *

Note: See TracTickets for help on using tickets.