Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#307 closed defect (wontfix)

http stream don't work for NON-INTERLEAVED AVI

Reported by: castet.matthieu@… Owned by: moritz@…
Priority: normal Component: demuxer
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

$mplayer "http://download.blender.org/demo/movies/artintro_final.avi"
MPlayer dev-CVS-050522-22:39-3.3.6 (C) 2000-2005 MPlayer Team
CPU: Advanced Micro Devices Athlon 4 /Athlon MP/XP Palomino (Family: 6, Stepping: 2)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx SSE

85 audio & 193 video codecs
Failed to open /dev/rtc: Permission denied (it should be readable by the user.)
Playing http://download.blender.org/demo/movies/artintro_final.avi.
Resolving download.blender.org for AF_INET...
Connecting to server download.blender.org[194.109.217.141]:80 ...
Cache size set to 320 KBytes
Connected to server: download.blender.org
Cache fill: 0.00% (0 bytes) AVI file format detected.
Resolving download.blender.org for AF_INET...
Connecting to server download.blender.org[194.109.217.141]:80 ...
Resolving download.blender.org for AF_INET...
Connecting to server download.blender.org[194.109.217.141]:80 ...
Detected NON-INTERLEAVED AVI file format.
Resolving download.blender.org for AF_INET...
Connecting to server download.blender.org[194.109.217.141]:80 ...
VIDEO: [DX50] 720x340 24bpp 25.000 fps 2791.6 kbps (340.8 kbyte/s)
==========================================================================
Trying to force audio codec driver family ffmpeg...
Trying to force audio codec driver family ...
Opening audio decoder: [pcm] Uncompressed PCM audio decoder
AUDIO: 44100 Hz, 2 ch, s16le, 1411.2 kbit/100.00% (ratio: 176400->176400)
Selected audio codec: [pcm] afm:pcm (Uncompressed PCM)
==========================================================================
vo: X11 running at 1024x768 with depth 24 and 32 bpp (":0.0" => local display)
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffodivx] vfm:ffmpeg (FFmpeg MPEG-4)
==========================================================================
Checking audio filter chain for 44100Hz/2ch/s16le -> 44100Hz/2ch/s16le...
AF_pre: 44100Hz/2ch/s16le
alsa-init: 1 soundcard found, using: hw:0
alsa: 44100 Hz/2 channels/4 bpf/65536 bytes buffer/Signed 16 bit Little Endian
AO: [alsa] 44100Hz 2ch s16le (2 bps)
Building audio filter chain for 44100Hz/2ch/s16le -> 44100Hz/2ch/s16le...
Starting playback...
VDec: vo config request - 720 x 340 (preferred csp: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 2.12:1 - prescaling to correct movie aspect.
VO: [xv] 720x340 => 720x340 Planar YV12
Resolving download.blender.org for AF_INET... 1 ??% ??% ??,?% 0 0 1%
Connecting to server download.blender.org[194.109.217.141]:80 ...
Resolving download.blender.org for AF_INET... 2 ??% ??% ??,?% 1 0 1%
Connecting to server download.blender.org[194.109.217.141]:80 ...
alsa-play: xrun of at least 295.618 msecs. resetting stream
Resolving download.blender.org for AF_INET...
Connecting to server download.blender.org[194.109.217.141]:80 ...
Resolving download.blender.org for AF_INET... 3 ??% ??% ??,?% 2 0 1%
Connecting to server download.blender.org[194.109.217.141]:80 ...
alsa-play: xrun of at least 443.774 msecs. resetting stream
Resolving download.blender.org for AF_INET...
Connecting to server download.blender.org[194.109.217.141]:80 ...
Resolving download.blender.org for AF_INET... 4 ??% ??% ??,?% 3 0 1%
Connecting to server download.blender.org[194.109.217.141]:80 ...
alsa-play: xrun of at least 300.114 msecs. resetting stream
Resolving download.blender.org for AF_INET...
Connecting to server download.blender.org[194.109.217.141]:80 ...
Resolving download.blender.org for AF_INET... 5 ??% ??% ??,?% 4 0 1%
Connecting to server download.blender.org[194.109.217.141]:80 ...
alsa-play: xrun of at least 441.875 msecs. resetting stream
Resolving download.blender.org for AF_INET...
Connecting to server download.blender.org[194.109.217.141]:80 ...
Resolving download.blender.org for AF_INET... 6 ??% ??% ??,?% 5 0 1%
Connecting to server download.blender.org[194.109.217.141]:80 ...
alsa-play: xrun of at least 372.087 msecs. resetting stream
Resolving download.blender.org for AF_INET...
Connecting to server download.blender.org[194.109.217.141]:80 ...
Resolving download.blender.org for AF_INET... 7 ??% ??% ??,?% 6 0 1%
Connecting to server download.blender.org[194.109.217.141]:80 ...
alsa-play: xrun of at least 598.573 msecs. resetting stream
Resolving download.blender.org for AF_INET...
Connecting to server download.blender.org[194.109.217.141]:80 ...
Resolving download.blender.org for AF_INET... 8 ??% ??% ??,?% 7 0 1%
Connecting to server download.blender.org[194.109.217.141]:80 ...
alsa-play: xrun of at least 349.395 msecs. resetting stream
Resolving download.blender.org for AF_INET...
Connecting to server download.blender.org[194.109.217.141]:80 ...

Change History (1)

comment:1 Changed 14 years ago by reimar

  • Resolution set to wontfix
  • Status changed from new to closed

It does work, it is just slow as hell. Non-interleaved is not suitable for
streaming since audio and video are at different places so you have to do a lot
of seeking. Since most ISP use gigantic queues and caches, seeking simply is
much too slow. Using a really big cache might help, but then you might just as
well download it first...

Note: See TracTickets for help on using tickets.