Opened 14 years ago

Closed 12 years ago

Last modified 11 years ago

#309 closed defect (fixed)

Impossible to use subtitles with comma in the filename

Reported by: wanted@… Owned by: reimar
Priority: normal Component: core
Version: HEAD Severity: normal
Keywords: Cc: ulion2002@…, cben@…
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

mplayer *avi -sub 'subtitles/Grand_bleu,_Le_(1988)-1.pl.srt'

Cannot load subtitles: subtitles/Grand_bleu
Cannot load subtitles: _Le_(1988)-1.pl.srt

The file naming scheme is IMO quite useful, because it matches the titles used
in IMDb. Unfortunately, comma seems to be a builtin separator, and I couldn't
find a way to play such files.

My proposal is to change the default separator to colon ':' (which is contrary
to comma very rarely used in filenames, and on some filesystems it's even
impossible to use), and for backward compatibility add checking in case user
specifies '-sub file1,file2' if these are in fact two files or a one file with
comma in it.

Change History (7)

comment:1 Changed 14 years ago by jagginess@…

I notice something wrong with comma filenames when using
mplayer -ao pcm:file="Musicfilename,01.wav" filename.ogg

when using this, the file name "Musicfilename" gets written to instead of
"Musicfilename,01.wav", I also tried using an escape '\' before the comma.

jagginess

comment:2 Changed 14 years ago by reimar

(In reply to comment #1)

I notice something wrong with comma filenames when using
mplayer -ao pcm:file="Musicfilename,01.wav" filename.ogg

"" and \ escaping is not supported here :-(
With current CVS you can use %20%Musicfilename,01.wav here (see the start of the
man page for a desciption of this syntax

comment:3 Changed 14 years ago by diego@…

  • Owner changed from alex@… to Reimar.Doeffinger@…

comment:4 Changed 14 years ago by reimar

  • Resolution set to fixed
  • Status changed from new to closed

"" escaping should work now with latest CVS.

comment:5 Changed 13 years ago by Zevele@…

  • Resolution fixed deleted
  • Status changed from closed to reopened

(In reply to comment #3)

"" escaping should work now with latest CVS.

I have exactly the same problem, when trying to run:
# mplayer movie.avi -sub "s,ub.srt"
mplayer tries to read two subtitle files s and ub.srt

I also tried s\,ub.srt and 'su,b.srt' :-(

Zeev

comment:6 Changed 12 years ago by ulion2002@…

  • Cc ulion2002@… added
  • Resolution set to fixed
  • Status changed from reopened to closed

(In reply to comment #4)

(In reply to comment #3)

"" escaping should work now with latest CVS.

I have exactly the same problem, when trying to run:
# mplayer movie.avi -sub "s,ub.srt"
mplayer tries to read two subtitle files s and ub.srt

I also tried s\,ub.srt and 'su,b.srt' :-(

Zeev

I think this bug is fixed, you use wrong syntax,
try "s\,ub.srt" or 's\,ub.srt' or s
,ub.srt

comment:7 Changed 11 years ago by compn

  • Cc cben@… added

* Bug 1092 has been marked as a duplicate of this bug. *

Note: See TracTickets for help on using tickets.