Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#310 closed defect (fixed)

Sub display error if the first char is a special char

Reported by: martin.bayard@… Owned by: alex@…
Priority: normal Component: core
Version: 1.0pre7 Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

The problem occurs only with mplayer (not with gmplayer ... thought if was only
a frontend...).

When I play a movie file with "mplayer blabla.avi", it loads blabla.srt and
starts, everything goes fine until the first char of a new line is a special
char (with accent or cdilla), in this case, the special char is dropped to the
end of the line, and the first char becomes a '.'

I tried on a .srt file that had a line starting with "à" to put the "à" at the
end of the previous line, and then it worked perfectly ... I noticed it also
happens with "ç".

Here is my version :
MPlayer 1.0pre7-3.4.3 (C) 2000-2005 MPlayer Team
CPU: Advanced Micro Devices Athlon MP/XP Thoroughbred (Family: 6, Stepping: 1)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0

Attachments (2)

test.srt (217 bytes) - added by martin.bayard@… 14 years ago.
a small subtitle file
log.txt (12.4 KB) - added by martin.bayard@… 14 years ago.
log from mplayer -v test.avi

Download all attachments as: .zip

Change History (8)

Changed 14 years ago by martin.bayard@…

a small subtitle file

comment:1 Changed 14 years ago by martin.bayard@…

Here is a small subtitle file (test.srt) with sample lines that cause the
display bug.

comment:2 Changed 14 years ago by reimar

Works for me with latest CVS. Are using a ttf or a bitmap font? Please provide a
full -v log, too.

comment:3 Changed 14 years ago by martin.bayard@…

(In reply to comment #2)

Works for me with latest CVS. Are using a ttf or a bitmap font? Please provide a
full -v log, too.

Same thing happens with tahoma.ttf or with default provided font. It doesn't
happen with gmplayer btw ...
I attach the log.txt from "mplayer -v toto.avi", hope it helps !

Changed 14 years ago by martin.bayard@…

log from mplayer -v test.avi

comment:4 Changed 14 years ago by martin.bayard@…

comment:5 Changed 14 years ago by martin.bayard@…

Just tested and it works with latest CVS version :)

comment:6 Changed 14 years ago by reimar

  • Resolution set to fixed
  • Status changed from new to closed

I'll assume it was fixed then...

Note: See TracTickets for help on using tickets.