Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#313 closed defect (wontfix)

xv output doesn't work for other applications after mplayer exits

Reported by: nar-nospam-linux@… Owned by: alex@…
Priority: normal Component: vo
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

I'm using Debian sarge on AMD Athlon with a NVidia Geforce 2 MX 400. When I run xawtv using the
xv output device, it works OK. I exit it, then I start the mplayer using the xv output device and it also
works OK. I exit mplayer and start xawtv again, but its window remains blank, just like when an other
application is still using the xv device. However, mplayer works fine if I start it. When I restart the X
server, xawtv works well again. Same happens with other applications using the xv output (e.g. ogle).
This bug wasn't present in mplayer 1.0pre6.

Change History (4)

comment:1 Changed 14 years ago by alex@…

Try out which revision broke.

1, checkout mplayer
2, cvs update -r 1.159 libvo/vo_xv.c
3, compile

pre6 has the revision 1.158 of the file, the current latest one is 1.164. try
out all revisions inbetween, and report which failed.

thanks

comment:2 Changed 14 years ago by alex@…

Sorry, the latest one is 1.168, but 1.167 happend on 06/27, so you need to try
it until 1.166.

But first try latest CVS whether it works or not.

comment:3 Changed 14 years ago by reimar

  • Resolution set to wontfix
  • Status changed from new to closed

This is mostly xawtv's fault, see: http://bugs.gentoo.org/show_bug.cgi?id=96848

comment:4 Changed 14 years ago by nar-nospam-linux@…

I've did a cvs update a couple of days ago and now the problem is gone. There was an xawtv upgrade
too - that might have fixed the problem but I'm not sure, because he problem was also with ogle which
I haven't upgraded, but that problem is also solved.

Note: See TracTickets for help on using tickets.