Opened 13 years ago

Last modified 9 years ago

#317 reopened defect

-vo directx memset(0) buffer problem

Reported by: compn Owned by: saschasommer@…
Priority: normal Component: vo
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

when directx reinit's or plays a second file (even in -fixed-vo) it flashes
green.

Change History (4)

comment:1 Changed 13 years ago by diego@…

  • Owner changed from alex@… to saschasommer@…

comment:2 Changed 13 years ago by saschasommer@…

  • Resolution set to remind
  • Status changed from new to closed

I think the green color you can see is actually the colorkey. When a new file gets opened, the video
device has to be reconfigured. During this reconfiguration all current buffers get destroyed
and the background color is visible. I don't know how to workaround this in the current libvo apart
from maybe using the -colorkey option to set a color more close to black.

comment:3 Changed 11 years ago by compn

  • Resolution remind deleted
  • Status changed from closed to reopened

also when mplayer starts up , the last image played on the overlay gets displayed for a split second...

comment:4 Changed 9 years ago by diogomfranco@…

The mandatory "me too". :)

(In reply to comment #1)

I think the green color you can see is actually the colorkey. When a new file
gets opened, the video
device has to be reconfigured. During this reconfiguration all current buffers
get destroyed
and the background color is visible.

Acceptable with -nofixed-vo, wrong with -fixed-vo since the point of that is to not reinitialize the VO (except maybe on res / AR changes).

Note: See TracTickets for help on using tickets.