Opened 14 years ago

Closed 10 years ago

#333 closed enhancement (fixed)

[REQUEST] DVD-A/DVD-Audio support (16/20/24 bit)

Reported by: gamester17@… Owned by: moritz@…
Priority: normal Component: demuxer
Version: unspecified Severity: minor
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

DVD-Audio (16/20/24 bit) playback/decoder request:

General request for full "DVD-Audio" support on behalf of all your users ;-)
(Note! "DVD-Audio" is aka: "DVD-A").

LPCM != PCM, so hopefully should not be that hard to code, or?
PPCM != PCM, too (I don't know as I'm not a developer/coder)?

VideoLAN VLC plays them but don't think MPlayer do yet?
http://mplayerhq.hu/pipermail/mplayer-dev-eng/2004-October/thread.html#30054

More on the "DVD-Audio" standard ("DVD-A"):
Short description: DVD-A standard as decived by "The Working Group (WG-4)"
supports up to six channel surround sound, and yes it is designed for music,
not video. The surround sound on standard DVD-Video's is in a compressed
format: either Dolby Digital or DTS. These are both 'lossy' forms of
compression in which some of the musical signal (thought to be inaudible,
however audiophiles disagree) is dispensed with in order to realise huge space
savings; but DVD-A use a different encoding technique for its high quality
sound: DVD-A used MLP (Meridian Lossless Packing) which is sometimes also
refered to as PPCM. Note that almost all DVD-A discs are also released with
standard DVD-Video content as well so they'll work in regular DVD players, this
content is a straight copy of the main DVD-A program (which, remember, usually
only has sound and still pictures), the DVD-Video portion usually has its sound
recorded in Dolby Digital or DTS 5.1, this makes most DVD-A discs and be played
on standard DVDs with lower audio quality, although still in surround sound (as
a standard DVD-player will only play the duplicate AC3 or DTS tracks that is
also on the disk, and not the full quality PCM tracks).

PCM – Pulse Code Modulation, the oldest and most commonly employed digital
encoding technique. A sample of the analogue signal is taken many thousands of
times each second, and its level is mapped onto a digital number.

MLP – Meridian Lossless Packing; the digital encoding technique used for DVD
Audio. This is based on the PCM system used for CDs, but uses a higher sampling
frequency (typically 88.2kHz or 96kHz for six channel signals and up to 192kHz
for stereo signals, compared with CD’s 44.1kHz) and greater resolution (up to
24 bits, compared with CD’s 16, yielding 256 times CD’s resolution). It also
employs a special compression technique developed by the British company
Meridian which, unlike Dolby Digital and DTS, preserves the original signal
perfectly.

PPCM – Packed Pulse Code Modulation, another term for MLP.

Free open sourced DVD-Audio Tools, Specs, code and samples available!:
http://dvd-audio.sourceforge.net
http://www.rarewares.org/others.html (LPCM 24bit RAW tools)
http://www.videohelp.com/~jsoto/audiotools.htm (samples and code)

DVD-Audio rippers are available which allows you to create unencrypted backups:
http://forum.doom9.org/showthread.php?t=96860
http://www.rarewares.org/others.html (under DVD Audio tools)

Links to other developer resources (specs, docs, etc.):
http://www.hometheaterhifi.com/volume_8_4/dvd-benchmark-part-6-dvd-audio-11-
2001.html
http://www.hodie-world.com/dvdtech1.html
http://patches.sonic.com/pdf/white-papers/wp_dvd_audio.pdf

PS! Not directly related but indirectly FYI know this:
A few DVDA are protected by The Verance Watermark
Secure Digital Music Initiative (SDMI), SDMI hack:
http://cryptome.org/sdmi-attack.htm
http://www.nanocrew.net/software/SDMI/

Change History (4)

comment:1 Changed 14 years ago by reimar

  • Summary changed from [REQUEST] DVD-A/DVD-Audio support (16/20/24 bit) to [REQUEST] DVD-A/DVD-Audio support (16/20/24 bit)

(In reply to comment #0)

LPCM != PCM, so hopefully should not be that hard to code, or?

LPCM should work fine.

PPCM != PCM, too (I don't know as I'm not a developer/coder)?

VideoLAN VLC plays them but don't think MPlayer do yet?

Are you sure VLC supports PPCM??

http://mplayerhq.hu/pipermail/mplayer-dev-eng/2004-October/thread.html#30054

Huh? What in that thread makes you think it isn't supported? It isn't tested...
Well, MLP isn't supported though, that's true.

sound: DVD-A used MLP (Meridian Lossless Packing) which is sometimes also

It's not lossless, that's nonsense (it is used in those cases where the DVD
transferrate is not enough for raw PCM, so it provides guaranteed compression -
which also means that for some very rare samples it will have to become lossy).
The fact that they are so openly treating their customers as stupid not exactly
motivates me to even try to support it.

DVD-Audio rippers are available which allows you to create unencrypted backups:

They're only WinDVD wrappers AFAICT, unless somebody comes up ith something
better and also releases the source I see little hope of supporting it.

A few DVDA are protected by The Verance Watermark
Secure Digital Music Initiative (SDMI), SDMI hack:

I don't think this is anything we want or need (except for the fact that it
shows the cluelessness of the people in this business and their inability to
admit to it).

comment:2 Changed 14 years ago by dominik@…

* Bug 334 has been marked as a duplicate of this bug. *

comment:3 Changed 14 years ago by gamester17@…

"Bug 333" was meant for the MPlayer-Team and "Bug 333" was meant for the FFmpeg-
Team, I got the impression they used this tracker as well if one
changed 'Product' to "FFmpeg"?, ...don't matter as long as they know about this
request/suggestion and that the general public demand for DVD-A software
support is growing, ...well, especially in North America anyway, checkout
www.amazon.com's stock of DVD-Audio discs, they which ship worldwide if anyones
interested.

PS! I am not 100% sure that VCL supports PPCM as I am not a VideoLan? user
myself, I only read it somewhere and I can't remember where now.

comment:4 Changed 10 years ago by compn

  • Resolution set to fixed
  • Status changed from new to closed

our dvda aka dvdpcm aka lpcm samples work ok
also our mlp samples seem to play with ffmlp now

if you got other samples (ppcm?) please reopen bug and upload or link to them.

Note: See TracTickets for help on using tickets.