Opened 14 years ago

Closed 13 years ago

Last modified 13 years ago

#344 closed defect (duplicate)

crop + resize + expand = bad subtitles

Reported by: sakya_tg@… Owned by: alex@…
Priority: normal Component: vf
Version: 1.0pre7 Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Hello!

Using this commands to encode a DVD 16/9 anamorphic-widescreen (using crop,
resize and expand to put subtitles in the black part at the bottom of the film)
create an avi with subtitles that never been cleared.
Any line of the subtitle goes over the last and they never disappear.

mencoder -dvd-device /dev/dvd -ovc frameno -oac mp3lame -lameopts
br=128:q=9:aq=5:abr:mode=1 -o /home/paolo/tmp/frameno.avi -aid 128 -af
resample=44100:1:2,volume=10:1 -ss 01:00:00 -endpos 00:00:30 dvd://1

mencoder -vf crop=704:416:10:78,scale=640:272,expand=0:-74:0:0:1 -dvd-device
/dev/dvd -sws 2 -lavcopts
vcodec=mpeg4:vqmin=2:vqmax=31:vbitrate=1000:mbd=1:v4mv:lumi_mask=0.07:dark_mask=0.2:scplx_mask=0.1:tcplx_mask=0.1:naq:vpass=1
-slang it -spuaa 4 -subpos 100 -subalign 2 -o /home/paolo/tmp/gbDVDenc.avi -oac
copy -ovc lavc -of avi -ffourcc xvid -ss 01:00:00 -endpos 00:00:30 dvd://1

If I use mplayer with the same -vf option the subtitles are well rendered. :-)

Best regards
Sakya

Change History (2)

comment:1 Changed 14 years ago by sakya_tg@…

Sorry, I forgot:
If I don't use "scale" and "crop" filters the subtitle are OK (but the film is
surely bad!) :-)

Best regards
Sakya

comment:2 Changed 13 years ago by reimar

  • Resolution set to duplicate
  • Status changed from new to closed

Despite the very different use case this is actually the same bug as bug #55,
marking as duplicate due to lack of a better state.

* This bug has been marked as a duplicate of 55 *

Note: See TracTickets for help on using tickets.