Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#368 closed defect (invalid)

change README: you need to configure --with-win32libdir

Reported by: dev@… Owned by: diego@…
Priority: normal Component: DOCS
Version: 1.0pre7 Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

from your all-codecs-package-README:

Put the files contained in this archive in a directory where MPlayer will find
them. The default directory is /usr/local/lib/codecs/ ($prefix/lib/codecs/) if
you are compiling from source, but you can change that value by passing the
'--with-codecsdir' option to './configure'.

not true. I did compile mplayer with ./configure, then put the codecs
to /usr/local/lib/codecs. No effect. Then, I recompiled with explicitely giving
the standard location:
./configure --with-win32libdir=/usr/local/lib/codecs
and it worked. Although there should be no difference. Please change the
README.

Attachments (1)

README.diff (970 bytes) - added by dev@… 15 years ago.
diff to make it understandable

Download all attachments as: .zip

Change History (7)

comment:1 Changed 15 years ago by reimar

Because you have to install the codecs before doing ./configure!
If the readme doesn't explain this it should probably be changed.

comment:2 Changed 15 years ago by dev@…

Finally a qualified answer in a bugzilla! The MPlayer team is best!

comment:3 Changed 15 years ago by diego@…

  • Resolution set to invalid
  • Status changed from new to closed

The README explains it correctly, the order of things is important.

Changed 15 years ago by dev@…

diff to make it understandable

comment:4 Changed 15 years ago by dev@…

This change makes the formulation correct. Please remember, the expression
"codecs" sounds like they will be dynamically linked. Thanks.

comment:5 Changed 15 years ago by reimar

They are not dynamically linked (if they were, they definitly would have to be
available before compiling), they are mmaped.
But MPlayer configure uses the existence of the /usr/local/lib/codecs directory
to decide whether to compile in the interface code for them or not.
So just creating the directory or using the --with-win32libdir option would work
too.

comment:6 Changed 15 years ago by diego@…

--with-win32libdir is not enough, you would need --with-codecsdir in any case...

Note: See TracTickets for help on using tickets.