Opened 14 years ago

Closed 12 years ago

#373 closed enhancement (fixed)

Mid-stream resolution change not honored.

Reported by: bugs@… Owned by: r_togni@…
Priority: normal Component: vd
Version: HEAD Severity: minor
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

If the resolution changes mid-stream, the output image stays at the same
resolution. This occurs as extra pixels when the resolution decreases and lost
pixels when the resolution increases.

I changed the code to always honor the resolution given. After that, the
resolution changes work both ways for me at least with the following commands:

mencoder -ovc lavc -lavcopts vcodec=mpeg4 -scale 512:384
mplayer -vo x11
mplayer -vo xv

The following case appears unaffected by the change:

mencoder -ovc lavc -lavcopts vcodec=mpeg4

I'll add the patch that works for me. It patches against both 1.0pre7try2 and
CVS.

[I marked this as an enhancement since Bug 190 states mid-stream resolution
changes are not officially supported.]

Attachments (1)

mplayer-vo-always-honor-resolution-change-1.0pre7try2-1.patch (835 bytes) - added by bugs@… 14 years ago.
Changes the vd component to always honor resolution changes

Download all attachments as: .zip

Change History (4)

Changed 14 years ago by bugs@…

Changes the vd component to always honor resolution changes

comment:1 Changed 14 years ago by bugs@…

I don't know if this is a good solution in all situations, in case not a
commandline switch could perhaps control whether resolution changes are to be
honored.

comment:2 Changed 12 years ago by compn

please try svn and if there are still problems, upload a sample file.

comment:3 Changed 12 years ago by bugs@…

  • Resolution set to fixed
  • Status changed from new to closed

Sorry for late reply. I'm happy with latest SVN, and I consider this bug fixed.

Note: See TracTickets for help on using tickets.