Opened 14 years ago

Closed 13 years ago

Last modified 13 years ago

#375 closed defect (fixed)

A bug with -audiofile and ogg and some feature suggestions

Reported by: lynx.abraxas@… Owned by: reimar
Priority: important Component: demuxer
Version: 1.0pre7 Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

First of all I want to thank the MPlayer folks for the absolutly great

programmes!
I noticed that since the version pre4 mplayers -audifile option is not working
on my system any more with seperate ogg-audio-files, with pre3 it played
perfectly. Since then I get the fowllowing with:

mplayer foo.avi -audiofile bar.ogg

The audio is played correctly but the viedo is shown like in benchmarking mode.
It's just displaying the pictures without a delay. I could get it to work under
my SuSE with this command:

mplayer foo.avi -audiofile bar.ogg -audio-demuxer 25

This uses the xmms audio demuxer. Under my LFS I don't have xmms and I'd prefer
mplayer to do it on its own. Adding -fps 25 , -audiofile-cache 50 , -ao
oss/alsa or -cache didn't help either.

Secondly I would be interested in how the mplayer normalizer works. What period
is it taking for normalization? Can I influence it?

Lastly I would find it useful if mplayer would be able to use chapter
information of ogm-files like that produced from dvdxchap.
And if possible also instant audio track switching for ogm-files with multipl
audio streams like # does for DVDs.

Thanks a lot
Lynx

Attachments (5)

ogg_audiofile.diff (1.9 KB) - added by reimar 14 years ago.
possible fix
ogg_audiofile.2.diff (1.6 KB) - added by reimar 14 years ago.
fixed patch, without unrelated changes
mplayer.out (5.3 KB) - added by lynx.abraxas@… 13 years ago.
mplayer output
track_03.ogg (671.3 KB) - added by lynx.abraxas@… 13 years ago.
test ogg
vorbis.out (7.7 KB) - added by lynx.abraxas@… 13 years ago.
occurences of vorbis in make output

Download all attachments as: .zip

Change History (20)

Changed 14 years ago by reimar

possible fix

comment:1 Changed 14 years ago by reimar

Please test this patch (extensively). Already submitted to the -dev-eng list.

comment:2 Changed 14 years ago by reimar

  • Owner changed from moritz@… to Reimar.Doeffinger@…
  • Status changed from new to assigned

Changed 14 years ago by reimar

fixed patch, without unrelated changes

comment:3 Changed 14 years ago by reimar

  • attachments.isobsolete changed from 0 to 1

comment:4 Changed 14 years ago by reimar

  • Resolution set to fixed
  • Status changed from assigned to closed

Applied the last patch, so fixed.
For you second question, better ask on the -users list, but it seems to be the
NSAMPLES and MIN_SAMPLE_SIZE defines in af_volnorm.c (I think the algorithm
isn't really good).
For the rest, please open seperate enhancement request bugs if it's not already
there in CVS.

comment:5 Changed 13 years ago by lynx.abraxas@…

  • Resolution fixed deleted
  • Status changed from closed to reopened

Got cvs-mplayer compiled finally. Mplayer works fine but can not play vorbis at
all.

This is with:
mplayer -v /media/cdrom/lord\ of\ the\ rings\ 1.avi -audiofile
/media/cdrom/lotr1.de-4.ogg
==========================================================================
Building audio filter chain for 48000Hz/2ch/s16le -> 0Hz/0ch/??...
[libaf] Adding filter dummy
[dummy] Was reinitialized: 48000Hz/2ch/s16le
[dummy] Was reinitialized: 48000Hz/2ch/s16le
alsa-init: requested format: 48000 Hz, 2 channels, 9
alsa-init: compiled for ALSA-1.0.7
alsa-init: setup for 1/2 channel(s)
alsa-init: 1 soundcard found, using: default
alsa-init: pcm opend in block-mode
alsa-init: chunksize set to 1024
alsa-init: fragcount=16
alsa-init: got buffersize=65536
alsa: 48000 Hz/2 channels/4 bpf/65536 bytes buffer/Signed 16 bit Little Endian
AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
AO: Description: ALSA-0.9.x-1.x audio output
AO: Author: Alex Beregszaszi, Zsolt Barat <joy@…>
AO: Comment: under developement
Building audio filter chain for 48000Hz/2ch/s16le -> 48000Hz/2ch/s16le...
[dummy] Was reinitialized: 48000Hz/2ch/s16le
[dummy] Was reinitialized: 48000Hz/2ch/s16le
Starting playback...
alsa-space: free space = 65536, prepared --

MPlayer interrupted by signal 11 in module: decode_audio

  • MPlayer crashed by bad usage of CPU/FPU/RAM. Recompile MPlayer with --enable-debug and make a 'gdb' backtrace and disassembly. Details in DOCS/HTML/en/bugreports_what.html#bugreports_crash.
  • MPlayer crashed. This shouldn't happen. It can be a bug in the MPlayer code _or_ in your drivers _or_ in your gcc version. If you think it's MPlayer's fault, please read DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and won't help unless you provide this information when reporting a possible bug.

Uninit audio filters...
[libaf] Removing filter dummy
uninit audio: libvorbis
free(): invalid pointer 0x8373d68!

MPlayer interrupted by signal 11 in module: uninit_acodec
uninit video: ffmpeg

MPlayer interrupted by signal 2 in module: uninit_vcodec

comment:6 Changed 13 years ago by reimar

Works still fine for me, please try with -ao oss, or otherwise provide a full
gdb backtrace (or alternatively start MPlayer under valgrind).
Making (part of) the files available might be helpful as well.

Changed 13 years ago by lynx.abraxas@…

mplayer output

comment:7 Changed 13 years ago by lynx.abraxas@…

Changed 13 years ago by lynx.abraxas@…

test ogg

comment:8 Changed 13 years ago by lynx.abraxas@…

comment:9 Changed 13 years ago by lynx.abraxas@…

Tried -ao oss. It's alsa-oss though, but didn't work either. I loaded the output_
and an ogg file up. Mplayer-pre7.2 has no difficulties with it. Both are_
compiled with newes libogg and libvorbis. gdb-trace would take some time, I
don't have it so far.

I couldn't find my enhancement suggestions in the wishlist. Where should I post

enhancement request bugs?

comment:10 Changed 13 years ago by reimar

Oh. Is there a reason you are using libvorbis (instead of internal libtremor)? I
guess that could explain the differences for us.
I will have a look at that later.

comment:11 Changed 13 years ago by lynx.abraxas@…

Well, I did, as told in the docs, install libvorbis an libogg. For compilation I
didn't specify anything special about vorbis. It says:
Checking for OggVorbis? support ... yes (internal Tremor)

Enabled optional drivers:

Input: ftp network tv-v4l edl tv matroska cdda mpdvdkit2 vcd
Codecs: qtx xvid libavcodec.so real xanim dshow/dmo win32 faad2(internal)

libmpeg2 liba52 mp3lib libtheora speex tremor(internal) libmad gif

Audio output: alsa oss sdl mpegpes(file)
Video output: xvidix cvidix sdl vesa gif89a md5sum pnm jpeg png

mpegpes(file) fbdev svga caca aa opengl dga xv x11 xover dfb

When compiling I get vorbis mentioned in: (see attachment)

Is libtremor better? I need libvorbis anyway. What's the difference?

Changed 13 years ago by lynx.abraxas@…

occurences of vorbis in make output

comment:12 Changed 13 years ago by lynx.abraxas@…

comment:13 Changed 13 years ago by reimar

Looks like this isn't the reason. I tried with your sample file, and it still
works fine for me... So I guess I really need a gdb or valgrind log...
bugreports.html should contain everything you need to create one...
libvorbis vs. libtremor: libtremor is a vorbis decoder using integer instead of
floating point operations. If you pass --disable-internal-tremor to configure,
MPlayer should use libvorbis instead.

comment:14 Changed 13 years ago by lynx.abraxas@…

Compiled mplayer with --disable-internal-tremor and it is now working perfectly
with vorbis. (This should be mentioned in the docs as a hint where ogg/Vorbis is
mentioned) Even with -audiofile foo.ogg the video is not benchmarking anymore.
Thanks a lot for the fix!
What is better integer or floating point operations? Why are there two different
libraries?
I have read the bugreport.html and posted my feature requests to the
user-mailinglist some years ago. As they are still not mentioned in the wishlist
nor do they seem to be realiesed I assume they got lost/ignored.
Do You mean I should open a normal bug-report here or send the requests to the
user-list again?

Thanks a lot again!

comment:15 Changed 13 years ago by reimar

  • Resolution set to fixed
  • Status changed from reopened to closed

Original issue seems to be fixed.
Feature requests can be added to bugzilla by setting "severity"
to "enhancement".
Wishlist is not really maintained, you can of course send patches for it if you
want to see something mentioned in it.

Note: See TracTickets for help on using tickets.