Opened 14 years ago

Closed 13 years ago

Last modified 13 years ago

#377 closed defect (wontfix)

Core Dump while transcoding some TiVo TY streams into DivX.

Reported by: bugzilla@… Owned by: moritz@…
Priority: important Component: demuxer
Version: HEAD Severity: critical
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

While transcoding a TiVo? Ty stream (from a UK series 1 TiVo?) into DivX, I get a
core dump. I have been able to successfully transcode most other TY files I've
tried... this problem only affects 1 in 10 or so files. I can successfully play
the file(s) on the TiVo? I extracted them from and I can also play them in
Windows Media Player, using TyShow?.

I was using the following command line to transcode the file:
mencoder file.ty -o file.avi -mc 0 -oac lavc -ovc lavc -lavcopts
vcodec=mpeg4:acodec=mp3:vbitrate=300:keyint=250:vpass=1:turbo -ffourcc DIVX -vop
scale=::::::pal

I've posted the core dump here:
http://www.bluewomble.co.uk/mencoder/bug/mencoder.exe.stackdump

I've posted the 2 pass divx log (if it helps) is here (large):
http://www.bluewomble.co.uk/mencoder/bug/divx2pass.log

If anyone would like me to sent them an exmaple Ty file, let me know and we can
arrange for me to send you a cd/dvd with the file (they are too large to post on
the net ~ 1Gb each) -- you can contact me on bugzilla@…

Finally, here is the command line output:

Ash@bluepower /cygdrive/c/etivo/{Dad's Army}{1970-10-09}{Boots, Boots,
Boots}{UGLD}.bad$ mencoder \{Dad\'s\ Army\}\{1970-10-09\}\{Boots\,\ Boots\,\
Boots\}\{U.ty -o dads.avi -mc 0 -oac lavc -ovc lavc -lavcopts
vcodec=mpeg4:acodec=mp3:vbitrate=300:keyint=250:vpass=1:turbo -ffourcc DIVX -vop
scale=::::::pal
MEncoder dev-CVS-050920-20:50-3.4.4 (C) 2000-2005 MPlayer Team
CPU: Intel Pentium 4/Xeon/Celeron Northwood (Family: 8, Stepping: 4)
Detected cache-line size is 64 bytes
CPUflags: Type: 8 MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled with runtime CPU detection - WARNING - this is not optimal!
To get best performance, recompile MPlayer with --disable-runtime-cpudetection.
success: format: 0 data: 0x0 - 0x39000cca
TiVo? file format detected.
VIDEO: MPEG2 352x576 (aspect 2) 25.000 fps 2600.0 kbps (325.0 kbyte/s)
[V] filefmt:33 fourcc:0x10000002 size:352x576 fps:25.00 ftime:=0.0400
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
AUDIO: 32000 Hz, 2 ch, s16le, 192.0 kbit/18.75% (ratio: 24000->128000)
Selected audio codec: [mp3] afm:mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
Opening video filter: [expand osd=1]
Expand: -1 x -1, -1 ; -1, osd: 1, aspect: 0.000000, round: 1
Opening video filter: [scale presize=pal]
==========================================================================
Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough
VDec: vo config request - 352 x 576 (preferred csp: Mpeg PES)
The selected video_out device is incompatible with this codec.
Also try adding the scale filter, e.g. -vf spp,scale instead of -vf spp.
VDecoder init failed :(
Opening video decoder: [libmpeg2] MPEG 1/2 Video decoder libmpeg2-v0.4.0b
Selected video codec: [mpeg12] vfm:libmpeg2 (MPEG-1 or 2 (libmpeg2))
==========================================================================
Forcing output fourcc to 58564944 [DIVX]
Building audio filter chain for 32000Hz/2ch/s16le -> 0Hz/0ch/??...
Building audio filter chain for 32000Hz/2ch/s16le -> 32000Hz/2ch/s16le...
Writing AVI header...
ODML: Aspect information not (yet?) available or unspecified, not writing vprpeader.
VDec: vo config request - 352 x 576 (preferred csp: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.

SwScaler?: BICUBIC scaler, from Planar YV12 to Planar YV12 using MMX2
videocodec: libavcodec (720x576 fourcc=58564944 [DIVX])
New_Face failed. Maybe the font path is wrong. 0mb A-V:0.000 [0:0]
Please supply the text font file (~/.mplayer/subfont.ttf).
subtitle font: load_sub_face failed.
ODML: Aspect information not (yet?) available or unspecified, not writing vprpeader.

1 duplicate frame(s)!
VDec: vo config request - 480 x 576 (preferred csp: Planar YV12)302:223]]
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
vf.c: have to REALLOCATE buffer memory :(
vf.c: have to REALLOCATE buffer memory :(
Segmentation fault (core dumped) Trem: 7min 170mb A-V:0.000 [302:224]

I'm not sure if I've posted this in the right place... if not, please let me
know and I'll repost elsewhere...
Thanks for your help,
Ash.

Change History (2)

comment:1 Changed 14 years ago by reimar

Can't just make the first few MB of a sample file available? I think MPlayer
should be able to play partial ty files.

comment:2 Changed 13 years ago by reimar

  • Resolution set to wontfix
  • Status changed from new to closed

Not a chance to fix unless we get a sample to fix. Marked "WONTFIX" due to lack
of a better state. Please reopen if a sample is available (samples can be
uploaded to ftp://upload.mplayerhq.hu/MPlayer/incoming).

Note: See TracTickets for help on using tickets.