Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#381 closed defect (invalid)

jerky DVD playback on amd64 + GeForce 6600

Reported by: ivsmplayer@… Owned by: r_togni@…
Priority: normal Component: streaming
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Mplyaer plays DVDs with jerks and pauses (dropped frames?). Xine plays the same
DVDs correctly. Tested on Mandriva 2005 LE and Gentoo 2005.1. Used 1.0pre7 and
the latest CVS versions.

The problem does not depend on DVD drive (tested with DVD-image from HDD --
problem persists) and occures with both "nvidia" and "nv" video drivers.

Using X.org 6.8.2, module XVideo loaded.

Change History (3)

comment:1 Changed 14 years ago by ivsmplayer@…

First word in description should be "Mplayer", of course :) Sorry for typo.

comment:2 Changed 14 years ago by reimar

Please provide a full mplayer -v log. Also, have you tried the -cache option?
How about -vo null? How about -nosound? -srate 44100? -srate 48000? -vfm ffmpeg?
What does the "(dropped frames?)" part mean? There is a dropped frames counter
in the status line, so you can see that (though MPlayer never drops frames
unless you specify -framedrop or -hardframedrop).
And it's MPlayer, not Mplayer.

comment:3 Changed 14 years ago by ivsmplayer@…

  • Resolution set to invalid
  • Status changed from new to closed

Sorry for delay. I've tested it a little bit -- it really looks like
sound-related problem. At least, -nosound gives very smooth playback without any
jerks.

I used ALSA compiled in kernel (not as module), now recompiled kernel to set up
ALSA as module. It partly helped -- now playback with sound is nearly OK, but
not so smooth as in Xine. I'll try to manage it by tweaking ALSA.

Closing this.

Thanks a lot!

Note: See TracTickets for help on using tickets.