Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#387 closed defect (wontfix)

Mencoder cannot take a screenshot, -vo jpeg

Reported by: ryes540@… Owned by: alex@…
Priority: important Component: ve
Version: HEAD Severity: major
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Mencoder cannot take a screenshot like MPlayer can with mplayer -vo jpeg -
nosound -frames 1. Should add this feature to Mencoder too since many people
encode a video with Mencoder and then need a thumbnail. Plus it makes sense
since Mencoder encodes to different formats, why not a JPEG image?

Change History (2)

comment:1 Changed 14 years ago by reimar

  • Resolution set to wontfix
  • Status changed from new to closed

Because jpeg is an image format, and mencoder is for movies. It can't even
handle audio-only properly.
-ovc mjpeg -of rawvideo might give you a jpeg image, but I'm not sure about
that.
Unless somebody finds a non-hackish way to implement this in mencoder, this
won't be changed.

comment:2 Changed 14 years ago by reimar

Actually,
mencoder -nosound -mc 0 -noskip -ovc lavc -lavcopts vcodec=mjpeg -of rawvideo -
frames 1 -o test.jpg file.avi
seems to produce a valid JPEG file.

Note: See TracTickets for help on using tickets.