Opened 14 years ago

Closed 9 years ago

#393 closed defect (wontfix)

Native mov demuxer causes artefacts in H.264 decode (no error messages though)

Reported by: hanno@… Owned by: reimar
Priority: normal Component: vd
Version: HEAD Severity: normal
Keywords: Cc: dominik@…
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

As subject says, this video, on current cvs (confirmed by at least one other
user on the mplayer-users-ml):
http://images.apple.com/movies/us/hd_gallery/gl1800/480p/BBCMG_Andes-r2_480p.mov

Change History (10)

comment:1 Changed 14 years ago by reimar

And as Loren Merrit stated in Message-ID: <Pine.A41.4.63a.0510202109300.
221352@…>, the reference decoder does not play it either,
so a broken encoder is to blame.

comment:2 Changed 14 years ago by hanno@…

Well, to cite the ffmpeg-hp (and I always thought this is the development
agenda of mplayer also):
"Many open source multimedia playback applications have been specifically tuned
to play all manner of multimedia files, no matter how incomplete or broken."

comment:3 Changed 14 years ago by reimar

I did not set it to WONTFIX, so nothing to complain. But that the stream is
broken and not our decoder is an important fact.

comment:4 Changed 14 years ago by dominik@…

  • Cc dominik@… added

The file is no longer available so I can't verify if it works with current CVS
or not. Any other samples?

comment:5 Changed 13 years ago by reimar

The link still works for me. But it still didn't work 2 weeks or so ago.

comment:6 Changed 10 years ago by compn

  • Resolution set to worksforme
  • Status changed from new to closed

hah! the url still works
and magically the video now works in mplayer!

closing bug!

comment:7 Changed 10 years ago by compn

oops, it always worked

still has artifacts, nevermind

comment:8 Changed 10 years ago by compn

  • Resolution worksforme deleted
  • Status changed from closed to reopened

oops, it always worked

still has artifacts, nevermind

comment:9 Changed 9 years ago by compn

  • Owner changed from r_togni@… to reimar

comment:10 Changed 9 years ago by reimar

  • Resolution set to wontfix
  • Status changed from reopened to closed
  • Summary changed from H264 video produces fractals and wrong colors to Native mov demuxer causes artefacts in H.264 decode (no error messages though)

This is actually some bug in the native mov demuxer, since the switch to -demuxer lavf it works.
Setting to WONTFIX since the native mov demuxer isn't really maintained anymore

Note: See TracTickets for help on using tickets.