Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#399 closed defect (worksforme)

crash playing H.264 after Unknown NAL code: 12

Reported by: mplayer-bugs@… Owned by: alex@…
Priority: normal Component: vd
Version: 1.0pre7 Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

mplayer crashes when I ask it to play a raw H.264 transport stream from my
Tandberg 5930 hardware encoder.

VDec: vo config request - 544 x 480 (preferred csp: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.37:1 - prescaling to correct movie aspect.
VO: [xv] 544x480 => 660x480 Planar YV12
[h264 @ 0x85fb420]Unknown NAL code: 12
mplayer: h264.c:3164: fill_default_ref_list: Assertion `best_i != -1' failed.

MPlayer interrupted by signal 6 in module: decode_video

  • MPlayer crashed. This shouldn't happen.

If it turns out that the NAL code 12 is the problem then I offer this explanation:

When you encounter filler data you can expect the following:

00 00 01 0c (ff)* 80

Basically, a metric buttload of ff bytes followed by an 80. Of course, you

can save yourself some stress and just search for the next 00 00 01 NAL unit
start code.

I'm not surprised you don't handle filler. It only appears in

constant-bit-rate video which is foolish for computer movie files.
Unfortunately, this type of video is ubiquitous in the television broadcast
industry (cable, satellite).

Attachments (1)

h264.mpeg (900.0 KB) - added by mplayer-bugs@… 14 years ago.
a raw H.264 stream from a Tandberg 5930

Download all attachments as: .zip

Change History (4)

comment:1 Changed 14 years ago by reimar

  • Component changed from vo to vd

Please provide a sample file otherwise we can't fix it. Also please try CVS,
pre7 is very old.

Changed 14 years ago by mplayer-bugs@…

a raw H.264 stream from a Tandberg 5930

comment:2 Changed 14 years ago by mplayer-bugs@…

This is the first 900k of a 26M transport stream. You should find 34
renderable frames. The stream is "raw" (it does not begin or end cleanly). It
triggers the crash the same as the full 26M file.

comment:3 Changed 14 years ago by reimar

  • Resolution set to worksforme
  • Status changed from new to closed

Plays fine for me using latest CVS, though I get only 27 frames.

Note: See TracTickets for help on using tickets.