Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#40 closed defect (fixed)

GMplayer error handling problem from alsa.

Reported by: Frankablu@… Owned by: alex@…
Priority: normal Component: vo
Version: HEAD Severity: normal
Keywords: Cc: reimar
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Note to OP please move to correct section
OS Info:
Linux 2.6.6-1.435.2.3 (Fedora Core 2)
libc-2.3.3
gcc 3.3.3
ld 2.15.90
as 2.15.90

GUI-Bug only

When playing video using the alsa plugin I recieve (spammed with) the following
error message:

alsa-control: mixer attach /dev/mixer error: No such file or directory

The console output is:
ALSA lib control.c:654:(snd_ctl_open_noupdate) Invalid CTL /dev/mixer
alsa-control: mixer attach /dev/mixer error: No such file or directory

My /dev/mixer doesn't work due a bug in my alsa driver. I have however found
someone else who's /dev/mixer does work (who is running redhat 9) and is also
receiving the same problem.

The problem is probaility in the alsa driver however gmplayer still plays the
video/music file however is unusable due to the error message taking focus by
rapidly opening and closing preventing the menu from being used.

Using mplayer gives the following output and works without problems:

==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
MP3lib: init layer2&3 finished, tables done
AUDIO: 44100 Hz, 2 ch, 16 bit (0x10), ratio: 16000->176400 (128.0 kbit)
Selected audio codec: [mp3] afm:mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
Checking audio filter chain for 44100Hz/2ch/16bit -> 44100Hz/2ch/16bit...
AF_pre: af format: 2 bps, 2 ch, 44100 hz, little endian signed int
AF_pre: 44100Hz 2ch Signed 16-bit (Little-Endian)
audio_setup: Can't open audio device /dev/dsp: No such device
alsa-init: got device=0, subdevice=0
alsa-init: 1 soundcard found, using: default
alsa: 44100 Hz/2 channels/4 bpf/57364 bytes buffer/Signed 16 bit Little Endian
AO: [alsa] 44100Hz 2ch Signed 16-bit (Little-Endian) (2 bps)
Building audio filter chain for 44100Hz/2ch/16bit -> 44100Hz/2ch/16bit...
Video: no video
Starting playback...

Change History (3)

comment:1 Changed 15 years ago by ebulgroz@…

Solution is on dev-eng:
http://mplayerhq.hu/pipermail/mplayer-dev-eng/2004-July/027206.html
somebody needs to apply patch to cvs though

comment:2 Changed 15 years ago by reimar

  • Cc Reimar.Doeffinger@… added

Please test the patch at
http://mplayerhq.hu/pipermail/mplayer-dev-eng/2004-July/027584.html. It also
adds an options dialog for alsa.

comment:3 Changed 15 years ago by reimar

  • Resolution set to fixed
  • Status changed from new to closed

I committed my patch, although I would have really liked it if somebody had
tested it before.

Note: See TracTickets for help on using tickets.