Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#412 closed defect (fixed)

mplayer has trouble playing h264 encoded mp4 file

Reported by: wbaker+mp@… Owned by: alex@…
Priority: normal Component: core
Version: 1.0pre7 Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Downloaded an mp4 file encoded in h264 and when I tried to play it I got the
following output:


Using GNU internationalization
Original domain: messages
Original dirname: /usr/share/locale
Current domain: mplayer
Current dirname: /usr/share/locale

MPlayer 1.0pre7-4.0.0 (C) 2000-2005 MPlayer Team
CPU: Advanced Micro Devices Athlon Thunderbird (Family: 6, Stepping: 2)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 0 SSE2: 0

Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup
scripts.
Opening joystick device /dev/input/js0
Can't open joystick device /dev/input/js0 : No such file or directory
Can't init input joystick
Setting up LIRC support...
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support.
You will not be able to use your remote control.
Playing <file>.mp4
QuickTime?/MOV file format detected.


MOV track #0: 3168 chunks, 35619 samples
MOV: AVC decoder configuration record atom (47)!
MOV: Found unknown movie atom btrt (20)!
Image size: 640 x 480 (24 bpp)
Display size: 640 x 480
Fourcc: avc1 Codec:


MOV track #1: 2967 chunks, 68229 samples
Audio bits: 16 chans: 2 rate: 48000
MOV: Found MPEG4 audio Elementary Stream Descriptor atom (39)!
Fourcc: mp4a


MOV: longest streams: A: #1 (68229 samples) V: #0 (35619 samples)
VIDEO: [avc1] 640x480 24bpp 23.976 fps 0.0 kbps ( 0.0 kbyte/s)
==========================================================================
Opening audio decoder: [faad] AAC (MPEG2/4 Advanced Audio Coding)
AUDIO: 48000 Hz, 2 ch, s16le, 128.0 kbit/8.33% (ratio: 15996->192000)
Selected audio codec: [faad] afm:faad (FAAD AAC (MPEG2/MPEG4 Audio) decoder)
==========================================================================
vo: X11 running at 1600x1200 with depth 24 and 32 bpp (":0.0" => local display)
vo_xvmc: X-Video extension 2.2
vo_xvmc: No X-Video MotionCompensation? Extension on :0.0
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffh264] vfm:ffmpeg (FFmpeg H.264)
==========================================================================
Checking audio filter chain for 48000Hz/2ch/s16le -> 48000Hz/2ch/s16le...
AF_pre: 48000Hz/2ch/s16le
AO: [oss] 48000Hz 2ch s16le (2 bps)
Building audio filter chain for 48000Hz/2ch/s16le -> 48000Hz/2ch/s16le...
Starting playback...
[h264 @ 0x85b9cb0]QP 57 out of range
Error while decoding frame!
mplayer: h264.c:2306: mc_dir_part: Assertion `pic->data[0]' failed.

MPlayer interrupted by signal 6 in module: decode_video


I am running Fedora Core 4 on an Athlon Thunderbird 600MHz with 256MB RAM. The
version of mplayer is 1.0-0.16.pre7.2 and it was downloaded from freshrpms.net.

The version of ffmpeg I'm using is 0.4.9-0.2.20050427.2, and was also

downloaded from freshrpms.net.

Change History (2)

comment:1 Changed 14 years ago by reimar

pre7 is too old for most H.264 content, please use CVS.
And if you use prebuilt packages, please use the official ones from http://rpm.
greysector.net/mplayer/ unless you have a very good reason not to.

comment:2 Changed 14 years ago by wbaker+mp@…

  • Resolution set to fixed
  • Status changed from new to closed

That worked perfectly! Thanks.

Just to repeat the URL because it wrapped:

http://rpm.greysector.net/mplayer/

Note: See TracTickets for help on using tickets.