Opened 13 years ago

Closed 12 years ago

Last modified 12 years ago

#417 closed defect (worksforme)

Choppy playback of DVDs and large videos

Reported by: sjm@… Owned by: alex@…
Priority: normal Component: vo
Version: 1.0pre7 Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Watching normal sized videos is OK but still seems somewhat "not right" (I would
put this down to placebo effect if I hadn't thought it before watching a DVD)
but watching large videos and DVDs is a no-go. The xv driver is extremely choppy
(lots of image tearing) and the x11 driver is less choppy but has a weird aspect
ratio bug whereby the window itself is 16:9 but the image is 4:3 with
transparent borders down the side. The sound seems to stay largely in sync with
the video.

I have an AMD64 3200+ with 1GB of RAM so that shouldn't be a problem. I don't
experience this problem under Linux and the OpenBSD Ogle port plays DVDs fine.

MPlayer 1.0pre7-3.3.5 (C) 2000-2005 MPlayer Team
CPU: Advanced Micro Devices (Family: 8, Stepping: 0)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 1
Compiled with runtime CPU detection - WARNING - this is not optimal!
To get best performance, recompile MPlayer with --disable-runtime-cpudetection.

Playing dvd://1.
Reading disc structure, please wait...
There are 28 titles on this DVD.
There are 28 chapters in this DVD title.
There are 1 angles in this DVD title.
DVD successfully opened.
Selected DVD audio channel: 128 language: en
MPEG-PS file format detected.
VIDEO: MPEG2 720x480 (aspect 3) 29.970 fps 9800.0 kbps (1225.0 kbyte/s)
==========================================================================
Opening audio decoder: [liba52] AC3 decoding with liba52
Using SSE optimized IMDCT transform
AC3: 5.1 (3f+2r+lfe) 48000 Hz 448.0 kbit/s
Using MMX optimized resampler
AUDIO: 48000 Hz, 2 ch, s16le, 448.0 kbit/29.17% (ratio: 56000->192000)
Selected audio codec: [a52] afm:liba52 (AC3-liba52)
==========================================================================
vo: X11 running at 1280x1024 with depth 16 and 16 bpp (":0.0" => local display)
==========================================================================
Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough
VDec: vo config request - 720 x 480 (preferred csp: Mpeg PES)
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
The selected video_out device is incompatible with this codec.
VDecoder init failed :(
Opening video decoder: [libmpeg2] MPEG 1/2 Video decoder libmpeg2-v0.4.0b
Selected video codec: [mpeg12] vfm:libmpeg2 (MPEG-1 or 2 (libmpeg2))
==========================================================================
Checking audio filter chain for 48000Hz/2ch/s16le -> 48000Hz/2ch/s16le...
AF_pre: 48000Hz/2ch/s16le
ao2: 48000 Hz 2 chans s16le [0x9]
AO: [sun] 48000Hz 2ch s16le (2 bps)
Building audio filter chain for 48000Hz/2ch/s16le -> 48000Hz/2ch/s16le...
Starting playback...
VDec: vo config request - 720 x 480 (preferred csp: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
VO: [xv] 720x480 => 854x480 Planar YV12
New_Face failed. Maybe the font path is wrong. 2 ??% ??% ??,?% 0 0
Please supply the text font file (~/.mplayer/subfont.ttf).
subtitle font: load_sub_face failed.
A: 2.7 V: 2.7 A-V: 0.023 ct: 0.082 81/ 78 3% 5% 25.6% 1 0
demux_mpg: 24000/1001fps progressive NTSC content detected, switching framerate.
A: 15.1 V: 15.1 A-V: 0.028 ct: 0.117 379/376 5% 17% 30.2% 1 0
Exiting... (Quit)

Attachments (1)

Xorg.0.log (39.4 KB) - added by sjm@… 13 years ago.
Xorg.0.log

Download all attachments as: .zip

Change History (3)

Changed 13 years ago by sjm@…

Xorg.0.log

comment:1 Changed 13 years ago by sjm@…

comment:2 Changed 12 years ago by reimar

  • Resolution set to worksforme
  • Status changed from new to closed

xv problem seems a driver bug, nothing we can do (unless it's just that vsync
attribute was not enabled, then it should be fixed). Reopen if you have any
indication this actually is a MPlayer bug.
Problem with -vo x11 can be avoided by -zoom, which is slow though since it
uses CPU to scale to correct aspect.

Note: See TracTickets for help on using tickets.