Opened 14 years ago

Closed 9 years ago

#426 closed defect (wontfix)

Speex + Theora desynchronization

Reported by: nicolas.george@… Owned by: reimar
Priority: normal Component: ad
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

I have got a class of Ogg files with Theora video and Speex audio, on which
MPlayer (CVS from 2005-12-18, nothing around Speex nor Theora changed since) has
a strange behavior:

  • playing with -nosound is just fine;
  • playing with -novideo is just fine;
  • starting a mplayer -nosound and a mplayer -novideo at the same time gives a

reasonable synchro;

  • playing the file with VLC is just fine;
  • BUT smplpy playing with mplayer gives a complete audio-video desync (the audio

seems to have the correct rythm, the video is too fast), and sometimes "your
system is too slow".

The status line of mplayer when playing displays:
A: inf V: 12.4 A-V: inf ct: 1.236 104/104 0% 0% 0.4% 0 0
Obviously, there is something wrong with the audio timing.

I will try to attach a sample file.

Regards,

--

Nicolas George

Attachments (1)

testcase.ogg (95.8 KB) - added by nicolas.george@… 14 years ago.
Ogg file showing the problem

Download all attachments as: .zip

Change History (4)

Changed 14 years ago by nicolas.george@…

Ogg file showing the problem

comment:1 Changed 14 years ago by nicolas.george@…

A rectangular bar that grows and shrinks, and beeps. The beeps should be in
sync with the bar being full or empty.

comment:2 Changed 9 years ago by compn

  • Owner changed from alex@… to reimar

comment:3 Changed 9 years ago by reimar

  • Resolution set to wontfix
  • Status changed from new to closed

It works with -demuxer lavf which is the default.
-demuxer ogg also work as long as no seeking is done, but beyond that it will not be fixed, because honestly the Ogg format is such an idiotic and painful design that I refuse to make more than a minimal effort to support it.

Note: See TracTickets for help on using tickets.